summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorClemmitt Sigler2022-12-03 16:35:55 -0500
committerClemmitt Sigler2022-12-03 16:35:55 -0500
commite37c4681af9fdf2c8068ecd37d595e883f3e9c68 (patch)
tree4d293eed68feca22184b44a404c71e4b09c98e45
downloadaur-e37c4681af9fdf2c8068ecd37d595e883f3e9c68.tar.gz
Initial pkg submission
-rw-r--r--.SRCINFO23
-rw-r--r--AGG-2.6-Anti-Grain-Geometry-Public-License.txt8
-rw-r--r--AGG-2.6-Modified-BSD-License.txt32
-rw-r--r--PKGBUILD54
4 files changed, 117 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b2df138a1b74
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = agg-2.6-git
+ pkgdesc = High Quality Rendering Engine for C++
+ pkgver = 2.6
+ pkgrel = 1
+ url = https://github.com/ghaerr/agg-2.6
+ arch = x86_64
+ license = BSD
+ license = custom:Anti-Grain Geometry Public License
+ makedepends = git
+ depends = gcc-libs
+ depends = sdl
+ depends = freetype2
+ provides = agg
+ conflicts = agg
+ replaces = antigrain
+ source = git+https://github.com/ghaerr/agg-2.6.git
+ source = AGG-2.6-Anti-Grain-Geometry-Public-License.txt
+ source = AGG-2.6-Modified-BSD-License.txt
+ sha256sums = SKIP
+ sha256sums = 74449c3b7082b77d63a23aba1c17ecc85c9dd292b3c6254f636746915d2c27b8
+ sha256sums = 308c93912836bb56fdd52c308bec06a5d3fe2b05947e35a89bab0bb52ce03d91
+
+pkgname = agg-2.6-git
diff --git a/AGG-2.6-Anti-Grain-Geometry-Public-License.txt b/AGG-2.6-Anti-Grain-Geometry-Public-License.txt
new file mode 100644
index 000000000000..d53f36e1164e
--- /dev/null
+++ b/AGG-2.6-Anti-Grain-Geometry-Public-License.txt
@@ -0,0 +1,8 @@
+Anti-Grain Geometry Public License
+Anti-Grain Geometry - Version 2.4
+Copyright (C) 2002-2004 Maxim Shemanarev (McSeem)
+
+Permission to copy, use, modify, sell and distribute this software
+is granted provided this copyright notice appears in all copies.
+This software is provided "as is" without express or implied
+warranty, and with no claim as to its suitability for any purpose.
diff --git a/AGG-2.6-Modified-BSD-License.txt b/AGG-2.6-Modified-BSD-License.txt
new file mode 100644
index 000000000000..bf9169cb25d6
--- /dev/null
+++ b/AGG-2.6-Modified-BSD-License.txt
@@ -0,0 +1,32 @@
+Modified BSD License
+Anti-Grain Geometry - Version 2.4
+Copyright (C) 2002-2005 Maxim Shemanarev (McSeem)
+
+Redistribution and use in source and binary forms, with or without
+modification, are permitted provided that the following conditions
+are met:
+
+ 1. Redistributions of source code must retain the above copyright
+ notice, this list of conditions and the following disclaimer.
+
+ 2. Redistributions in binary form must reproduce the above copyright
+ notice, this list of conditions and the following disclaimer in
+ the documentation and/or other materials provided with the
+ distribution.
+
+ 3. The name of the author may not be used to endorse or promote
+ products derived from this software without specific prior
+ written permission.
+
+THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR
+IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
+WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
+ARE DISCLAIMED. IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT,
+INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES
+(INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR
+SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
+HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT,
+STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING
+IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
+POSSIBILITY OF SUCH DAMAGE.
+Please mention the authors in any work derived from Anti-Grain Geometry.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1d636ec153ae
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,54 @@
+# Maintainer: Clemmitt Sigler <cmsigler.online@gmail.com>
+
+pkgname=agg-2.6-git
+_pkgname=agg
+pkgver=2.6
+pkgrel=1
+pkgdesc='High Quality Rendering Engine for C++'
+arch=('x86_64')
+url='https://github.com/ghaerr/agg-2.6'
+license=('BSD' 'custom:Anti-Grain Geometry Public License')
+depends=('gcc-libs' 'sdl' 'freetype2')
+makedepends=('git')
+provides=('agg')
+conflicts=('agg')
+replaces=('antigrain')
+source=("git+https://github.com/ghaerr/agg-2.6.git"
+ 'AGG-2.6-Anti-Grain-Geometry-Public-License.txt'
+ 'AGG-2.6-Modified-BSD-License.txt')
+sha256sums=('SKIP'
+ '74449c3b7082b77d63a23aba1c17ecc85c9dd292b3c6254f636746915d2c27b8'
+ '308c93912836bb56fdd52c308bec06a5d3fe2b05947e35a89bab0bb52ce03d91')
+
+prepare() {
+ cd "$_pkgname-$pkgver/agg-src"
+
+ autoupdate
+ aclocal
+ autoheader
+ autoconf
+ libtoolize -f
+ automake --foreign -a -i
+}
+
+build() {
+ cd "$_pkgname-$pkgver/agg-src"
+
+ # Do not use/remove GPC code to remove dependency on GPC license
+ # See https://github.com/ghaerr/agg-2.6/blob/master/agg-web/license/index.html
+ ./configure --prefix=/usr --disable-gpc --disable-static --disable-examples
+ make
+}
+
+package() {
+ make -C "$_pkgname-$pkgver/agg-src" DESTDIR="$pkgdir" install
+
+ # Do not use/remove GPC code to remove dependency on GPC license
+ # See https://github.com/ghaerr/agg-2.6/blob/master/agg-web/license/index.html
+ rm -f ./include/agg_conv_gpc.h "$pkgdir/usr/include/agg2/agg_conv_gpc.h"
+
+ install -Dm644 AGG-2.6-Anti-Grain-Geometry-Public-License.txt -t "$pkgdir/usr/share/licenses/$pkgname"
+ install -Dm644 AGG-2.6-Modified-BSD-License.txt -t "$pkgdir/usr/share/licenses/$pkgname"
+}
+
+# vim:set ts=2 sw=2 et: