summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfreeman2016-02-26 12:34:48 +0100
committerfreeman2016-02-26 12:34:48 +0100
commite37d5763baa2a7c9c11f917fa319bb5cac17ddd5 (patch)
tree43c22903bccda896e8d0cb17ba78d38fa974efc9
downloadaur-e37d5763baa2a7c9c11f917fa319bb5cac17ddd5.tar.gz
Initial import: Added version 2 of ASDCP lib
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD25
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a21bd9dff1fa
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Fri Feb 26 11:24:29 UTC 2016
+pkgbase = asdcplib2
+ pkgdesc = open source implementation of SMPTE and the MXF Interop “Sound & Picture Track File” format with IMF support
+ pkgver = 2.5.11
+ pkgrel = 1
+ url = http://www.cinecert.com/asdcplib/
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ depends = expat
+ depends = openssl
+ source = http://download.cinecert.com/asdcplib/asdcplib-2.5.11.tar.gz
+ sha1sums = 96932a265d822a2cbbf3a0b3e4821140fee9dc89
+
+pkgname = asdcplib2
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d1f55d9ae57d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: friehmaen <fm@xers.de>
+# Contributor: ianux <ianux@free.fr>
+
+pkgname=asdcplib2
+pkgver=2.5.11
+pkgrel=1
+pkgdesc="open source implementation of SMPTE and the MXF Interop “Sound & Picture Track File” format with IMF support"
+arch=('i686' 'x86_64')
+url="http://www.cinecert.com/asdcplib/"
+license=('GPL3')
+depends=('expat' 'openssl')
+source=(http://download.cinecert.com/asdcplib/asdcplib-${pkgver}.tar.gz)
+sha1sums=('96932a265d822a2cbbf3a0b3e4821140fee9dc89')
+
+build() {
+ cd asdcplib-${pkgver}
+ ./configure --prefix=/usr --enable-as-02
+ make
+}
+
+package() {
+ cd asdcplib-${pkgver}
+ make DESTDIR=${pkgdir} install
+}
+