summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorandalenavals2017-10-27 22:22:03 -0200
committerandalenavals2017-10-27 22:22:03 -0200
commite382f775e887edd60f8c91b75f96dd164ccf938c (patch)
treef559f9dc1bb751468708317bfad35e5ba67c2e0a
downloadaur-e382f775e887edd60f8c91b75f96dd164ccf938c.tar.gz
This version is from July 2017, there is a issue with permision of usr/lib/libfuntools.a
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD58
2 files changed, 72 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b756955038ca
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = funtools-git
+ pkgdesc = FITS library and utility package.
+ pkgver = r50.9c8bb6f
+ pkgrel = 1
+ url = https://github.com/ericmandel/funtools
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ depends = sh
+ source = funtools-git-r50.9c8bb6f::git+https://github.com/ericmandel/funtools
+ md5sums = SKIP
+
+pkgname = funtools-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..345cfbfdf55c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,58 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: Andres Alejandro Navarro Alsina <aanavarroa@unal.edu.co>
+# Contributor: Eric Mandel
+pkgname=funtools-git
+pkgver=r50.9c8bb6f
+pkgrel=1
+#epoch=
+
+pkgdesc=" FITS library and utility package. "
+
+
+arch=('x86_64')
+url="https://github.com/ericmandel/funtools"
+license=('GPL3')
+groups=()
+depends=('sh')
+makedepends=('git')
+checkdepends=()
+optdepends=()
+#provides=()
+#conflicts=()
+#replaces=()
+#backup=()
+options=()
+install=
+changelog=
+source=("$pkgname-$pkgver::git+${url}")
+#noextract=()
+md5sums=('SKIP')
+#validpgpkeys=()
+
+
+build() {
+ cd "$src"
+ cd "$pkgname-$pkgver"
+ ./mkconfigure
+ ./configure --prefix=/usr
+ make
+}
+
+
+pkgver() {
+ cd "$pkgname-$pkgver"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+
+package() {
+ cd "$src"
+ cd "$pkgname-$pkgver"
+ install -d "$pkgdir"/usr/share/man
+ make DESTDIR="$pkgdir" install
+
+}