summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAmin Vakil2020-11-14 21:18:34 +0330
committerAmin Vakil2020-11-14 21:18:34 +0330
commite38b19c81cdfd75b5ce3509069eef42c9e864a27 (patch)
tree4e4dca3de32e1fb94ad7485a17341d2ba62e05db
downloadaur-e38b19c81cdfd75b5ce3509069eef42c9e864a27.tar.gz
Initial commit
-rw-r--r--.SRCINFO35
-rw-r--r--PKGBUILD52
2 files changed, 87 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f0f5b9f699a3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,35 @@
+pkgbase = ansible-core-git
+ pkgdesc = Radically simple IT automation platform
+ pkgver = r50796.c20329a0f6
+ pkgrel = 1
+ url = https://github.com/ansible/ansible
+ arch = any
+ license = GPL3
+ makedepends = python-setuptools
+ makedepends = git
+ depends = python
+ depends = python-yaml
+ depends = python-paramiko
+ depends = python-jinja
+ optdepends = sshpass: for ssh connections with password
+ optdepends = python-passlib: crypt values for vars_prompt
+ optdepends = python-netaddr: for the ipaddr filter
+ optdepends = python-systemd: log to journal
+ optdepends = python-pywinrm: connect to Windows machines
+ optdepends = python-dnspython: for dig lookup
+ optdepends = python-jmespath: json_query support
+ provides = ansible-core
+ provides = ansible-base
+ provides = python-ansible
+ conflicts = ansible-core
+ conflicts = ansible-base
+ conflicts = python-ansible
+ replaces = ansible-core
+ replaces = ansible-base
+ replaces = python-ansible
+ backup = etc/ansible/ansible.cfg
+ source = ansible-core-git::git+https://github.com/ansible/ansible.git
+ sha512sums = SKIP
+
+pkgname = ansible-core-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b9224c8d661d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,52 @@
+# Maintainer: Amin Vakil <info AT aminvakil DOT com>
+# Contributor: Jack Rubacha <rubacha.jack03@gmail.com>
+# Contributor: Paul Nicholson <brenix@gmail.com>
+# Contributor: Sven-Hendrik Haase <sh@lutzhaase.com>
+# Contributor: Bartłomiej Piotrowski <bpiotrowski@archlinux.org>
+# Contributor: Daniel Wallace <danielwallace at gtmanfred dot com>
+# Contributor: Chris <seitz.christoph@gmail.com>
+# Contributor: m0ikz <ndelatorre@moikz.com.ar>
+# Contributor: atweiden <archbaum@gmail.com>
+
+pkgname=ansible-core-git
+pkgver=r50796.c20329a0f6
+pkgrel=1
+pkgdesc='Radically simple IT automation platform'
+arch=('any')
+url='https://github.com/ansible/ansible'
+license=('GPL3')
+depends=('python' 'python-yaml' 'python-paramiko' 'python-jinja')
+provides=('ansible-core' 'ansible-base' 'python-ansible')
+replaces=('ansible-core' 'ansible-base' 'python-ansible')
+conflicts=('ansible-core' 'ansible-base' 'python-ansible')
+optdepends=('sshpass: for ssh connections with password'
+ 'python-passlib: crypt values for vars_prompt'
+ 'python-netaddr: for the ipaddr filter'
+ 'python-systemd: log to journal'
+ 'python-pywinrm: connect to Windows machines'
+ 'python-dnspython: for dig lookup'
+ 'python-jmespath: json_query support')
+makedepends=('python-setuptools' 'git')
+backup=('etc/ansible/ansible.cfg')
+source=($pkgname::git+https://github.com/ansible/ansible.git)
+sha512sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "${srcdir}"/${pkgname}
+ python setup.py build
+}
+
+package() {
+ cd ${pkgname}
+ python setup.py install -O1 --root="${pkgdir}"
+ install -Dm644 COPYING "${pkgdir}"/usr/share/doc/${pkgname}/COPYING
+
+ install -d "${pkgdir}"/usr/share/ansible/doc
+ cp -dpr --no-preserve=ownership ./examples "${pkgdir}"/usr/share/ansible/doc/
+ install -Dm644 examples/ansible.cfg "${pkgdir}"/etc/ansible/ansible.cfg
+}