summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYour Name2016-12-08 00:03:09 -0500
committerYour Name2016-12-08 00:03:09 -0500
commite3ba9a4008bf606abf0adaa1f76e25a42dec70cf (patch)
treeb80b799a2dfca1b97dbeec5791a1a567b8302666
parent7a4f34a1481577b6f6151cc6a50f97de58398c16 (diff)
downloadaur-e3ba9a4008bf606abf0adaa1f76e25a42dec70cf.tar.gz
remove cppunit
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD17
2 files changed, 16 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e7df86b6f1ca..38d794647ab9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Wed Dec 7 11:05:04 UTC 2016
+# Thu Dec 8 05:02:53 UTC 2016
pkgbase = libtorrent-pyro-git
pkgdesc = BitTorrent library written in C++ (git version)
pkgver = 20161207
@@ -11,7 +11,6 @@ pkgbase = libtorrent-pyro-git
arch = armv7h
license = GPL
makedepends = git
- makedepends = cppunit
depends = openssl
provides = libtorrent
conflicts = libtorrent
diff --git a/PKGBUILD b/PKGBUILD
index a7184b955035..d491418c56c6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -16,13 +16,18 @@ url='https://rakshasa.github.io/rtorrent'
license=('GPL')
arch=('i686' 'x86_64' 'armv7h')
depends=('openssl')
-makedepends=('git' 'cppunit')
+makedepends=('git')
conflicts=('libtorrent' 'libtorrent-git')
provides=('libtorrent')
install=libtorrent-pyro.install
[[ $_debug = 'n' ]] &&
- _debug='--disable-debug' || options=(!strip)
+ _debug='--disable-debug' ||
+{
+ _debug='--enable-extra-debug'
+ depends+=('cppunit')
+ options=(!strip)
+}
source=("git://github.com/rakshasa/libtorrent.git#branch=$_branch")
md5sums=('SKIP')
@@ -51,6 +56,14 @@ build() {
make
}
+check() {
+ [[ ! $_debug = 'n' ]] && {
+ cd "$srcdir/libtorrent"
+ make check
+ }
+}
+
+
package() {
make -C "$srcdir/libtorrent" DESTDIR="$pkgdir" install
}