summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Peukert2023-05-23 08:34:47 +0200
committerDaniel Peukert2023-05-23 08:34:47 +0200
commite3c3fcbf68c8f0ad18b9e4ddf37502b051883b5d (patch)
tree7849b8a4e29a26145adfb2958d02da3c6d0e68da
parent89f78dd562828fdd84ccb1abe7842d74ff2a90b3 (diff)
downloadaur-e3c3fcbf68c8f0ad18b9e4ddf37502b051883b5d.tar.gz
Fix ocaml-ocplib-endian build
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD17
2 files changed, 18 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fa52be1a2dea..9c1c14989f39 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ocaml-ocplib-endian
pkgdesc = Optimised functions to read and write int16/32/64 from strings, bytes and bigarrays
pkgver = 1.2
- pkgrel = 4
+ pkgrel = 5
url = https://github.com/OCamlPro/ocplib-endian
arch = x86_64
arch = i486
@@ -14,7 +14,9 @@ pkgbase = ocaml-ocplib-endian
makedepends = dune>=1.0.0
depends = ocaml>=4.03.0
options = !strip
- source = ocaml-ocplib-endian-1.2-4.tar.gz::https://github.com/OCamlPro/ocplib-endian/archive/1.2.tar.gz
+ source = ocaml-ocplib-endian-1.2-5.tar.gz::https://github.com/OCamlPro/ocplib-endian/archive/1.2.tar.gz
+ source = ocaml-ocplib-endian-1.2-5-remove-bytes-dep.diff::https://github.com/OCamlPro/ocplib-endian/pull/26.diff
sha512sums = 2e70be5f3d6e377485c60664a0e235c3b9b24a8d6b6a03895d092c6e40d53810bfe1f292ee69e5181ce6daa8a582bfe3d59f3af889f417134f658812be5b8b85
+ sha512sums = 6199b7032bb3939513de1376966c595fc47e8204f2ba96d6909897378ed18f88e39d81bdabb09c4669c092eacdb8c600fccde733d61677890093b2a50bb90bf0
pkgname = ocaml-ocplib-endian
diff --git a/PKGBUILD b/PKGBUILD
index b0d1df30f662..eeedaf73c8f9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_projectname='ocplib-endian'
pkgname="ocaml-$_projectname"
pkgver='1.2'
-pkgrel='4'
+pkgrel='5'
pkgdesc='Optimised functions to read and write int16/32/64 from strings, bytes and bigarrays'
# If you're running on i486, i686, pentium4, armv7h or aarch64, you have to add it to the arch array of the cppo AUR dependency
arch=('x86_64' 'i486' 'i686' 'pentium4' 'armv7h' 'aarch64')
@@ -12,11 +12,22 @@ license=('custom:LGPL2.1 with linking exception')
depends=('ocaml>=4.03.0')
makedepends=('cppo' 'dune>=1.0.0')
options=('!strip')
-source=("$pkgname-$pkgver-$pkgrel.tar.gz::$url/archive/$pkgver.tar.gz")
-sha512sums=('2e70be5f3d6e377485c60664a0e235c3b9b24a8d6b6a03895d092c6e40d53810bfe1f292ee69e5181ce6daa8a582bfe3d59f3af889f417134f658812be5b8b85')
+source=(
+ "$pkgname-$pkgver-$pkgrel.tar.gz::$url/archive/$pkgver.tar.gz"
+ "$pkgname-$pkgver-$pkgrel-remove-bytes-dep.diff::$url/pull/26.diff"
+)
+sha512sums=('2e70be5f3d6e377485c60664a0e235c3b9b24a8d6b6a03895d092c6e40d53810bfe1f292ee69e5181ce6daa8a582bfe3d59f3af889f417134f658812be5b8b85'
+ '6199b7032bb3939513de1376966c595fc47e8204f2ba96d6909897378ed18f88e39d81bdabb09c4669c092eacdb8c600fccde733d61677890093b2a50bb90bf0')
_sourcedirectory="$_projectname-$pkgver"
+prepare() {
+ cd "$srcdir/$_sourcedirectory/"
+
+ # Make sure we don't directly depend on bytes, as that stopped working in ocaml 5.0 (https://github.com/OCamlPro/ocplib-endian/pull/26)
+ patch --forward -p1 < "../$pkgname-$pkgver-$pkgrel-remove-bytes-dep.diff"
+}
+
build() {
cd "$srcdir/$_sourcedirectory/"
dune build --release --verbose