summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonne Haß2020-04-23 18:11:10 +0200
committerJonne Haß2020-04-23 18:11:10 +0200
commite3dbf5f4e3805bc6a251f73c315262ae856ec413 (patch)
tree49d5226f23ea76a0609a6f6be60bb2b4f5d69732
parent13b1440df9cac0fa1208a1c4588b8cbbd1ccf721 (diff)
downloadaur-e3dbf5f4e3805bc6a251f73c315262ae856ec413.tar.gz
diaspora: use Ruby 2.5
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD17
2 files changed, 13 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index af5efc41cc07..d67c93c851a7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = diaspora-postgresql-git
pkgdesc = A distributed privacy aware social network (development head) (PostgreSQL)
- pkgver = 0.7.13.0.r404.g984b739eb
+ pkgver = 0.7.13.0.r483.g002d427f3
pkgrel = 1
url = https://diasporafoundation.org
install = diaspora.install
@@ -9,8 +9,8 @@ pkgbase = diaspora-postgresql-git
license = AGPL3
makedepends = nodejs
makedepends = git
- depends = ruby2.4
- depends = ruby2.4-bundler
+ depends = ruby2.5
+ depends = ruby2.5-bundler
depends = redis
depends = imagemagick
depends = libxslt
diff --git a/PKGBUILD b/PKGBUILD
index 535690674564..ebf66108780b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,12 @@
# Maintainer: Jonne Haß <me@jhass.eu>
pkgname='diaspora-postgresql-git'
-pkgver=0.7.13.0.r404.g984b739eb
+pkgver=0.7.13.0.r483.g002d427f3
pkgrel=1
pkgdesc="A distributed privacy aware social network (development head) (PostgreSQL)"
arch=('i686' 'x86_64')
url="https://diasporafoundation.org"
license=('AGPL3')
-depends=('ruby2.4' 'ruby2.4-bundler' 'redis' 'imagemagick' 'libxslt' 'net-tools' 'gsfonts' 'libtirpc' 'postgresql-libs')
+depends=('ruby2.5' 'ruby2.5-bundler' 'redis' 'imagemagick' 'libxslt' 'net-tools' 'gsfonts' 'libtirpc' 'postgresql-libs')
optdepends=('jemalloc: lower memory consumption' 'postgresql: Database server')
makedepends=('nodejs' 'git')
conflicts=('diaspora-mysql' 'diaspora-postgresql' 'diaspora-mysql-git')
@@ -50,9 +50,10 @@ _reset_ruby() {
}
build() {
- _bundle=bundle-2.4
- _ruby=ruby-2.4
- _rake=rake-2.4
+ _bundle=bundle-2.5
+ _ruby=ruby-2.5
+ _rake=rake-2.5
+ _gem=gem-2.5
_builddir=$srcdir/build
_reset_ruby
@@ -66,6 +67,8 @@ build() {
msg "Bundle dependencies"
echo "gem: --no-rdoc --no-ri --no-user-install" > $_builddir/.gemrc
+ export GEM_HOME="$_builddir/vendor/bundle"
+ HOME=$_builddir $_gem install bundler -v 1.17.3
HOME=$_builddir $_bundle config --local path vendor/bundle
HOME=$_builddir $_bundle config --local frozen 1
HOME=$_builddir $_bundle config --local disable_shared_gems true
@@ -95,8 +98,8 @@ build() {
}
package() {
- _bundle=bundle-2.4
- _ruby=ruby-2.4
+ _bundle=bundle-2.5
+ _ruby=ruby-2.5
_builddir=$srcdir/build
msg "Copy contents to package directory"