summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordtbaumann2019-04-16 18:35:00 +0200
committerdtbaumann2019-04-16 18:35:00 +0200
commite3f2fb2e2f73612b546f4889748b8e9358d51d35 (patch)
tree1d076c9301f1254dfbd3c7aee03ad5919f0b28b1
parentd7e8ec4eeebd4a24b3b90cd9638bc020c305a3d1 (diff)
downloadaur-e3f2fb2e2f73612b546f4889748b8e9358d51d35.tar.gz
upgpkg: phreeqc-3.5.0
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD12
-rw-r--r--phreeqc.el18
3 files changed, 20 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 811971067dfd..716deb69f161 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,21 @@
# Generated by mksrcinfo v8
-# Fri Nov 17 20:32:59 UTC 2017
+# Tue Apr 16 16:34:16 UTC 2019
pkgbase = phreeqc
pkgdesc = A Computer Program for Speciation, Batch-Reaction, One-Dimensional Transport, and Inverse Geochemical Calculations
- pkgver = 3.4.0
+ pkgver = 3.5.0
pkgrel = 1
url = http://wwwbrr.cr.usgs.gov/projects/GWC_coupled/phreeqc/
install = install.sh
arch = x86_64
- license = custom
+ license = custom:CC0
depends = gmp
- source = ftp://brrftp.cr.usgs.gov/pub/charlton/phreeqc/phreeqc-3.4.0-12927.tar.gz
+ source = http://water.usgs.gov/water-resources/software/PHREEQC/phreeqc-3.5.0-14000.tar.gz
source = install.sh
source = phreeqc.el
source = https://raw.githubusercontent.com/jaalto/project-emacs--folding-mode/master/folding.el
- md5sums = 03e5c35fbfef89bbc8cd621d23e10ddc
+ md5sums = 0e77b2538d61df00212b9f648aae9c75
md5sums = 8facd6e784cd1985b2c57c092b753002
- md5sums = 2661645b6a28535f172b2314303c400b
+ md5sums = d4a5cee3f748c8c6ebcd042955ee234b
md5sums = d262512bd4a19a68805914d35f8f9019
pkgname = phreeqc
diff --git a/PKGBUILD b/PKGBUILD
index 64b8d9866f82..830825074232 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,12 @@
# Maintainer: arch AT nnamuab DOT de
pkgname=phreeqc
-pkgver=3.4.0
-_pkgsvn=12927
+pkgver=3.5.0
+_pkgsvn=14000
pkgrel=1
pkgdesc="A Computer Program for Speciation, Batch-Reaction, One-Dimensional Transport, and Inverse Geochemical Calculations"
arch=('x86_64')
url="http://wwwbrr.cr.usgs.gov/projects/GWC_coupled/phreeqc/"
-license=('custom')
+license=('custom:CC0')
groups=()
depends=('gmp')
makedepends=()
@@ -19,13 +19,13 @@ backup=()
options=()
install="install.sh"
changelog=
-source=("ftp://brrftp.cr.usgs.gov/pub/charlton/phreeqc/phreeqc-$pkgver-$_pkgsvn.tar.gz"
+source=("http://water.usgs.gov/water-resources/software/PHREEQC/${pkgname}-${pkgver}-${_pkgsvn}.tar.gz"
install.sh
phreeqc.el
"https://raw.githubusercontent.com/jaalto/project-emacs--folding-mode/master/folding.el")
-md5sums=('03e5c35fbfef89bbc8cd621d23e10ddc'
+md5sums=('0e77b2538d61df00212b9f648aae9c75'
'8facd6e784cd1985b2c57c092b753002'
- '2661645b6a28535f172b2314303c400b'
+ 'd4a5cee3f748c8c6ebcd042955ee234b'
'd262512bd4a19a68805914d35f8f9019')
build() {
diff --git a/phreeqc.el b/phreeqc.el
index 4f80c4bf5683..a6ce909a1261 100644
--- a/phreeqc.el
+++ b/phreeqc.el
@@ -1,6 +1,6 @@
;;; phreeqc.el --- Phreeqe code editing commands for Emacs
-;; Copyright (C) 2000,2015 dr. thomas baumann
+;; Copyright (C) 2000,2017 dr. thomas baumann
;; Author: Dr. Thomas Baumann
;; Keywords: languages
@@ -29,7 +29,7 @@
;; for automated loading add
;;
;; (autoload 'phreeqc-mode "phreeqc" "PhreeqC editing mode" t)
-;; (setq auto-mode-alist (append '(("\\.phrq$" . phreeqc-mode)) auto-mode-alist))
+;; (setq auto-mode-alist (append '(("\\.\\(phrq\\|pqi\\)$" . phreeqc-mode)) auto-mode-alist))
;;
;; to your .emacs file
@@ -53,7 +53,7 @@
:group 'phreeqc)
(defcustom phreeqc-manual-fn "/usr/share/doc/phreeqc/Phreeqc_3_2013_manual.pdf"
- "Name and path of the default thermodynamic database."
+ "Name and path of the PhreeqC manual."
:type 'string
:group 'phreeqc)
@@ -62,8 +62,6 @@
:type 'string
:group 'phreeqc)
-
-
(defcustom phreeqc-indent 4
"*This variable gives the indentation in Phreeqc-Mode."
:type 'integer
@@ -397,12 +395,12 @@ with no args, if that value is non-nil."
(phreeqc-goto-error)
(font-lock-fontify-buffer)
;; (folding-mode t)
-;; (folding-shift-in)
+;; (folding-shift-in t)
)
(font-lock-fontify-buffer)) t)
(read-only-mode t)
- (auto-revert-mode t)
+;; (auto-revert-mode t)
(if (phreeqc-run-fail-p)
(phreeqc-goto-error)
;; (folding-mode t)
@@ -445,7 +443,7 @@ with no args, if that value is non-nil."
"Move to next simulation in folded output mode."
(interactive)
(if folding-stack
- (folding-shift-out))
+ (folding-shift-out t))
(next-line)
(folding-next-visible-heading)
(folding-shift-in))
@@ -454,9 +452,9 @@ with no args, if that value is non-nil."
"Move to previous simulation in folded output mode."
(interactive)
(if folding-stack
- (folding-shift-out))
+ (folding-shift-out t))
(folding-next-visible-heading 1)
- (folding-shift-in))
+ (folding-shift-in t))
(defun phreeqc-compile ()