summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-11-17 10:47:51 +0800
committerzxp198210052023-11-17 10:47:51 +0800
commite414e2c4ca1d4761b5cea06b9bf7c00b0c4248e6 (patch)
tree079fe48921871ad9b0e52da326dc17017b72c733
parent6710dabefb1bd0a357bdc29446224b7a39897933 (diff)
downloadaur-e414e2c4ca1d4761b5cea06b9bf7c00b0c4248e6.tar.gz
fix errors
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD26
2 files changed, 15 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d968977fb290..5d3f4ac54aea 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,16 @@
pkgbase = dooble-bin
pkgdesc = Web browser based on QtWebEngine
pkgver = 2023.08.30
- pkgrel = 3
- url = https://textbrowser.github.io/dooble/
+ pkgrel = 4
+ url = https://textbrowser.github.io/dooble
arch = x86_64
license = custom
makedepends = findutils
makedepends = gendesk
depends = at-spi2-core
- depends = bash
depends = cairo
depends = freetype2
- depends = gcc-libs
depends = gdk-pixbuf2
- depends = glib2
- depends = glibc
depends = gpgme
depends = gst-plugins-base-libs
depends = gstreamer
@@ -48,12 +44,13 @@ pkgbase = dooble-bin
depends = xcb-util-keysyms
depends = xcb-util-renderutil
depends = xcb-util-wm
- depends = zlib
provides = dooble=2023.08.30
conflicts = dooble
source = dooble-2023.08.30.tar.gz::https://github.com/textbrowser/dooble/releases/download/2023.08.30/Dooble-2023.08.30.tar.gz
source = LICENSE::https://raw.githubusercontent.com/textbrowser/dooble/2023.08.30/LICENSE
+ source = dooble.sh
sha256sums = 407057d48fa3aaf78c378c9b8e9ad8181cf0ee25eb5dbe75801e133718a9d34c
sha256sums = c60bf2d6a8bfdf7c7418bba91c6767cbb4b48dccae36dd5d9ffdb48f756815dd
+ sha256sums = 845fbb33d7152f74b5d7bbdf5566f9985ca73d1865c517c8fe820eabae923be1
pkgname = dooble-bin
diff --git a/PKGBUILD b/PKGBUILD
index 2f930a902466..c8948eb438b8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,21 +5,17 @@
pkgname=dooble-bin
_pkgname=Dooble
pkgver=2023.08.30
-pkgrel=3
+pkgrel=4
pkgdesc="Web browser based on QtWebEngine"
arch=("x86_64")
-url="https://textbrowser.github.io/dooble/"
-_githuburl="https://github.com/textbrowser/${pkgname%-bin}"
+url="https://textbrowser.github.io/dooble"
+_ghurl="https://github.com/textbrowser/dooble"
license=('custom')
depends=(
'at-spi2-core'
- 'bash'
'cairo'
'freetype2'
- 'gcc-libs'
'gdk-pixbuf2'
- 'glib2'
- 'glibc'
'gpgme'
'gst-plugins-base-libs'
'gstreamer'
@@ -53,7 +49,6 @@ depends=(
'xcb-util-keysyms'
'xcb-util-renderutil'
'xcb-util-wm'
- 'zlib'
)
optdependes=(
'bzip2: needed in plugins/multimedia/libffmpegmediaplugin.so'
@@ -65,11 +60,13 @@ makedepends=(
provides=("${pkgname%-bin}=${pkgver}")
conflicts=("${pkgname%-bin}")
source=(
- "${pkgname%-bin}-${pkgver}.tar.gz::${_githuburl}/releases/download/${pkgver}/${_pkgname}-${pkgver}.tar.gz"
+ "${pkgname%-bin}-${pkgver}.tar.gz::${_ghurl}/releases/download/${pkgver}/${_pkgname}-${pkgver}.tar.gz"
"LICENSE::https://raw.githubusercontent.com/textbrowser/dooble/${pkgver}/LICENSE"
+ "${pkgname%-bin}.sh"
)
sha256sums=('407057d48fa3aaf78c378c9b8e9ad8181cf0ee25eb5dbe75801e133718a9d34c'
- 'c60bf2d6a8bfdf7c7418bba91c6767cbb4b48dccae36dd5d9ffdb48f756815dd')
+ 'c60bf2d6a8bfdf7c7418bba91c6767cbb4b48dccae36dd5d9ffdb48f756815dd'
+ '845fbb33d7152f74b5d7bbdf5566f9985ca73d1865c517c8fe820eabae923be1')
build() {
gendesk -q -f -n --categories "Network" --name "${_pkgname}" --exec "${pkgname%-bin}"
# Fix incorrect permissions
@@ -78,16 +75,15 @@ build() {
find "${srcdir}/${pkgname%-bin}" -type f -perm 0775 -print0 | xargs -r0 chmod 0755
find "${srcdir}/${pkgname%-bin}" -type f -name '*.so' -print0 | xargs -r0 chmod 0755
# Remove libraries provided by upstream
- rm -rf "${srcdir}/${pkgname%-bin}/Lib/"
+ rm -rf "${srcdir}/${pkgname%-bin}/Lib/"{libc.so.6,libm.so.6}
cp "${srcdir}/${pkgname%-bin}/Translations/${pkgname%-bin}_zh_CN_simple.qm" "${srcdir}/${pkgname%-bin}/Translations/${pkgname%-bin}_zh_CN.qm"
}
package() {
- install -Dm755 -d "${pkgdir}/"{opt,usr/bin}
+ install -Dm755 -d "${pkgdir}/opt"
cp -r "${srcdir}/${pkgname%-bin}" "${pkgdir}/opt"
# Add a symlink to dooble.sh for those who prefer to not use a mouse
- ln -sr "${pkgdir}/opt/${pkgname%-bin}/${pkgname%-bin}.sh" "${pkgdir}/usr/bin/${pkgname%-bin}"
+ install -Dm755 "${srcdir}/${pkgname%-bin}.sh" "${pkgdir}/usr/bin/${pkgname%-bin}"
install -Dm644 "${srcdir}/LICENSE" -t "${pkgdir}/usr/share/licenses/${pkgname}"
install -Dm644 "${srcdir}/${pkgname%-bin}/${pkgname%-bin}.png" -t "${pkgdir}/usr/share/pixmaps"
install -Dm644 "${srcdir}/${pkgname%-bin}.desktop" -t "${pkgdir}/usr/share/applications"
-}
-# always end a file with a newline
+} \ No newline at end of file