summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSumner Evans2018-12-02 21:57:24 -0700
committerSumner Evans2018-12-02 21:57:36 -0700
commite421eccb4b53411348ee25bb23a5e7602d8c4aa3 (patch)
treed49270f6696fe2a1b0965bcc005ffba470c80683
parentd38070a447faaa36bd4fe3cd9a7027f9c2d54299 (diff)
downloadaur-e421eccb4b53411348ee25bb23a5e7602d8c4aa3.tar.gz
0.5.0 -> 0.6.0
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD24
-rwxr-xr-xupdate.sh64
3 files changed, 82 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c8aecea64edb..c984a5ae2c13 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = zsh-you-should-use
pkgdesc = ZSH plugin that reminds you to use existing aliases for commands you just typed
- pkgver = 0.5.0
+ pkgver = 0.6.0
pkgrel = 1
url = https://github.com/MichaelAquilina/zsh-you-should-use
install = zsh-you-should-use.install
arch = any
license = GPL3
- source = https://github.com/MichaelAquilina/zsh-you-should-use/archive/0.5.0.tar.gz
- sha256sums = d41f1cbfba03d6f446d2e19f7b758fe81e154dd9287415699c2438c450c144c3
+ source = https://github.com/MichaelAquilina/zsh-you-should-use/archive/0.6.0.tar.gz
+ sha256sums = c1c16c0bc339c6212748798528c1c62703dce86cd0381ef2ec6e115abc45e6fc
pkgname = zsh-you-should-use
diff --git a/PKGBUILD b/PKGBUILD
index 02aebc32e8af..3999ae2cda8e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,21 @@
-# Maintainer: Jonathan Sumner Evans <sumner.evans98@gmail.com>
+# Maintainer: Sumner Evans <sumner.evans98 at gmail dot com>
-pkgname="zsh-you-should-use"
-pkgver=0.5.0
+pkgbase=('zsh-you-should-use')
+pkgname=('zsh-you-should-use')
+_module='zsh-you-should-use'
+pkgver='0.6.0'
pkgrel=1
-pkgdesc="ZSH plugin that reminds you to use existing aliases for commands you just typed"
-url="https://github.com/MichaelAquilina/zsh-you-should-use"
-arch=("any")
-license=("GPL3")
-source=("https://github.com/MichaelAquilina/${pkgname}/archive/${pkgver}.tar.gz")
+pkgdesc='ZSH plugin that reminds you to use existing aliases for commands you just typed'
+url='https://github.com/MichaelAquilina/zsh-you-should-use'
+depends=(
+)
+makedepends=()
+arch=('any')
+license=('GPL3')
+source=('https://github.com/MichaelAquilina/zsh-you-should-use/archive/0.6.0.tar.gz')
install="${pkgname}.install"
-sha256sums=("d41f1cbfba03d6f446d2e19f7b758fe81e154dd9287415699c2438c450c144c3")
+sha256sums=('c1c16c0bc339c6212748798528c1c62703dce86cd0381ef2ec6e115abc45e6fc')
+
package() {
install -d "${pkgdir}/usr/share/zsh/plugins/${pkgname}"
diff --git a/update.sh b/update.sh
new file mode 100755
index 000000000000..60db852d6bde
--- /dev/null
+++ b/update.sh
@@ -0,0 +1,64 @@
+#! /bin/sh
+
+AUR_NAME=zsh-you-should-use
+PROJ_NAME=zsh-you-should-use
+DESCRIPTION="ZSH plugin that reminds you to use existing aliases for commands you just typed"
+URL="https://github.com/MichaelAquilina/zsh-you-should-use"
+DEPENDS=()
+LICENSE='GPL3'
+ADDITIONAL=
+
+if [[ $# == 0 ]]; then
+ echo 'Usage: ./update.sh VERSION_NUMBER'
+ exit 1
+fi
+
+SRC=https://github.com/MichaelAquilina/${PROJ_NAME}/archive/$1.tar.gz
+
+# Get the sha256sum sum of the package.
+mkdir -p dist
+pushd dist
+wget $SRC
+sha=$(sha256sum "$1.tar.gz" | cut -d ' ' -f 1)
+echo $sha
+popd
+
+echo "# Maintainer: Sumner Evans <sumner.evans98 at gmail dot com>
+
+pkgbase=('${AUR_NAME}')
+pkgname=('${AUR_NAME}')
+_module='${PROJ_NAME}'
+pkgver='$1'
+pkgrel=1
+pkgdesc='${DESCRIPTION}'
+url='${URL}'
+depends=(" > PKGBUILD
+
+# Include the dependencies.
+for d in ${DEPENDS[*]}; do
+ echo " '$d'" >> PKGBUILD
+done
+
+echo ")
+makedepends=()
+arch=('any')
+license=('${LICENSE}')
+source=('${SRC}')
+install=\"\${pkgname}.install\"
+sha256sums=('${sha}')
+${ADDITIONAL}
+
+package() {
+ install -d \"\${pkgdir}/usr/share/zsh/plugins/\${pkgname}\"
+ install -Dm644 \"\${srcdir}/\${pkgname}-\${pkgver}/you-should-use.plugin.zsh\" \\
+ \"\${pkgdir}/usr/share/zsh/plugins/\${pkgname}\"
+
+ # License
+ install -Dm644 \"\${srcdir}/\${pkgname}-\${pkgver}/LICENSE\" \\
+ \"\${pkgdir}/usr/share/licenses/\${pkgname}/LICENSE\"
+}" >> PKGBUILD
+
+make
+
+# Test
+makepkg -f