summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Peukert2022-03-08 12:09:23 +0100
committerDaniel Peukert2022-03-08 12:09:23 +0100
commite42e5c4565cac1314fdc21dbda0f4483a8172296 (patch)
tree9a64666a7be5ac3bd5a17751aca66b3aab3edb9e
parentffd2bd58e1446bf064fed29b7076487542dd6bf9 (diff)
downloadaur-e42e5c4565cac1314fdc21dbda0f4483a8172296.tar.gz
Disable clippy tests for spot-client
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD17
-rw-r--r--disable-clippy.patch19
3 files changed, 36 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 004a38023d24..614e04d98727 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = spot-client-git
pkgdesc = Gtk/Rust native Spotify client - git version
- pkgver = 0.3.0.r3.g1812877
+ pkgver = 0.3.1.r19.gef3309c
pkgrel = 1
url = https://github.com/xou816/spot
arch = x86_64
@@ -28,6 +28,8 @@ pkgbase = spot-client-git
provides = spot-client
conflicts = spot-client
source = spot-client-git::git+https://github.com/xou816/spot
+ source = disable-clippy.patch
sha512sums = SKIP
+ sha512sums = 1cb0faced2e6801cb994e9af7b81411355837b2efcd9c82b82751508e0bfcc967c50b3d6296bfdb8c017bbf2e7a503a3920d36cb896e44c896c23f5b9e1d13f1
pkgname = spot-client-git
diff --git a/PKGBUILD b/PKGBUILD
index 5ca7121e4fc2..0bcdde8504b5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: NicoHood <archlinux {cat} nicohood {dog} de>
_projectname='spot'
pkgname="$_projectname-client-git"
-pkgver='0.3.0.r3.g1812877'
+pkgver='0.3.1.r19.gef3309c'
pkgrel='1'
pkgdesc='Gtk/Rust native Spotify client - git version'
arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h' 'aarch64')
@@ -14,12 +14,23 @@ makedepends=('cargo' 'git' 'meson>=0.50.0')
checkdepends=('appstream-glib')
provides=("$_projectname-client")
conflicts=("$_projectname-client")
-source=("$pkgname::git+$url")
-sha512sums=('SKIP')
+source=(
+ "$pkgname::git+$url"
+ 'disable-clippy.patch'
+)
+sha512sums=('SKIP'
+ '1cb0faced2e6801cb994e9af7b81411355837b2efcd9c82b82751508e0bfcc967c50b3d6296bfdb8c017bbf2e7a503a3920d36cb896e44c896c23f5b9e1d13f1')
_sourcedirectory="$pkgname"
_builddirectory='build'
+prepare() {
+ cd "$srcdir/$_sourcedirectory/"
+
+ # Disable clippy tests, as they don't realy make sense for user builds (https://gitlab.com/dpeukert/pkgbuilds/-/issues/37)
+ patch --forward -p1 < '../disable-clippy.patch'
+}
+
pkgver() {
cd "$srcdir/$_sourcedirectory/"
git describe --long --tags | sed -e 's/^v//' -e 's/-\([^-]*-g[^-]*\)$/-r\1/' -e 's/-/./g'
diff --git a/disable-clippy.patch b/disable-clippy.patch
new file mode 100644
index 000000000000..25b954400ad3
--- /dev/null
+++ b/disable-clippy.patch
@@ -0,0 +1,19 @@
+diff --git a/src/meson.build b/src/meson.build
+index 755d870..fac1b77 100644
+--- a/src/meson.build
++++ b/src/meson.build
+@@ -208,14 +208,3 @@ test('Unit tests',
+ ],
+ timeout: 180
+ )
+-
+-cargo_clippy = find_program(meson.source_root() / 'build-aux/clippy.sh')
+-test('Clippy',
+- cargo_clippy,
+- args: [
+- meson.source_root(),
+- meson.build_root(),
+- get_option('offline') ? 'true' : 'false'
+- ],
+- timeout: 180
+-)