summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoão Figueiredo2023-06-10 01:06:46 +0100
committerJoão Figueiredo2023-06-10 01:06:46 +0100
commite45990c025d122891f8e578a071888e9e6cebcca (patch)
tree8ed26d504887ce0784861c5279ed2826c31cffad
parent9bae5de7c789fe1e55c0a51e5ba2a818d8cbfc6c (diff)
downloadaur-e45990c025d122891f8e578a071888e9e6cebcca.tar.gz
Migrate to Qt6
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD9
2 files changed, 9 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3479a3497d07..6c2ac641ce9c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = plasma-workspace-git
pkgdesc = KDE Plasma Workspace
- pkgver = 5.24.80_r11429.g43ca3339b
+ pkgver = 5.27.80_r13857.gb5c675324
pkgrel = 1
url = https://kde.org/plasma-desktop/
arch = x86_64
@@ -21,7 +21,7 @@ pkgbase = plasma-workspace-git
depends = libqalculate
depends = kde-cli-tools-git
depends = appstream-qt
- depends = phonon-qt5-git
+ depends = phonon-qt6-git
depends = xorg-xrdb
depends = xorg-xsetroot
depends = kactivitymanagerd-git
@@ -51,7 +51,7 @@ pkgname = plasma-workspace-git
optdepends = networkmanager-qt: IP based geolocation
optdepends = kdepim-addons-git: displaying PIM events in the calendar
optdepends = appmenu-gtk-module: global menu support for GTK2 and some GTK3 applications
- optdepends = qt5-virtualkeyboard: virtual keyboard support in lock screen
+ optdepends = qt6-virtualkeyboard: virtual keyboard support in lock screen
optdepends = baloo-git: Baloo search runner
optdepends = discover: manage applications installation from the launcher
provides = plasma-workspace
@@ -62,7 +62,7 @@ pkgname = plasma-workspace-git
pkgname = plasma-wayland-session-git
pkgdesc = Plasma Wayland session
depends = plasma-workspace-git
- depends = qt5-wayland
+ depends = qt6-wayland
depends = kwayland-integration-git
depends = xorg-server-xwayland
provides = plasma-wayland-session
diff --git a/PKGBUILD b/PKGBUILD
index 3ddcf623e305..3e0a5d28046d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,13 +3,13 @@
pkgbase=plasma-workspace-git
pkgname=(plasma-workspace-git plasma-wayland-session-git)
-pkgver=5.24.80_r11429.g43ca3339b
+pkgver=5.27.80_r13857.gb5c675324
pkgrel=1
pkgdesc='KDE Plasma Workspace'
arch=($CARCH)
url='https://kde.org/plasma-desktop/'
license=(LGPL)
-depends=(knotifyconfig-git libksysguard-git ktexteditor-git libqalculate kde-cli-tools-git appstream-qt phonon-qt5-git
+depends=(knotifyconfig-git libksysguard-git ktexteditor-git libqalculate kde-cli-tools-git appstream-qt phonon-qt6-git
xorg-xrdb xorg-xsetroot kactivitymanagerd-git kholidays-git xorg-xmessage milou-git prison-git kwin-git
plasma-integration-git kdelibs4support-git kpeople-git kactivities-stats-git libkscreen-git kquickcharts-git kuserfeedback-git layer-shell-qt-git)
makedepends=(git extra-cmake-modules-git kdoctools-git gpsd baloo-git networkmanager-qt-git kdesignerplugin-git kinit-git plasma-wayland-protocols-git)
@@ -28,6 +28,7 @@ pkgver() {
build() {
cmake -B build -S ${pkgbase%-git} \
+ -DQT_MAJOR_VERSION=6 \
-DCMAKE_INSTALL_LIBEXECDIR=lib \
-DBUILD_TESTING=OFF
cmake --build build
@@ -38,7 +39,7 @@ package_plasma-workspace-git() {
'gpsd: GPS based geolocation' 'networkmanager-qt: IP based geolocation'
'kdepim-addons-git: displaying PIM events in the calendar'
'appmenu-gtk-module: global menu support for GTK2 and some GTK3 applications'
- 'qt5-virtualkeyboard: virtual keyboard support in lock screen'
+ 'qt6-virtualkeyboard: virtual keyboard support in lock screen'
'baloo-git: Baloo search runner' 'discover: manage applications installation from the launcher')
conflicts=(plasma-workspace)
provides=(plasma-workspace notification-daemon)
@@ -54,7 +55,7 @@ package_plasma-workspace-git() {
package_plasma-wayland-session-git() {
pkgdesc='Plasma Wayland session'
- depends=(plasma-workspace-git qt5-wayland kwayland-integration-git xorg-server-xwayland)
+ depends=(plasma-workspace-git qt6-wayland kwayland-integration-git xorg-server-xwayland)
conflicts=(plasma-wayland-session)
provides=(plasma-wayland-session)