summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authora8212022-11-01 09:57:05 +0100
committera8212022-11-01 09:57:05 +0100
commite4743c8ff6776fc18e6a6c0ffbb87a1b594e67b9 (patch)
tree9efb4458f316ae307329ddba65206e9e6723d448
parentf349e783821c4f988fe367b5d2e1e1f37db2af7b (diff)
downloadaur-e4743c8ff6776fc18e6a6c0ffbb87a1b594e67b9.tar.gz
Version 0.5.8
-rw-r--r--.SRCINFO7
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD11
3 files changed, 17 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3de92ad23811..8002d5c3da78 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,17 @@
pkgbase = python-pynndescent
pkgdesc = Simple fast approximate nearest neighbor search
- pkgver = 0.5.7
+ pkgver = 0.5.8
pkgrel = 1
url = https://github.com/lmcinnes/pynndescent
arch = any
license = BSD
+ checkdepends = python-pytest
makedepends = python-setuptools
depends = python-joblib
depends = python-numba
depends = python-scikit-learn
depends = python-scipy
- source = https://pypi.io/packages/source/p/pynndescent/pynndescent-0.5.7.tar.gz
- sha256sums = ecb395255fa36a748b5870b4ba0300ea0f7da8b1964864b8edd62577a84dfd7d
+ source = https://pypi.io/packages/source/p/pynndescent/pynndescent-0.5.8.tar.gz
+ sha256sums = a7c552569bf604a101fd54bba1d27c12389e065945dee3a6777a518c63a46f2b
pkgname = python-pynndescent
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..4785aa5f48e2
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!/.SRCINFO
+!/PKGBUILD
+!/.gitignore
diff --git a/PKGBUILD b/PKGBUILD
index 2bacedc1b722..10e5f65f7f32 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,6 @@
+# Maintainer: a821
pkgname=python-pynndescent
-pkgver=0.5.7
+pkgver=0.5.8
pkgrel=1
pkgdesc="Simple fast approximate nearest neighbor search"
arch=('any')
@@ -7,8 +8,14 @@ url="https://github.com/lmcinnes/pynndescent"
license=('BSD')
depends=('python-joblib' 'python-numba' 'python-scikit-learn' 'python-scipy')
makedepends=('python-setuptools')
+checkdepends=('python-pytest')
source=("https://pypi.io/packages/source/p/pynndescent/pynndescent-${pkgver}.tar.gz")
-sha256sums=('ecb395255fa36a748b5870b4ba0300ea0f7da8b1964864b8edd62577a84dfd7d')
+sha256sums=('a7c552569bf604a101fd54bba1d27c12389e065945dee3a6777a518c63a46f2b')
+
+check() {
+ cd "pynndescent-$pkgver"
+ pytest
+}
package() {
cd "$srcdir/pynndescent-$pkgver"