summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorArti Zirk2018-07-04 22:38:06 +0300
committerArti Zirk2018-07-04 22:38:06 +0300
commite4837e17e927c2335716e47dfcf8264c971f87a5 (patch)
treee67270f11565077cf7b117f9e2141e6d96dced8d
downloadaur-e4837e17e927c2335716e47dfcf8264c971f87a5.tar.gz
Import ABS version and change soruce to upstream git repo
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD44
-rw-r--r--arch-detect.patch21
3 files changed, 86 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5bd08e3bd168
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = debootstrap-git
+ pkgdesc = Bootstrap a basic Debian system
+ pkgver = 1.0.103.r18.g95713fa
+ pkgrel = 1
+ url = https://tracker.debian.org/pkg/debootstrap
+ arch = any
+ license = GPL
+ depends = wget
+ depends = binutils
+ optdepends = gnupg: check release signatures
+ optdepends = debian-archive-keyring: check release signatures for Debian
+ optdepends = ubuntu-keyring: check release signatures for Ubuntu
+ provides = debootstrap
+ conflicts = debootstrap
+ source = debootstrap-git::git+https://salsa.debian.org/installer-team/debootstrap.git
+ source = arch-detect.patch
+ sha512sums = SKIP
+ sha512sums = 56e25f48027f99f7e720859a9e14fe769b1cbd6227c7a7e27e14c2fea88520109342d6e5b127dc34ce8cc40f46941a0c5157ad35cf8ef9b3e4323877a4b32d97
+
+pkgname = debootstrap-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d10e4e16f149
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Felix Yan <felixonmars@archlinux.org>
+# Maintainer: arti.zirk <arti.zirk@gmail.com>
+
+pkgname=debootstrap-git
+pkgver=1.0.103.r18.g95713fa
+pkgrel=1
+pkgdesc="Bootstrap a basic Debian system"
+conflicts=('debootstrap')
+provides=('debootstrap')
+arch=('any')
+license=('GPL')
+url="https://tracker.debian.org/pkg/debootstrap"
+depends=('wget' 'binutils')
+source=("$pkgname::git+https://salsa.debian.org/installer-team/debootstrap.git"
+ arch-detect.patch)
+optdepends=('gnupg: check release signatures'
+ 'debian-archive-keyring: check release signatures for Debian'
+ 'ubuntu-keyring: check release signatures for Ubuntu')
+sha512sums=('SKIP'
+ '56e25f48027f99f7e720859a9e14fe769b1cbd6227c7a7e27e14c2fea88520109342d6e5b127dc34ce8cc40f46941a0c5157ad35cf8ef9b3e4323877a4b32d97')
+
+pkgver() {
+ cd "$pkgname"
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ cd "$pkgname"
+
+ sed -i 's/sbin/bin/g' Makefile
+
+ # Debian defaults
+ sed -i 's|export PATH|export PATH="/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin"|' debootstrap
+
+ # Detect Architecture
+ patch -p1 -i ../arch-detect.patch
+}
+
+package() {
+ cd "$pkgname"
+ make DESTDIR="$pkgdir" install
+
+ install -Dm644 debootstrap.8 "$pkgdir"/usr/share/man/man8/debootstrap.8
+}
diff --git a/arch-detect.patch b/arch-detect.patch
new file mode 100644
index 000000000000..2a76428fdd6c
--- /dev/null
+++ b/arch-detect.patch
@@ -0,0 +1,21 @@
+diff --git a/debootstrap b/debootstrap
+index fcdb20f..184900d 100755
+--- a/debootstrap
++++ b/debootstrap
+@@ -427,6 +427,16 @@ elif in_path udpkg && \
+ HOST_ARCH=$(/usr/bin/udpkg --print-architecture)
+ elif [ -e "$DEBOOTSTRAP_DIR/arch" ]; then
+ HOST_ARCH=$(cat "$DEBOOTSTRAP_DIR/arch")
++elif in_path pacman; then
++ # pacman 5.1 will have `pacman-conf Architecture`
++ CARCH="$(bash -c '. /etc/makepkg.conf && echo $CARCH')"
++ case "$CARCH" in
++ "i686") HOST_ARCH="i386" ;;
++ "x86_64") HOST_ARCH="amd64" ;;
++ "armv7h") HOST_ARCH="armhf" ;;
++ "aarch64") HOST_ARCH="arm64" ;;
++ *) echo "Unknown architecture: $CARCH" && exit 1
++ esac
+ fi
+ HOST_OS="$HOST_ARCH"
+ # basic host OS guessing for non-Debian systems