summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCallum Parsey2023-07-07 19:07:09 +0930
committerCallum Parsey2023-07-07 19:07:09 +0930
commite4ac0757e700e06b03fcc2f88a50d8b577b77bca (patch)
treec0952723d29c0aa15b63c9c876c600f416647f16
parent95c48448e1afb9c7126d79c7f7251b5473d1dcff (diff)
downloadaur-e4ac0757e700e06b03fcc2f88a50d8b577b77bca.tar.gz
Update patchset for upstream 0.8.0 release
As of 0.8.0, libQuotient has a build-time option for selecting either Qt 5 or Qt 6, which required adding infrastructure to change the name of the library target to prevent conflicts. Since I had to do this in my patchset for 0.7.2, the patchset is now greatly simplified. I still needed to make a few changes to other files to move the header install location though. I have also made some changes to the `pkg-config` description file to make it more responsive to the selected build configuration. These changes should probably be upstreamed as the file is otherwise incorrect for Qt 6 builds.
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD56
-rw-r--r--namespace.patch203
3 files changed, 70 insertions, 201 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e098a214da7b..ff54cf5d79a6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = libquotient-encryption
pkgdesc = A Qt library to write cross-platform clients for Matrix (with experimental encryption support)
- pkgver = 0.7.2
- pkgrel = 2
+ pkgver = 0.8.0
+ pkgrel = 1
url = https://github.com/quotient-im/libQuotient
arch = x86_64
arch = aarch64
@@ -14,10 +14,10 @@ pkgbase = libquotient-encryption
depends = qt5-base
depends = qt5-multimedia
depends = qtkeychain-qt5
- provides = libQuotientE2EE.so=0.7-64
- source = https://github.com/quotient-im/libQuotient/archive/0.7.2/libquotient-encryption-0.7.2.tar.gz
+ provides = libQuotientE2EE.so=0.8-64
+ source = https://github.com/quotient-im/libQuotient/archive/0.8.0/source.tar.gz
source = namespace.patch
- sha256sums = 62ff42c8fe321e582ce8943417c1d815ab3f373a26fa0d99a5926e713f6a9382
- sha256sums = cfb01b1855ac31fdfa614b3802b0cfc9890b92b7a4dade71f5f94f775773a94e
+ sha256sums = 40d84c2a1ed8c57605836dd175aabd069aed33c77b6bd841391631607b8c3a76
+ sha256sums = d1a40852adb19ba5ce132f1c1ff680c198e7e1cd9b2a36c2cc278907525f4d4e
pkgname = libquotient-encryption
diff --git a/PKGBUILD b/PKGBUILD
index 4b6d15ec8eaf..1ceda070c601 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
# Contributor: [object Object] <objekt-Objekt@proton.me>
pkgname=libquotient-encryption
-pkgver=0.7.2
-pkgrel=2
+pkgver=0.8.0
+pkgrel=1
pkgdesc="A Qt library to write cross-platform clients for Matrix (with experimental encryption support)"
arch=("x86_64" "aarch64")
url="https://github.com/quotient-im/libQuotient"
@@ -11,31 +11,31 @@ license=("LGPL2.1")
depends=("gcc-libs" "glibc" "libolm" "openssl" "qt5-base" "qt5-multimedia" "qtkeychain-qt5")
makedepends=("cmake")
provides=("libQuotientE2EE.so=${pkgver%.*}-64")
-source=("https://github.com/quotient-im/libQuotient/archive/${pkgver}/${pkgname}-${pkgver}.tar.gz"
+source=("https://github.com/quotient-im/libQuotient/archive/${pkgver}/source.tar.gz"
"namespace.patch")
-sha256sums=("62ff42c8fe321e582ce8943417c1d815ab3f373a26fa0d99a5926e713f6a9382"
- "cfb01b1855ac31fdfa614b3802b0cfc9890b92b7a4dade71f5f94f775773a94e")
+sha256sums=('40d84c2a1ed8c57605836dd175aabd069aed33c77b6bd841391631607b8c3a76'
+ 'd1a40852adb19ba5ce132f1c1ff680c198e7e1cd9b2a36c2cc278907525f4d4e')
prepare() {
- # This patch makes the following changes to CMakeLists.txt:
- # - Adds a new variable called `${LIBRARY_NAME}` which is currently set
- # to `QuotientE2EE`, which will replace `${PROJECT_NAME}` in all cases
- # where the name needs to be changed
- # - Replaces the name of the library target with `${LIBRARY_NAME}` so that
- # the generated shared objects are called `libQuotientE2EE.so*`
- # - All references to `${PROJECT_NAME}` which really refer to the library
- # target instead of the CMake project as a whole have been changed
- # - Changed the output names of the `pkg-config` script and the output
- # CMake files (i.e. `QuotientE2EEConfig.cmake`,
- # `QuotientE2EETargets.cmake` and so on)
- # - Changed the install directories for the config files and headers to use
- # `QuotientE2EE` instead of `Quotient`
- # - Disable generating files for integration with the Android Native
- # Development Kit, as these files have generic names which will conflict
- # with the official Arch `libquotient` package
- # Also, the template files for the `pkg-config` script (`Quotient.pc.in`)
- # and CMake script (`QuotientConfig.cmake.in`) have been adjusted to use
- # `${LIBRARY_NAME}` where necessary instead of hard-coding `Quotient`.
+ # This patch makes the following changes:
+ # - There is existing logic in `CMakeLists.txt` to change the name of the
+ # library to `QuotientQt6` when the relevant build option is enabled, I
+ # extend this to also add `E2EE` to the name if that option is enabled.
+ # This will change the name of the generated library (i.e. it becomes
+ # `libQuotientE2EE.so`) as well as the `pkg-config` description file (it
+ # will be installed to `<prefix>/lib/pkgconfig/QuotientE2EE.pc`) and
+ # CMake package description files (which will go to
+ # `<prefix>/lib/cmake/QuotientE2EE/QuotientE2EE-*.cmake`). The
+ # aforementioned CMake files also internally use the correct name.
+ # - In both `CMakeLists.txt` and the template `<target>Config.cmake` file,
+ # I change the install location for the headers from
+ # `<prefix>/include/Quotient` to `<prefix>/include/QuotientE2EE` so that
+ # this package does not need to conflict with or depend on the official
+ # `libquotient` Arch package.
+ # - Corrected the `pkg-config` description file so that it takes the
+ # correct name, description and linker directives for the selected build
+ # configuration. These changes are not Arch-specific and should be
+ # upstreamed at some point.
patch -Np0 -d . -i namespace.patch
}
@@ -75,6 +75,8 @@ package() {
# which matched the first sub-expression verbatim.
# - `[[:blank:]]*` matches an arbitrary amount of white-space (space or
# horizontal tab characters)
+ # - `[<"]` matches a single instance of either the quote or left angle
+ # bracket characters
# - Places where a forward slash needs to be part of the expression or
# replacement text are escaped with a backslash, i.e. `\/`
# - So the expression reads: match all instances of text which are of the
@@ -82,8 +84,8 @@ package() {
# slash contained in a sub-expression, and with an arbitrary amount of
# white-space allowed
# - And the replacement text will be whatever text matched the first
- # sub-expression (i.e. `# include <Quotient` but with the right amount
- # of white-space) followed by `E2EE/`.
+ # sub-expression (i.e. `# include <Quotient` or `# include "Quotient` but
+ # with the right amount of white-space) followed by `E2EE/`.
find "${pkgdir}/usr/include/QuotientE2EE" -name '*.h' -exec sed -i \
- 's/\(#[[:blank:]]*include[[:blank:]]*<Quotient\)\//\1E2EE\//g' '{}' \;
+ 's/\(#[[:blank:]]*include[[:blank:]]*[<"]Quotient\)\//\1E2EE\//g' '{}' \;
}
diff --git a/namespace.patch b/namespace.patch
index 948ec7878429..c2756ee17649 100644
--- a/namespace.patch
+++ b/namespace.patch
@@ -1,196 +1,63 @@
-diff '--color=auto' -rupN libQuotient-0.7.2.orig/cmake/QuotientConfig.cmake.in libQuotient-0.7.2/cmake/QuotientConfig.cmake.in
---- libQuotient-0.7.2.orig/cmake/QuotientConfig.cmake.in 2023-06-26 10:28:12.392559752 +0930
-+++ libQuotient-0.7.2/cmake/QuotientConfig.cmake.in 2023-06-26 11:28:49.614659917 +0930
-@@ -2,10 +2,10 @@ include(CMakeFindDependencyMacro)
-
- @FIND_DEPS@
-
--include("${CMAKE_CURRENT_LIST_DIR}/QuotientTargets.cmake")
-+include("${CMAKE_CURRENT_LIST_DIR}/@LIBRARY_NAME@Targets.cmake")
+diff '--color=auto' -rupN libQuotient-0.8.0.orig/cmake/QuotientConfig.cmake.in libQuotient-0.8.0/cmake/QuotientConfig.cmake.in
+--- libQuotient-0.8.0.orig/cmake/QuotientConfig.cmake.in 2023-07-05 12:23:12.511208577 +0930
++++ libQuotient-0.8.0/cmake/QuotientConfig.cmake.in 2023-07-05 12:54:04.695305929 +0930
+@@ -17,6 +17,6 @@ include("${CMAKE_CURRENT_LIST_DIR}/@QUOT
if (NOT QUOTIENT_FORCE_NAMESPACED_INCLUDES)
-- get_target_property(_include_dir @PROJECT_NAME@ INTERFACE_INCLUDE_DIRECTORIES)
+ get_target_property(_include_dir @QUOTIENT_LIB_NAME@ INTERFACE_INCLUDE_DIRECTORIES)
- list(APPEND _include_dir "${_include_dir}/Quotient")
-- set_target_properties(@PROJECT_NAME@ PROPERTIES INTERFACE_INCLUDE_DIRECTORIES "${_include_dir}")
-+ get_target_property(_include_dir @LIBRARY_NAME@ INTERFACE_INCLUDE_DIRECTORIES)
-+ list(APPEND _include_dir "${_include_dir}/@LIBRARY_NAME@")
-+ set_target_properties(@LIBRARY_NAME@ PROPERTIES INTERFACE_INCLUDE_DIRECTORIES "${_include_dir}")
- endif()
-diff '--color=auto' -rupN libQuotient-0.7.2.orig/CMakeLists.txt libQuotient-0.7.2/CMakeLists.txt
---- libQuotient-0.7.2.orig/CMakeLists.txt 2023-06-26 10:28:12.385892873 +0930
-+++ libQuotient-0.7.2/CMakeLists.txt 2023-06-26 11:30:48.835074310 +0930
-@@ -5,6 +5,7 @@ endif()
-
- set(API_VERSION "0.7")
- project(Quotient VERSION "${API_VERSION}.2" LANGUAGES CXX)
-+set(LIBRARY_NAME ${PROJECT_NAME}E2EE)
-
- message(STATUS)
- message(STATUS "Configuring ${PROJECT_NAME} ${PROJECT_VERSION} ==>")
-@@ -68,7 +69,7 @@ if (WIN32)
- endif()
- else()
- include(GNUInstallDirs)
-- set(CMakeFilesLocation "${CMAKE_INSTALL_LIBDIR}/cmake/${PROJECT_NAME}")
-+ set(CMakeFilesLocation "${CMAKE_INSTALL_LIBDIR}/cmake/${LIBRARY_NAME}")
- endif(WIN32)
- set(${PROJECT_NAME}_INSTALL_INCLUDEDIR
- "${CMAKE_INSTALL_INCLUDEDIR}/" CACHE PATH
-@@ -273,24 +274,24 @@ add_compile_options(
- -DQT_NO_FOREACH
- )
-
--add_library(${PROJECT_NAME} ${lib_SRCS} ${api_ALL_SRCS})
-+add_library(${LIBRARY_NAME} ${lib_SRCS} ${api_ALL_SRCS})
- # Set BUILDING_SHARED_QUOTIENT if building as a shared library
--target_compile_definitions(${PROJECT_NAME} PRIVATE
-- $<$<STREQUAL:$<TARGET_PROPERTY:${PROJECT_NAME},TYPE>,SHARED_LIBRARY>:BUILDING_SHARED_QUOTIENT>)
-+target_compile_definitions(${LIBRARY_NAME} PRIVATE
-+ $<$<STREQUAL:$<TARGET_PROPERTY:${LIBRARY_NAME},TYPE>,SHARED_LIBRARY>:BUILDING_SHARED_QUOTIENT>)
- # Set QUOTIENT_STATIC in a static library setting
--target_compile_definitions(${PROJECT_NAME} PUBLIC
-- $<$<STREQUAL:$<TARGET_PROPERTY:${PROJECT_NAME},TYPE>,STATIC_LIBRARY>:QUOTIENT_STATIC>)
--target_compile_definitions(${PROJECT_NAME} PRIVATE
-+target_compile_definitions(${LIBRARY_NAME} PUBLIC
-+ $<$<STREQUAL:$<TARGET_PROPERTY:${LIBRARY_NAME},TYPE>,STATIC_LIBRARY>:QUOTIENT_STATIC>)
-+target_compile_definitions(${LIBRARY_NAME} PRIVATE
- QT_NO_JAVA_STYLE_ITERATORS QT_NO_URL_CAST_FROM_STRING QT_NO_CAST_TO_ASCII
- QT_STRICT_ITERATORS QT_NO_CAST_FROM_BYTEARRAY)
-
--target_compile_definitions(${PROJECT_NAME} PUBLIC ${PROJECT_NAME}_VERSION_MAJOR=${PROJECT_VERSION_MAJOR}
-+target_compile_definitions(${LIBRARY_NAME} PUBLIC ${PROJECT_NAME}_VERSION_MAJOR=${PROJECT_VERSION_MAJOR}
- ${PROJECT_NAME}_VERSION_MINOR=${PROJECT_VERSION_MINOR} ${PROJECT_NAME}_VERSION_PATCH=${PROJECT_VERSION_PATCH}
- ${PROJECT_NAME}_VERSION_STRING=\"${PROJECT_VERSION}\")
- if (${PROJECT_NAME}_ENABLE_E2EE)
-- target_compile_definitions(${PROJECT_NAME} PUBLIC ${PROJECT_NAME}_E2EE_ENABLED)
-+ target_compile_definitions(${LIBRARY_NAME} PUBLIC ${PROJECT_NAME}_E2EE_ENABLED)
- endif()
--set_target_properties(${PROJECT_NAME} PROPERTIES
-+set_target_properties(${LIBRARY_NAME} PROPERTIES
- CXX_STANDARD 20
- CXX_EXTENSIONS OFF
- VISIBILITY_INLINES_HIDDEN ON
-@@ -299,33 +300,33 @@ set_target_properties(${PROJECT_NAME} PR
- SOVERSION ${API_VERSION}
- INTERFACE_${PROJECT_NAME}_MAJOR_VERSION ${API_VERSION}
- )
--set_property(TARGET ${PROJECT_NAME} APPEND PROPERTY
-+set_property(TARGET ${LIBRARY_NAME} APPEND PROPERTY
- COMPATIBLE_INTERFACE_STRING ${PROJECT_NAME}_MAJOR_VERSION)
-
--target_compile_features(${PROJECT_NAME} PUBLIC cxx_std_20)
-+target_compile_features(${LIBRARY_NAME} PUBLIC cxx_std_20)
- if (MSVC)
-- target_compile_options(${PROJECT_NAME} PUBLIC /Zc:preprocessor)
-+ target_compile_options(${LIBRARY_NAME} PUBLIC /Zc:preprocessor)
++ list(APPEND _include_dir "${_include_dir}/@QUOTIENT_LIB_NAME@")
+ set_target_properties(@QUOTIENT_LIB_NAME@ PROPERTIES INTERFACE_INCLUDE_DIRECTORIES "${_include_dir}")
endif()
-
- # Don't use PCH w/GCC (https://bugzilla.redhat.com/show_bug.cgi?id=1721553#c34)
- if (NOT CMAKE_CXX_COMPILER_ID STREQUAL GNU)
-- target_precompile_headers(${PROJECT_NAME} PRIVATE Quotient/converters.h)
-+ target_precompile_headers(${LIBRARY_NAME} PRIVATE Quotient/converters.h)
- endif ()
-
--target_include_directories(${PROJECT_NAME} PUBLIC
-+target_include_directories(${LIBRARY_NAME} PUBLIC
- $<BUILD_INTERFACE:${CMAKE_CURRENT_SOURCE_DIR}>
- $<BUILD_INTERFACE:$<$<NOT:$<BOOL:${QUOTIENT_FORCE_NAMESPACED_INCLUDES}>>:${CMAKE_CURRENT_SOURCE_DIR}/Quotient>>
- $<INSTALL_INTERFACE:${${PROJECT_NAME}_INSTALL_INCLUDEDIR}>
- )
-
--target_link_libraries(${PROJECT_NAME} PUBLIC ${Qt}::Core ${Qt}::Network ${Qt}::Gui qt${${Qt}Core_VERSION_MAJOR}keychain)
-+target_link_libraries(${LIBRARY_NAME} PUBLIC ${Qt}::Core ${Qt}::Network ${Qt}::Gui qt${${Qt}Core_VERSION_MAJOR}keychain)
- if (Qt STREQUAL Qt5) # See #483
-- target_link_libraries(${PROJECT_NAME} PRIVATE ${Qt}::Multimedia)
-+ target_link_libraries(${LIBRARY_NAME} PRIVATE ${Qt}::Multimedia)
+diff '--color=auto' -rupN libQuotient-0.8.0.orig/CMakeLists.txt libQuotient-0.8.0/CMakeLists.txt
+--- libQuotient-0.8.0.orig/CMakeLists.txt 2023-07-05 12:23:12.501208379 +0930
++++ libQuotient-0.8.0/CMakeLists.txt 2023-07-05 12:40:00.568400131 +0930
+@@ -52,10 +52,12 @@ else()
endif()
- set(FIND_DEPS "find_dependency(${Qt}Keychain)") # For QuotientConfig.cmake.in
- if (${PROJECT_NAME}_ENABLE_E2EE)
-- target_link_libraries(${PROJECT_NAME}
-+ target_link_libraries(${LIBRARY_NAME}
- PUBLIC
- Olm::Olm
- ${Qt}::Sql
-@@ -338,7 +339,7 @@ if (${PROJECT_NAME}_ENABLE_E2EE)
- find_dependency(${Qt}Sql)")
+ option(BUILD_WITH_QT6 "Build Quotient with Qt 6 (EXPERIMENTAL)" OFF)
++set(QUOTIENT_LIB_NAME ${PROJECT_NAME})
+ if (BUILD_WITH_QT6)
+- set(QUOTIENT_LIB_NAME ${PROJECT_NAME}Qt6)
+-else()
+- set(QUOTIENT_LIB_NAME ${PROJECT_NAME})
++ set(QUOTIENT_LIB_NAME ${QUOTIENT_LIB_NAME}Qt6)
++endif()
++if (${PROJECT_NAME}_ENABLE_E2EE)
++ set(QUOTIENT_LIB_NAME ${QUOTIENT_LIB_NAME}E2EE)
endif()
--configure_file(${PROJECT_NAME}.pc.in ${CMAKE_CURRENT_BINARY_DIR}/${PROJECT_NAME}.pc @ONLY NEWLINE_STYLE UNIX)
-+configure_file(${PROJECT_NAME}.pc.in ${CMAKE_CURRENT_BINARY_DIR}/${LIBRARY_NAME}.pc @ONLY NEWLINE_STYLE UNIX)
-
- # Configure testing
-
-@@ -350,45 +351,45 @@ endif()
-
- # Configure installation
-
--install(TARGETS ${PROJECT_NAME} EXPORT ${PROJECT_NAME}Targets
-+install(TARGETS ${LIBRARY_NAME} EXPORT ${LIBRARY_NAME}Targets
+ if (WIN32)
+@@ -355,7 +357,7 @@ install(TARGETS ${QUOTIENT_LIB_NAME} EXP
LIBRARY RUNTIME
ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR}
)
-install(DIRECTORY Quotient/ DESTINATION ${${PROJECT_NAME}_INSTALL_INCLUDEDIR}/Quotient
-+install(DIRECTORY Quotient/ DESTINATION ${${PROJECT_NAME}_INSTALL_INCLUDEDIR}/${LIBRARY_NAME}
++install(DIRECTORY Quotient/ DESTINATION ${${PROJECT_NAME}_INSTALL_INCLUDEDIR}/${QUOTIENT_LIB_NAME}
FILES_MATCHING PATTERN "*.h")
include(CMakePackageConfigHelpers)
- # NB: SameMajorVersion doesn't really work yet, as we're within 0.x trail.
- # Maybe consider jumping the gun and releasing 1.0, as semver advises?
- write_basic_package_version_file(
-- "${CMAKE_CURRENT_BINARY_DIR}/${PROJECT_NAME}/${PROJECT_NAME}ConfigVersion.cmake"
-+ "${CMAKE_CURRENT_BINARY_DIR}/${LIBRARY_NAME}/${LIBRARY_NAME}ConfigVersion.cmake"
- COMPATIBILITY SameMajorVersion
- )
-
--export(PACKAGE ${PROJECT_NAME})
--export(EXPORT ${PROJECT_NAME}Targets
-- FILE "${CMAKE_CURRENT_BINARY_DIR}/${PROJECT_NAME}/${PROJECT_NAME}Targets.cmake")
-+export(PACKAGE ${LIBRARY_NAME})
-+export(EXPORT ${LIBRARY_NAME}Targets
-+ FILE "${CMAKE_CURRENT_BINARY_DIR}/${LIBRARY_NAME}/${LIBRARY_NAME}Targets.cmake")
- configure_file(cmake/${PROJECT_NAME}Config.cmake.in
-- "${CMAKE_CURRENT_BINARY_DIR}/${PROJECT_NAME}/${PROJECT_NAME}Config.cmake"
-+ "${CMAKE_CURRENT_BINARY_DIR}/${LIBRARY_NAME}/${LIBRARY_NAME}Config.cmake"
- @ONLY
- )
-
--install(EXPORT ${PROJECT_NAME}Targets
-- FILE ${PROJECT_NAME}Targets.cmake DESTINATION ${CMakeFilesLocation})
-+install(EXPORT ${LIBRARY_NAME}Targets
-+ FILE ${LIBRARY_NAME}Targets.cmake DESTINATION ${CMakeFilesLocation})
-
- install(FILES
-- "${CMAKE_CURRENT_BINARY_DIR}/${PROJECT_NAME}/${PROJECT_NAME}Config.cmake"
-- "${CMAKE_CURRENT_BINARY_DIR}/${PROJECT_NAME}/${PROJECT_NAME}ConfigVersion.cmake"
-+ "${CMAKE_CURRENT_BINARY_DIR}/${LIBRARY_NAME}/${LIBRARY_NAME}Config.cmake"
-+ "${CMAKE_CURRENT_BINARY_DIR}/${LIBRARY_NAME}/${LIBRARY_NAME}ConfigVersion.cmake"
+@@ -387,7 +389,7 @@ install(FILES
+ "${CMAKE_CURRENT_BINARY_DIR}/${QUOTIENT_LIB_NAME}/${QUOTIENT_LIB_NAME}ConfigVersion.cmake"
DESTINATION ${CMakeFilesLocation}
)
--install(EXPORT_ANDROID_MK ${PROJECT_NAME}Targets DESTINATION ${CMAKE_INSTALL_DATADIR}/ndk-modules)
-+#install(EXPORT_ANDROID_MK ${PROJECT_NAME}Targets DESTINATION ${CMAKE_INSTALL_DATADIR}/ndk-modules)
+-install(EXPORT_ANDROID_MK ${QUOTIENT_LIB_NAME}Targets DESTINATION ${CMAKE_INSTALL_DATADIR}/ndk-modules)
++#install(EXPORT_ANDROID_MK ${QUOTIENT_LIB_NAME}Targets DESTINATION ${CMAKE_INSTALL_DATADIR}/ndk-modules)
if (WIN32)
install(FILES mime/packages/freedesktop.org.xml DESTINATION mime/packages)
- endif (WIN32)
-
- if (UNIX AND NOT APPLE)
-- install(FILES ${CMAKE_CURRENT_BINARY_DIR}/${PROJECT_NAME}.pc
-+ install(FILES ${CMAKE_CURRENT_BINARY_DIR}/${LIBRARY_NAME}.pc
- DESTINATION ${CMAKE_INSTALL_LIBDIR}/pkgconfig)
- endif()
-
-diff '--color=auto' -rupN libQuotient-0.7.2.orig/Quotient.pc.in libQuotient-0.7.2/Quotient.pc.in
---- libQuotient-0.7.2.orig/Quotient.pc.in 2023-06-26 10:28:12.385892873 +0930
-+++ libQuotient-0.7.2/Quotient.pc.in 2023-06-26 11:04:31.648488210 +0930
+diff '--color=auto' -rupN libQuotient-0.8.0.orig/Quotient.pc.in libQuotient-0.8.0/Quotient.pc.in
+--- libQuotient-0.8.0.orig/Quotient.pc.in 2023-07-05 12:23:12.501208379 +0930
++++ libQuotient-0.8.0/Quotient.pc.in 2023-07-05 12:44:01.419228176 +0930
@@ -3,8 +3,8 @@ exec_prefix=${prefix}
includedir=${prefix}/@CMAKE_INSTALL_INCLUDEDIR@
libdir=${prefix}/@CMAKE_INSTALL_LIBDIR@
-Name: Quotient
-+Name: @LIBRARY_NAME@
- Description: A Qt5 library to write cross-platfrom clients for Matrix
+-Description: A Qt5 library to write cross-platfrom clients for Matrix
++Name: @QUOTIENT_LIB_NAME@
++Description: A @Qt@ library to write cross-platfrom clients for Matrix
Version: @API_VERSION@
Cflags: -I${includedir}
-Libs: -L${libdir} -lQuotient
-+Libs: -L${libdir} -l@LIBRARY_NAME@
++Libs: -L${libdir} -l@QUOTIENT_LIB_NAME@