summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPer Osbäck2018-05-14 20:37:37 +0200
committerPer Osbäck2018-05-14 20:39:40 +0200
commite4ba97764d295d2af953023edba5c83e64631f5b (patch)
treee7c135e5db11c079d24d5a41584ab034eb6adafb
downloadaur-e4ba97764d295d2af953023edba5c83e64631f5b.tar.gz
packaging of perfops-cli
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD26
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..55f55a0aff30
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = perfops-cli
+ pkgdesc = A simple command line tool to interact with hundreds of servers around the world. Run benchmarks and debug your infrastructure without leaving your console.
+ pkgver = 0.7.0
+ pkgrel = 1
+ url = https://perfops.net
+ arch = x86_64
+ license = APACHE
+ makedepends = git
+ makedepends = go
+ source = perfops-cli::git+https://github.com/ProspectOne/perfops-cli.git#tag=v0.7.0
+ md5sums = SKIP
+
+pkgname = perfops-cli
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..804c35c236d4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Per Osbeck <per@osbeck.com>
+pkgname=perfops-cli
+pkgver=0.7.0
+pkgrel=1
+pkgdesc="A simple command line tool to interact with hundreds of servers around the world. Run benchmarks and debug your infrastructure without leaving your console."
+arch=(x86_64)
+url="https://perfops.net"
+license=('APACHE')
+makedepends=('git' 'go')
+source=("$pkgname::git+https://github.com/ProspectOne/$pkgname.git#tag=v$pkgver")
+md5sums=(SKIP)
+
+build() {
+ cd "$pkgname"
+ PERFOPS_BUILD_PLATFORMS=linux bash hack/build-all.sh
+}
+
+# check() {
+# #
+# }
+
+package() {
+ cd "$pkgname"
+ install -Dm755 "release/perfops-linux-amd64" "$pkgdir/usr/bin/perfops-cli"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$_pkgname/LICENSE"
+}