summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHyacinthe Cartiaux2014-02-07 15:39:07 +0100
committerHyacinthe Cartiaux2015-06-09 14:09:39 +0200
commite4e37824e357229eec221e62757a6bbbe5db0c42 (patch)
tree56cc5a9d26ad78a6e8b5a732ca2f6bd71da8d999
parent544555ad87964b215e39d3e34915c42097036234 (diff)
downloadaur-e4e37824e357229eec221e62757a6bbbe5db0c42.tar.gz
[powerstat-git] Fix makedepends, url and license
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD17
2 files changed, 13 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5026c4359aea..80a5038d3e55 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,12 @@
pkgbase = powerstat-git
pkgdesc = a tool for measuring a laptops power usage via the battery
- pkgver = 20120328
+ pkgver = 20140207
pkgrel = 1
- url = http://kernel.ubuntu.com/git?p=cking/powerstat.git
+ url = http://kernel.ubuntu.com/~cking/powerstat/
arch = i686
arch = x86_64
- license = GPL
- makedepends = make
+ license = GPL2
+ makedepends = git
depends = glibc
provides = powerstat
diff --git a/PKGBUILD b/PKGBUILD
index c7842f2e1ce1..5d979b940caf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,15 @@
-# Maintainer: Eugeni Dodonov <eugeni@dodonov.net>
+# Maintainer: Hyacinthe Cartiaux <hyacinthe.cartiaux@free.fr>
+# Contributor: Eugeni Dodonov <eugeni@dodonov.net>
pkgname=powerstat-git
-pkgver=20120328
+pkgver=20140207
pkgrel=1
pkgdesc="a tool for measuring a laptops power usage via the battery"
arch=(i686 x86_64)
-url="http://kernel.ubuntu.com/git?p=cking/powerstat.git"
-license=(GPL)
+url="http://kernel.ubuntu.com/~cking/powerstat/"
+license=(GPL2)
depends=(glibc)
-makedepends=(make)
+makedepends=(git)
provides=('powerstat')
@@ -18,14 +19,14 @@ _gitname=powerstat
build() {
cd ${srcdir}
if [ -d $_gitname ] ; then
- ( cd $_gitname && git pull )
+ ( cd $_gitname && git pull )
else
git clone $_gitroot
fi
-
+
rm -rf "${_gitname}_build"
cp -r "${_gitname}" "${_gitname}_build"
-
+
cd "${_gitname}_build/"
make
}