summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorErik Dubois2017-07-14 13:30:43 +0200
committerErik Dubois2017-07-14 13:30:43 +0200
commite4ebfb6330c0c3bb16d5c29fe9cd308d72e3b235 (patch)
treea00b6452a8c9ee277e09462c036fecdd68104a8b
downloadaur-e4ebfb6330c0c3bb16d5c29fe9cd308d72e3b235.tar.gz
commit from @ Fri Jul 14 13:30:43 CEST 2017
-rw-r--r--.SRCINFO20
-rwxr-xr-xPKGBUILD29
-rwxr-xr-xgit.sh16
3 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0a8c8455dd50
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+# Generated by mksrcinfo v8
+# Fri Jul 14 11:30:43 UTC 2017
+pkgbase = numix-circle-arc-icons-git
+ pkgdesc = Install Numix and Numix Circle. Numix icons combined with the Arc folders
+ pkgver = 9.3
+ pkgrel = 0
+ arch = any
+ license = Attribution-NonCommercial-ShareAlike 4.0 International Public License
+ makedepends = git
+ depends = numix-circle-icon-theme-git
+ depends = numix-icon-theme-git
+ provides = numix-circle-arc-icons-git
+ conflicts = numix-circle-arc-icons-git
+ options = !strip
+ options = !emptydirs
+ source = numix-circle-arc-icons::git+https://github.com/erikdubois/Numix-Circle-Arc
+ sha256sums = SKIP
+
+pkgname = numix-circle-arc-icons-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..e1bb31503368
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Erik Dubois <erik.dubois@gmail.com>
+pkgname=numix-circle-arc-icons-git
+_pkgname=numix-circle-arc-icons
+_destname="/usr/share/icons/"
+_pkggithub="https://github.com/erikdubois/Numix-Circle-Arc"
+pkgdesc="Install Numix and Numix Circle. Numix icons combined with the Arc folders"
+pkgver=9.3
+pkgrel=0
+arch=('any')
+url="${pkggithub}"
+license=('Attribution-NonCommercial-ShareAlike 4.0 International Public License')
+makedepends=('git')
+depends=('numix-circle-icon-theme-git' 'numix-icon-theme-git')
+provides=("${pkgname}")
+conflicts=("${pkgname}")
+options=(!strip !emptydirs)
+source=("${_pkgname}"::git+"${_pkggithub}")
+sha256sums=('SKIP')
+
+
+package() {
+ rm -f "${srcdir}/${_pkgname}/"README.md
+ rm -f "${srcdir}/${_pkgname}/"git-v*
+ rm -f "${srcdir}/${_pkgname}/"setup*
+ install -dm 755 "${pkgdir}"/"${_destname}"
+ cp -dr --no-preserve='ownership' ${_pkgname}/* "${pkgdir}"/usr/share/icons/
+}
+
+
diff --git a/git.sh b/git.sh
new file mode 100755
index 000000000000..275cdf15587c
--- /dev/null
+++ b/git.sh
@@ -0,0 +1,16 @@
+#!/bin/bash
+############################################################################
+# Author : Erik Dubois
+# Website : http://www.erikdubois.be
+############################################################################
+
+
+mksrcinfo
+git add --all .
+
+# Committing to the local repository with a message containing the time details
+curtime=$(date)
+git commit -m "commit from @ $curtime"
+
+# Push the local snapshot to a remote destination
+git push -u origin master \ No newline at end of file