summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTimothy Redaelli2015-08-18 19:51:54 +0200
committerTimothy Redaelli2015-08-18 20:02:42 +0200
commite50409e30f36fc2a33160dd1c4b1b9ee59fab4de (patch)
treeff7800a52e71fdec1bf7b46012579f0f19654894
downloadaur-e50409e30f36fc2a33160dd1c4b1b9ee59fab4de.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD31
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c7eb175dc4ab
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = ucommon
+ pkgdesc = A light-weight C++ library to facilitate using C++ design patterns
+ pkgver = 6.5.3
+ pkgrel = 1
+ url = http://www.gnutelephony.org/index.php/GNU_uCommon_C++
+ arch = i686
+ arch = x86_64
+ license = LGPL3
+ depends = gnutls
+ source = http://ftp.gnu.org/pub/gnu/commoncpp/ucommon-6.5.3.tar.gz
+ source = http://ftp.gnu.org/pub/gnu/commoncpp/ucommon-6.5.3.tar.gz.sig
+ md5sums = 9bee591419a3377644e01ec615b9ca6c
+ md5sums = SKIP
+
+pkgname = ucommon
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c709db96dfa5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Timothy Redaelli <timothy.redaelli@gmail.com>
+# Contributor: Sergej Pupykin <pupykin.s+arch@gmail.com>
+
+pkgname=ucommon
+pkgver=6.5.3
+pkgrel=1
+pkgdesc="A light-weight C++ library to facilitate using C++ design patterns"
+arch=('i686' 'x86_64')
+url="http://www.gnutelephony.org/index.php/GNU_uCommon_C++"
+license=('LGPL3')
+depends=('gnutls')
+source=("http://ftp.gnu.org/pub/gnu/commoncpp/$pkgname-$pkgver.tar.gz"{,.sig})
+md5sums=('9bee591419a3377644e01ec615b9ca6c'
+ 'SKIP')
+validpgpkeys=('5CF995AAD5CC1E4079F76C38B1732A9CB37C87BA')
+
+build() {
+ cd ${pkgname}-${pkgver}
+ ./configure --prefix=/usr --with-sslstack=gnu --enable-socks --enable-stdcpp --enable-atomics --with-pkg-config
+ make
+}
+
+check() {
+ cd ${pkgname}-${pkgver}
+ make check
+}
+
+package() {
+ cd ${pkgname}-${pkgver}
+ make DESTDIR="${pkgdir}" install
+}