summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortimttmy2015-08-08 21:10:24 +0100
committertimttmy2015-08-08 21:10:24 +0100
commite50b60aea6f60a3a4b29a4abe7274d9748f0479a (patch)
treeeddf1133e003cc2765e6e8e76b2972991eab4010
downloadaur-e50b60aea6f60a3a4b29a4abe7274d9748f0479a.tar.gz
Initial
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD31
-rw-r--r--heybuddy.desktop9
-rw-r--r--heybuddy.install21
4 files changed, 85 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8324873ce097
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = heybuddy
+ pkgdesc = A light/feature free client for the identi.ca microblogging site.
+ pkgver = 0.2.5
+ pkgrel = 3
+ url = https://launchpad.net/heybuddy/
+ install = heybuddy.install
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = sed
+ depends = python2
+ depends = pygtk
+ optdepends = gtkspell
+ optdepends = python2-gtkspell
+ optdepends = libnotify
+ provides = heybuddy
+ conflicts = heybuddy-trunk-bzr
+ source = http://launchpad.net/heybuddy/0.2/0.2.5/+download/heybuddy-0.2.5.tgz
+ source = heybuddy.desktop
+ md5sums = d5ee49ecad0d0efd9f1ca1990bc1c792
+ md5sums = 68d0c01882c9db6ae6381b49e3507eea
+
+pkgname = heybuddy
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..32c1cc40c4ad
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: timttmy <marshall\\dot//cleave\\at//tiscali\\dot//co\\dot//uk>
+
+pkgname=heybuddy
+pkgver=0.2.5
+pkgrel=3
+pkgdesc="A light/feature free client for the identi.ca microblogging site."
+arch=('i686' 'x86_64')
+url="https://launchpad.net/heybuddy/"
+license=('GPL3')
+depends=('python2' 'pygtk')
+makedepends=('sed')
+optdepends=('gtkspell' 'python2-gtkspell' 'libnotify')
+provides=(heybuddy)
+conflicts=(heybuddy-trunk-bzr)
+install=heybuddy.install
+source=(http://launchpad.net/heybuddy/0.2/$pkgver/+download/$pkgname-$pkgver.tgz $pkgname.desktop)
+md5sums=('d5ee49ecad0d0efd9f1ca1990bc1c792' '68d0c01882c9db6ae6381b49e3507eea')
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ sed -i 's/env\ python/env\ python2/' heybuddy.py || return 1
+}
+package() {
+ mkdir -p "$pkgdir/usr/share/heybuddy" || return 1
+ mkdir -p "$pkgdir/usr/bin/" || return 1
+ mkdir -p "$pkgdir/usr/share/pixmaps/" || return 1
+ cp -a ./ "$pkgdir/usr/share/heybuddy/" || return 1
+ ln -sf /usr/share/heybuddy/heybuddy.py "$pkgdir/usr/bin/heybuddy" || return 1
+ install -m 644 $srcdir/$pkgname-$pkgver/assets/icon.png "$pkgdir/usr/share/pixmaps/$pkgname.png"
+ install -Dm644 $startdir/$pkgname.desktop "$pkgdir/usr/share/applications/$pkgname.desktop"
+ python2 -m compileall "$pkgdir/usr/share/heybuddy"
+}
diff --git a/heybuddy.desktop b/heybuddy.desktop
new file mode 100644
index 000000000000..414f973a23e3
--- /dev/null
+++ b/heybuddy.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Exec=heybuddy
+Name=heybuddy
+Comment=Statusnet µblogging client
+Type=Application
+Terminal=false
+Icon=heybuddy.png
+Caption=A light/feature free client for the identi.ca microblogging site.
+Categories=Application;Network
diff --git a/heybuddy.install b/heybuddy.install
new file mode 100644
index 000000000000..bd17ded1c40f
--- /dev/null
+++ b/heybuddy.install
@@ -0,0 +1,21 @@
+post_install() {
+echo ""
+echo "-Spellchecking in heybuddy-"
+echo ""
+echo "Optional dependences for spellcheck"
+echo ""
+echo "gtkspell"
+echo "python-gtkspell from AUR"
+echo "aspell-{locale}"
+echo ""
+echo ""
+echo "Recommended optional dependency for Openbox users"
+echo "xfce4-notifyd"
+echo "A light weight notification server"
+echo ""
+}
+
+post_upgrade() {
+ post_install
+}
+