summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorokasha2021-02-08 18:06:44 +0200
committerokasha2021-02-08 18:06:44 +0200
commite5295ec734d4f6f98f8fdeb6848f46eed9c7a6c1 (patch)
tree8ff45e23bb5f95a25400a330bc6ffd0b5ef0a8dd
parent04f73c40ff822351f24ea4c5388f6155401ccb06 (diff)
downloadaur-e5295ec734d4f6f98f8fdeb6848f46eed9c7a6c1.tar.gz
cleaning up and update to version 2.4.1
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD35
2 files changed, 27 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f116439f9e06..562716ec5a41 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,18 @@
pkgbase = digilent.adept.utilities
- pkgdesc = The Adept configuration tools
- pkgver = 2.3.2
- pkgrel = 2
+ pkgdesc = Digilent Adept Utilities.
+ pkgver = 2.4.1
+ pkgrel = 1
url = https://reference.digilentinc.com/digilent_adept_2
- arch = x86_64
arch = i686
+ arch = x86_64
license = custom
- depends = digilent.adept.runtime
+ depends = digilent.adept.runtime>=2.21.2
options = !strip
- source_x86_64 = https://digilent.s3.amazonaws.com/Software/AdeptUtilities/2.3.2/digilent.adept.utilities_2.3.2-amd64.deb
- sha256sums_x86_64 = ec9eef8340619aeba7d2f10dda63f05be35346302ad1b8f03e1f324f52665b20
- source_i686 = https://digilent.s3.amazonaws.com/Software/AdeptUtilities/2.3.2/digilent.adept.utilities_2.3.2-i386.deb
- sha256sums_i686 = 12a3ef87ee861c259633d778cf6becba9a5a28f3d079828efe79d7b7169474d7
+ options = !emptydirs
+ source_i686 = https://digilent.s3.amazonaws.com/Software/AdeptUtilities/2.4.1/digilent.adept.utilities_2.4.1-i386.deb
+ sha256sums_i686 = fa4b2f7c9c08c302e177142162497487d3b27cbc7136010f012cb3e3e9c1edc3
+ source_x86_64 = https://digilent.s3.amazonaws.com/Software/AdeptUtilities/2.4.1/digilent.adept.utilities_2.4.1-amd64.deb
+ sha256sums_x86_64 = a05d2c13df1639e92aa96f4532b1990ef1166059bd361da0259d5b0cca3c7be6
pkgname = digilent.adept.utilities
diff --git a/PKGBUILD b/PKGBUILD
index 7a931f2ee346..dedd4d50f094 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,26 @@
-# Maintainer: Knight <anonymousknight96 AT gmail.com>
-
+# Maintainer: Amr Okasha <amradel55 at gmail dot com>
+# Contributer: Knight <anonymousknight96 at gmail dot com>
pkgname=digilent.adept.utilities
-pkgver='2.3.2'
-pkgrel=2
-pkgdesc="The Adept configuration tools"
-arch=('x86_64' 'i686')
-url='https://reference.digilentinc.com/digilent_adept_2'
+pkgver=2.4.1
+pkgrel=1
+pkgdesc="Digilent Adept Utilities."
+arch=('i686' 'x86_64')
+url="https://reference.digilentinc.com/digilent_adept_2"
license=('custom')
-depends=('digilent.adept.runtime')
-options=('!strip')
+depends=('digilent.adept.runtime>=2.21.2')
+options=('!strip' '!emptydirs')
source_x86_64=("https://digilent.s3.amazonaws.com/Software/AdeptUtilities/${pkgver}/${pkgname}_${pkgver}-amd64.deb")
source_i686=("https://digilent.s3.amazonaws.com/Software/AdeptUtilities/${pkgver}/${pkgname}_${pkgver}-i386.deb")
-sha256sums_x86_64=('ec9eef8340619aeba7d2f10dda63f05be35346302ad1b8f03e1f324f52665b20')
-sha256sums_i686=('12a3ef87ee861c259633d778cf6becba9a5a28f3d079828efe79d7b7169474d7')
+sha256sums_i686=('fa4b2f7c9c08c302e177142162497487d3b27cbc7136010f012cb3e3e9c1edc3')
+sha256sums_x86_64=('a05d2c13df1639e92aa96f4532b1990ef1166059bd361da0259d5b0cca3c7be6')
package(){
- tar -xJf data.tar.xz --exclude="usr/share/lintian" -C "${pkgdir}"/
- [ -d "${pkgdir}"/usr/lib64 ] && mv "${pkgdir}"/usr/{lib64,lib}
- [ -d "${pkgdir}"/usr/sbin ] && mv "${pkgdir}"/usr/{sbin,bin}
+ # Extract package data
+ tar -xJf data.tar.xz -C "${pkgdir}"/
- install -dm 755 "${pkgdir}/usr/share/licenses/${pkgname}"
- ln -s "/usr/share/doc/${pkgname}/copyright" "${pkgdir}/usr/share/licenses/${pkgname}/copyright"
- ln -s "/usr/share/doc/${pkgname}/EULA" "${pkgdir}/usr/share/licenses/${pkgname}/EULA"
-}
+ install -dm 755 "${pkgdir}/usr/share/licenses/${pkgname}"
+ ln -s "/usr/share/doc/${pkgname}/copyright" "${pkgdir}/usr/share/licenses/${pkgname}/copyright"
+ ln -s "/usr/share/doc/${pkgname}/EULA" "${pkgdir}/usr/share/licenses/${pkgname}/EULA"
+}