summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2023-06-20 21:30:30 -0300
committerDaniel Bermond2023-06-20 21:30:30 -0300
commite53fe0707ee6b6b400e34921993b0a9433b90456 (patch)
treea0a6abc9bdfde1839cbe72383af92fd978029892
parent9fb5bebd72ead956b81aa2e7dacdf0c2315f45ac (diff)
downloadaur-e53fe0707ee6b6b400e34921993b0a9433b90456.tar.gz
Fix build. Change vulkan dependency. Switch libmfx to onevpl.
'--enable-nonfree' was accidentally dropped in the last update, causing a build error. Fixed by adding it again. Changed libvulkan dependency to match[1][2] the repository package. package. Intel Media SDK (libmfx) was discontinued[3] by upstream. Switched to the sucessor, onevpl, as recommended by upstream. This adds support for new Intel hardware, and drops support for the so called "legacy" hardware. [1] https://gitlab.archlinux.org/archlinux/packaging/packages/ffmpeg/-/commit/da2f83c16c1dca710f58ccaa5245bba0b9e24b4d [2] https://gitlab.archlinux.org/archlinux/packaging/packages/ffmpeg/-/commit/5670ccd86d3b816f49ebc18cab878125eca2f81f [3] https://github.com/Intel-Media-SDK/MediaSDK/commit/7a72de33a15d6e7cdb842b12b901a003f7154f0a
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD15
2 files changed, 12 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c62f51fcfcab..39b3a34dd2a2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ffmpeg-decklink
pkgdesc = Complete solution to record, convert and stream audio and video (decklink enabled)
pkgver = 6.0
- pkgrel = 1
+ pkgrel = 2
epoch = 1
url = https://www.ffmpeg.org/
arch = x86_64
@@ -36,7 +36,6 @@ pkgbase = ffmpeg-decklink
depends = libgl
depends = libiec61883
depends = libjxl.so
- depends = libmfx
depends = libmodplug
depends = libopenmpt.so
depends = libpulse
@@ -54,7 +53,6 @@ pkgbase = ffmpeg-decklink
depends = libvorbisenc.so
depends = libvorbis.so
depends = libvpx.so
- depends = libvulkan.so
depends = libwebp
depends = libx11
depends = libx264.so
@@ -66,6 +64,7 @@ pkgbase = ffmpeg-decklink
depends = libxvidcore.so
depends = libzimg.so
depends = ocl-icd
+ depends = onevpl
depends = opencore-amr
depends = openjpeg2
depends = opus
@@ -75,12 +74,13 @@ pkgbase = ffmpeg-decklink
depends = svt-av1
depends = v4l-utils
depends = vmaf
+ depends = vulkan-icd-loader
depends = xz
depends = zlib
optdepends = avisynthplus: for AviSynthPlus support
- optdepends = intel-media-sdk: for Intel Quick Sync Video
optdepends = ladspa: for LADSPA filters
optdepends = nvidia-utils: for Nvidia NVDEC/NVENC support
+ optdepends = onevpl-intel-gpu: for Intel Quick Sync Video
provides = libavcodec.so
provides = libavdevice.so
provides = libavfilter.so
diff --git a/PKGBUILD b/PKGBUILD
index 1d36f46bbc04..cb75691076e4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=ffmpeg-decklink
pkgver=6.0
-pkgrel=1
+pkgrel=2
epoch=1
pkgdesc='Complete solution to record, convert and stream audio and video (decklink enabled)'
arch=('x86_64')
@@ -30,7 +30,6 @@ depends=(
libgl
libiec61883
libjxl.so
- libmfx
libmodplug
libopenmpt.so
libpulse
@@ -48,7 +47,6 @@ depends=(
libvorbisenc.so
libvorbis.so
libvpx.so
- libvulkan.so
libwebp
libx11
libx264.so
@@ -60,6 +58,7 @@ depends=(
libxvidcore.so
libzimg.so
ocl-icd
+ onevpl
opencore-amr
openjpeg2
opus
@@ -69,6 +68,7 @@ depends=(
svt-av1
v4l-utils
vmaf
+ vulkan-icd-loader
xz
zlib
)
@@ -85,9 +85,9 @@ makedepends=(
decklink-sdk
)
optdepends=('avisynthplus: for AviSynthPlus support'
- 'intel-media-sdk: for Intel Quick Sync Video'
'ladspa: for LADSPA filters'
- 'nvidia-utils: for Nvidia NVDEC/NVENC support')
+ 'nvidia-utils: for Nvidia NVDEC/NVENC support'
+ 'onevpl-intel-gpu: for Intel Quick Sync Video')
provides=('libavcodec.so' 'libavdevice.so' 'libavfilter.so' 'libavformat.so'
'libavutil.so' 'libpostproc.so' 'libswresample.so' 'libswscale.so'
'ffmpeg')
@@ -138,7 +138,6 @@ build() {
--enable-libiec61883 \
--enable-libjack \
--enable-libjxl \
- --enable-libmfx \
--enable-libmodplug \
--enable-libmp3lame \
--enable-libopencore_amrnb \
@@ -159,6 +158,7 @@ build() {
--enable-libvidstab \
--enable-libvmaf \
--enable-libvorbis \
+ --enable-libvpl \
--enable-libvpx \
--enable-libwebp \
--enable-libx264 \
@@ -174,7 +174,8 @@ build() {
--enable-shared \
--enable-version3 \
--enable-vulkan \
- --enable-decklink
+ --enable-decklink \
+ --enable-nonfree
make
make tools/qt-faststart
}