summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWard Segers2018-12-18 00:00:02 +0100
committerWard Segers2018-12-18 00:00:02 +0100
commite549af5d842ee7c8bbe3c2cf4ab61f1b15ae55d6 (patch)
treeef6a025589ce4b16669da547f425d573a66a9d33
downloadaur-e549af5d842ee7c8bbe3c2cf4ab61f1b15ae55d6.tar.gz
r-bsda package
-rw-r--r--.SRCINFO15
-rw-r--r--.gitlab-ci.yml15
-rw-r--r--PKGBUILD25
3 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..265a86c5d545
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = r-bsda
+ pkgdesc = R Basic Statistics and Data Analysis
+ pkgver = 1.2.0
+ pkgrel = 1
+ url = https://cran.r-project.org/package=expm
+ arch = x86_64
+ license = GPL
+ depends = r
+ depends = r-e1071
+ replaces = r-cran-bsda
+ source = https://cran.r-project.org/src/contrib/BSDA_1.2.0.tar.gz
+ sha512sums = b169d21dfa74498f6c8244229162d340e7995bf1be4dd7a6149981d3bdba3bdd777b7d91127f93a887b2c5ee645781503fd1b14200ed2e84b4d371cb0a49ea53
+
+pkgname = r-bsda
+
diff --git a/.gitlab-ci.yml b/.gitlab-ci.yml
new file mode 100644
index 000000000000..97d498b7f4e2
--- /dev/null
+++ b/.gitlab-ci.yml
@@ -0,0 +1,15 @@
+image: "imrehg/archlinux-makepkg"
+
+before_script:
+- sudo pacman -Syu --noconfirm
+
+package:
+ script:
+ - makepkg -s --noconfirm
+ artifacts:
+ paths:
+ - pkg/
+ - r-bsda-*.tar.xz
+ expire_in: 2 days
+
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1028f5708517
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Ward Segers <w@rdsegers.be>
+# Contributor: Alex Branham <alex.branham@gmail.com>
+
+_cranver=1.2.0
+pkgname=r-bsda
+pkgver=${_cranver//[:-]/.}
+pkgrel=1
+pkgdesc='R Basic Statistics and Data Analysis'
+arch=('x86_64')
+url='https://cran.r-project.org/package=expm'
+license=('GPL')
+depends=('r' 'r-e1071')
+replaces=('r-cran-bsda')
+source=("https://cran.r-project.org/src/contrib/BSDA_"$_cranver".tar.gz")
+sha512sums=('b169d21dfa74498f6c8244229162d340e7995bf1be4dd7a6149981d3bdba3bdd777b7d91127f93a887b2c5ee645781503fd1b14200ed2e84b4d371cb0a49ea53')
+
+build(){
+ R CMD INSTALL BSDA_"$_cranver".tar.gz -l "$srcdir"
+}
+
+package() {
+ install -dm0755 "$pkgdir"/usr/lib/R/library
+ cp -a --no-preserve=ownership BSDA "$pkgdir"/usr/lib/R/library
+}
+