summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJacek Szafarkiewicz2021-04-26 12:36:15 +0200
committerJacek Szafarkiewicz2021-04-26 12:36:15 +0200
commite580aac9ccc84b8c70aab08e403c52b5c448fade (patch)
tree3971afd03b280daf2db1a9e606aadeb8bf8ab991
parent15fe763dbcceaee73aeac7c1132415fe97d3e569 (diff)
downloadaur-e580aac9ccc84b8c70aab08e403c52b5c448fade.tar.gz
Update build script
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD61
-rwxr-xr-xsunshine9
3 files changed, 50 insertions, 44 deletions
diff --git a/.SRCINFO b/.SRCINFO
index affa688d22f0..b1126e72fb50 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,30 @@
pkgbase = sunshine-git
pkgdesc = Open source implementation of NVIDIA's GameStream, as used by the NVIDIA Shield
- pkgver = 0.4.0.q.290415dec3..
+ pkgver = 0.4.0.310.488d8e5
pkgrel = 1
- url = http://sunshine-stream.com
+ url = https://github.com/loki-47-6F-64/sunshine
arch = x86_64
arch = i686
license = GPL3
makedepends = git
makedepends = cmake
- depends = boost
+ makedepends = boost
+ depends = boost-libs
+ depends = ffmpeg
+ depends = openssl
+ depends = libpulse
+ depends = opus
+ depends = libxtst
+ depends = libx11
+ depends = libxfixes
+ depends = libevdev
+ depends = libxcb
provides = sunshine
conflicts = sunshine
- source = sunshine-git::git+https://github.com/loki-47-6F-64/sunshine
- source = sunshine
- sha512sums = SKIP
- sha512sums = SKIP
+ source = sunshine-git::git+https://github.com/loki-47-6F-64/sunshine.git
+ source = systemd-cleanup.patch::https://patch-diff.githubusercontent.com/raw/loki-47-6F-64/sunshine/pull/42.patch
+ sha256sums = SKIP
+ sha256sums = f785ab0ac13f4d3bcd61cc20de1422d8006bb3eee444b9b2e38705d45eb7c28d
pkgname = sunshine-git
diff --git a/PKGBUILD b/PKGBUILD
index 15427b08851d..b8e006f32214 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,51 +1,56 @@
-# Maintainer: Levente Polyak <anthraxx[at]archlinux[dot]org>
+# Maintainer: Jacek Szafarkiewicz <szafar at linux dot pl>
+# Contributor: Levente Polyak <anthraxx[at]archlinux[dot]org>
_pkgname=sunshine
pkgname=${_pkgname}-git
-pkgver=0.4.0.q.290415dec3..
+pkgver=0.4.0.310.488d8e5
pkgrel=1
pkgdesc="Open source implementation of NVIDIA's GameStream, as used by the NVIDIA Shield"
-url="http://sunshine-stream.com"
+url="https://github.com/loki-47-6F-64/sunshine"
arch=('x86_64' 'i686')
license=('GPL3')
-depends=('boost')
-makedepends=('git' 'cmake')
+
+depends=('boost-libs' 'ffmpeg' 'openssl' 'libpulse' 'opus' 'libxtst' 'libx11' 'libxfixes' 'libevdev' 'libxcb')
+makedepends=('git' 'cmake' 'boost')
+
provides=('sunshine')
conflicts=("sunshine")
-source=(${pkgname}::git+https://github.com/loki-47-6F-64/sunshine
- sunshine)
-sha512sums=('SKIP' 'SKIP')
+
+source=(${pkgname}::git+https://github.com/loki-47-6F-64/sunshine.git
+ systemd-cleanup.patch::https://patch-diff.githubusercontent.com/raw/loki-47-6F-64/sunshine/pull/42.patch)
+sha256sums=('SKIP'
+ 'f785ab0ac13f4d3bcd61cc20de1422d8006bb3eee444b9b2e38705d45eb7c28d')
pkgver() {
- cd ${pkgname}
- printf "%s.%s.%s" "$(git describe --tags --abbrev=0|cut -dv -f2|sed 's|\-|.|g')" \
-q "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ cd "$pkgname"
+ printf "%s.%s.%s" "$(git describe --tags $(git rev-list --tags --max-count=1) | sed 's/^v//')" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
prepare() {
- cd ${pkgname}
- git submodule update --recursive --init
+ cd "$pkgname"
+ git rm -f pre-compiled
+ git submodule update --recursive --init
+
+ patch -p1 -i ../systemd-cleanup.patch
}
build() {
- cd ${pkgname}
- mkdir build || rm -rf build/*
- cd build
-# export SUNSHINE_EXECUTABLE_PATH=/usr/bin/
- cmake ..
- make
- sed 's/\@SUNSHINE_EXECUTABLE_PATH\@/\/usr\/bin\/sunshine \/etc\/sunshine.conf/g' ../sunshine.service.in > sunshine.service
+ cmake \
+ -S "$pkgname" \
+ -B build \
+ -Wno-dev \
+ -D SUNSHINE_EXECUTABLE_PATH=/usr/bin/$_pkgname \
+ -D SUNSHINE_ASSETS_DIR=/usr/share/$_pkgname \
+
+ make -C build
}
package() {
- mkdir -p "$pkgdir/usr/bin/" "$pkgdir/usr/lib/systemd/user/" "$pkgdir/etc/" "$pkgdir/usr/lib/sunshine/bin/"
- cp sunshine "$pkgdir/usr/bin/"
-
- cd ${pkgname}
- cp build/sunshine "$pkgdir/usr/lib/sunshine/bin/"
- cp build/sunshine.service "$pkgdir/usr/lib/systemd/user/"
- cp assets/sunshine.conf "$pkgdir/etc/"
-
+ install -Dm755 "$pkgname/assets/sunshine.conf" "$pkgdir/usr/share/$_pkgname/sunshine.conf"
+ install -Dm755 "$pkgname/assets/apps_linux.json" "$pkgdir/usr/share/$_pkgname/apps_linux.json"
+
+ install -Dm755 build/$_pkgname "$pkgdir/usr/bin/$_pkgname"
+ install -Dm755 build/sunshine.service "$pkgdir/usr/lib/systemd/user/sunshine.service"
}
# vim: ts=2 sw=2 et:
diff --git a/sunshine b/sunshine
deleted file mode 100755
index c19a459343c1..000000000000
--- a/sunshine
+++ /dev/null
@@ -1,9 +0,0 @@
-#!/usr/bin/sh
-
-set -e
-
-cd
-mkdir .config/sunshine &> /dev/null || true
-cd .config/sunshine
-
-/usr/lib/sunshine/bin/sunshine $*