summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbartus2024-01-16 17:18:17 +0100
committerbartus2024-01-16 17:18:17 +0100
commite5989d1d6d3184572b8e436cfc2ead9b614bb1c5 (patch)
treee67d645e126b6fc8aa306b4c1ee2c575e526203f
parent25832320c05c7b62a897c7da7a0c41d7779ccd60 (diff)
downloadaur-e5989d1d6d3184572b8e436cfc2ead9b614bb1c5.tar.gz
Use system-wide qhull
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD7
2 files changed, 4 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 44339282583a..027021cfd3ba 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -28,6 +28,7 @@ pkgbase = meshlab
depends = gmp
depends = mpfr
depends = mesa
+ depends = qhull
optdepends = lib3ds: for Autodesk`s 3D-Studio r3 and r4 .3DS file support
optdepends = muparser: for filer_func plugins
optdepends = openctm-tools: for compressed triangle mesh file format
diff --git a/PKGBUILD b/PKGBUILD
index 83307c176ff7..3e4b731488f9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
#Todo:
#* add external cmake projects to source array and patch src/externla/*.cmake
-#* use system wide: levmar, libigl, qhull, structyresynth, libe57, u3d, tinygltf
+#* use system wide: levmar, libigl, structyresynth, libe57, u3d, tinygltf
#Configuration:
#Use: makepkg VAR1=0 VAR2=1 to enable(1) disable(0) a feature
@@ -24,7 +24,7 @@ arch=('i686' 'x86_64')
url="https://www.meshlab.net"
license=('GPL2')
depends=('bzip2' 'cgal' 'glew' 'glu' 'openssl' 'qt5-base' 'qt5-declarative' 'qt5-script' 'qt5-xmlpatterns' 'xerces-c'
- 'gmp' 'mpfr' 'mesa')
+ 'gmp' 'mpfr' 'mesa' 'qhull')
makedepends=('boost' 'cmake' 'eigen' 'ninja' 'git' 'muparser' 'lib3ds' 'openctm-tools' 'gcc12')
optdepends=('lib3ds: for Autodesk`s 3D-Studio r3 and r4 .3DS file support'
'muparser: for filer_func plugins'
@@ -41,8 +41,7 @@ prepare() {
build() {
- _cmake_flags+=( '-DALLOW_SYSTEM_QHULL=OFF'
- '-DCMAKE_INSTALL_PREFIX=/usr'
+ _cmake_flags+=( '-DCMAKE_INSTALL_PREFIX=/usr'
'-DCMAKE_BUILD_TYPE=Release'
'-DCMAKE_C_COMPILER=gcc-12'
'-DCMAKE_CXX_COMPILER=g++-12'