summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Gerber2016-01-01 18:44:17 +0100
committerMichael Gerber2016-01-01 18:44:17 +0100
commite5b0a81bf6b39eb67630a8b40808b0a60429be68 (patch)
tree3ef29d28d3850843d8930d3470112172305f4efb
downloadaur-e5b0a81bf6b39eb67630a8b40808b0a60429be68.tar.gz
Initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD28
-rw-r--r--open-xchange-smtp.install16
3 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ae91840f28f4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+# Generated by mksrcinfo v8
+# Fri Jan 1 17:44:17 UTC 2016
+pkgbase = open-xchange-smtp
+ pkgdesc = The Open-Xchange Server SMTP Bundle
+ pkgver = 7.8.0
+ pkgrel = 6
+ url = http://www.ox.io/
+ install = open-xchange-smtp.install
+ arch = any
+ groups = open-xchange-minimal
+ groups = open-xchange
+ groups = open-xchange-all
+ license = GPLv2
+ depends = open-xchange-core
+ provides = open-xchange-smtp
+ source = https://software.open-xchange.com/products/appsuite/stable/backend/DebianJessie/all/open-xchange-smtp_7.8.0-6_all.deb
+ sha256sums = 750d3e9c545a6bbcd8279f90bdfb63022668748b5912821910039c81ac68c51f
+
+pkgname = open-xchange-smtp
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1fe5e950f9d5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Michael Gerber <aur at lynxcore dot org >
+pkgname=open-xchange-smtp
+pkgver=7.8.0
+pkgrel=6
+pkgdesc='The Open-Xchange Server SMTP Bundle'
+groups=('open-xchange-minimal' 'open-xchange' 'open-xchange-all')
+install='open-xchange-smtp.install'
+arch=('any')
+url='http://www.ox.io/'
+license=('GPLv2')
+depends=('open-xchange-core')
+makedepends=()
+conflicts=()
+provides=('open-xchange-smtp')
+source=('https://software.open-xchange.com/products/appsuite/stable/backend/DebianJessie/all/open-xchange-smtp_7.8.0-6_all.deb')
+sha256sums=('750d3e9c545a6bbcd8279f90bdfb63022668748b5912821910039c81ac68c51f')
+
+package() {
+ if test -f "data.tar.xz"; then
+ tar xf data.tar.xz
+ cp -a $(find . -mindepth 1 -maxdepth 1 -type d) "$pkgdir"
+ fi
+
+ if test -f "data.tar.gz"; then
+ tar xf data.tar.gz
+ cp -a $(find . -mindepth 1 -maxdepth 1 -type d) "$pkgdir"
+ fi
+}
diff --git a/open-xchange-smtp.install b/open-xchange-smtp.install
new file mode 100644
index 000000000000..5a0607f15101
--- /dev/null
+++ b/open-xchange-smtp.install
@@ -0,0 +1,16 @@
+# This is a default template for a post-install scriptlet.
+# Uncomment only required functions and remove any functions
+# you don't need (and this header).
+
+pre_install() {
+ if id -u "open-xchange" >/dev/null 2>&1; then
+ echo "user open-xchange exists. All good."
+ else
+ echo "user open-xchange does not exist. Creating it now"
+ useradd -U -s /usr/bin/false -d /opt/open-xchange open-xchange
+ fi
+}
+
+post_install() {
+ chown -R open-xchange:open-xchange /opt/open-xchange
+}