summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexandre Demers2023-03-20 23:53:24 -0400
committerAlexandre Demers2023-03-20 23:53:24 -0400
commite5b786791dcb3e9b882dbc4350ff152d40ea57d5 (patch)
tree289984a19ab61f48c6f44c22ceb39d40a0944f96
parent42bc177491bd7f6c0c1c0f6d9f586c1a28e190f2 (diff)
downloadaur-e5b786791dcb3e9b882dbc4350ff152d40ea57d5.tar.gz
Upgrade to 6.0
- Remove cherry-picked eb0455d646 that was introduced temporarily in the last update - Add a version check in lib32-ffmpeg on lib32-libffmpeg - Many new dependencies in native package are not available as 32 bit libraries Signed-off-by: Alexandre Demers <alexandre.f.demers@gmail.com>
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD50
2 files changed, 32 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2dd04e766085..aaeb38bf2a21 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = lib32-ffmpeg
pkgdesc = Complete solution to record, convert and stream audio and video (32 bit)
- pkgver = 5.1.2
- pkgrel = 2
+ pkgver = 6.0
+ pkgrel = 1
epoch = 2
url = http://ffmpeg.org/
arch = x86_64
@@ -15,7 +15,7 @@ pkgbase = lib32-ffmpeg
makedepends = nasm
makedepends = opencl-headers
makedepends = vulkan-headers
- depends = ffmpeg>=2:5.1.2
+ depends = ffmpeg>=2:6.0
depends = lib32-alsa-lib
depends = lib32-aom
depends = lib32-bzip2
@@ -69,7 +69,7 @@ pkgbase = lib32-ffmpeg
optdepends = lib32-ladspa: LADSPA filters
optdepends = lib32-nvidia-utils: Nvidia NVDEC/NVENC support
options = debug
- source = git+https://git.ffmpeg.org/ffmpeg.git?signed#tag=1326fe9d4c85cca1ee774b072ef4fa337694f2e7
+ source = git+https://git.ffmpeg.org/ffmpeg.git?signed#tag=3949db4d261748a9f34358a388ee255ad1a7f0c0
source = add-av_stream_get_first_dts-for-chromium.patch
validpgpkeys = DD1EC9E8DE085C629B3E1846B18E8928B3948D64
b2sums = SKIP
@@ -77,7 +77,7 @@ pkgbase = lib32-ffmpeg
pkgname = lib32-ffmpeg
pkgdesc = Complete solution to record, convert and stream audio and video (32 bit)
- depends = lib32-libffmpeg
+ depends = lib32-libffmpeg=6.0
pkgname = lib32-libffmpeg
pkgdesc = Complete solution to record, convert and stream audio and video - library (32 bit)
diff --git a/PKGBUILD b/PKGBUILD
index e2610d679616..cda425e4a714 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,15 +6,15 @@
_pkgbasename=ffmpeg
pkgname=("lib32-$_pkgbasename" "lib32-lib$_pkgbasename")
-pkgver=5.1.2
-pkgrel=2
+pkgver=6.0
+pkgrel=1
epoch=2
pkgdesc="Complete solution to record, convert and stream audio and video (32 bit)"
arch=('x86_64')
url="http://ffmpeg.org/"
license=('GPL3')
depends=(
-# "$_pkgbasename"
+# "$_pkgbasename"
"$_pkgbasename>=${epoch}:${pkgver}"
'lib32-alsa-lib'
'lib32-aom'
@@ -36,18 +36,20 @@ depends=(
'lib32-freetype2'
'lib32-libglvnd'
'lib32-libiec61883'
-# 'lib32-libmfx'
+# ' lib32-libjxl'
+# 'lib32-libmfx'
'lib32-libmodplug'
+# 'lib32-libopenmpt'
'lib32-libpulse'
-# 'lib32-rav1e'
+# 'lib32-rav1e'
'lib32-libraw1394'
'lib32-librsvg'
-# 'lib32-libsoxr'
-# 'lib32-libssh'
+# 'lib32-libsoxr'
+# 'lib32-libssh'
'lib32-libtheora'
'lib32-libva'
'lib32-libvdpau'
-# 'lib32-vid.stab'
+# 'lib32-vid.stab'
'lib32-libvorbis'
'lib32-libvpx'
'lib32-libwebp'
@@ -59,7 +61,7 @@ depends=(
'lib32-libxml2'
'lib32-libxv'
'lib32-xvidcore'
-# 'lib32-libzimg'
+# 'lib32-libzimg'
'lib32-ocl-icd'
'lib32-opencore-amr'
'lib32-openjpeg2'
@@ -67,7 +69,7 @@ depends=(
'lib32-sdl2'
'lib32-speex'
'lib32-srt'
-# 'lib32-svt-av1'
+# 'lib32-svt-av1'
'lib32-v4l-utils'
'lib32-vmaf'
'lib32-vulkan-icd-loader'
@@ -75,7 +77,7 @@ depends=(
'lib32-zlib'
)
makedepends=(
-# 'avisynthplus'
+# 'avisynthplus'
'amf-headers'
'lib32-clang'
'ffnvcodec-headers'
@@ -87,15 +89,15 @@ makedepends=(
'vulkan-headers'
)
optdepends=(
-# 'avisynthplus: AviSynthPlus support'
-# 'intel-media-sdk: Intel QuickSync support'
+# 'avisynthplus: AviSynthPlus support'
+# 'intel-media-sdk: Intel QuickSync support'
'lib32-ladspa: LADSPA filters'
'lib32-nvidia-utils: Nvidia NVDEC/NVENC support'
)
options=(
debug
)
-_tag=1326fe9d4c85cca1ee774b072ef4fa337694f2e7
+_tag=3949db4d261748a9f34358a388ee255ad1a7f0c0
source=(
"git+https://git.ffmpeg.org/ffmpeg.git?signed#tag=${_tag}"
"add-av_stream_get_first_dts-for-chromium.patch"
@@ -112,7 +114,6 @@ prepare() {
# Patching if needed
patch -Np1 -i "${srcdir}"/add-av_stream_get_first_dts-for-chromium.patch # https://crbug.com/1251779
- git cherry-pick -n eb0455d646 #https://trac.ffmpeg.org/ticket/10115
}
pkgver() {
@@ -183,16 +184,19 @@ build() {
--enable-vulkan \
--disable-doc
-# --enable-avisynth \ ## not available under 32 bit
+## not available under 32 bit
+# --enable-avisynth \
+# --enable-libjxl \
# --enable-libopenh264
-# --enable-librav1e \ ## not available under 32 bit
-# --enable-libsoxr \ ## not available under 32 bit
-# --enable-libssh \ ## not available under 32 bit
+# --enable-libopenmpt \
+# --enable-librav1e \
+# --enable-libsoxr \
+# --enable-libssh \
# --enable-libsvtav1
# --enable-libuavs3d
-# --enable-libvidstab \ ## not available under 32 bit
-# --enable-libmfx \ ## not available under 32 bit
-# --enable-libzimg \ ## not available under 32 bit
+# --enable-libvidstab \
+# --enable-libmfx \
+# --enable-libzimg \
make
}
@@ -221,7 +225,7 @@ package_lib32-libffmpeg() {
package_lib32-ffmpeg() {
pkgdesc="Complete solution to record, convert and stream audio and video (32 bit)"
depends=(
- 'lib32-libffmpeg'
+ "lib32-libffmpeg=${pkgver}"
)
cd ${_pkgbasename}