summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorErik Dubois2017-04-30 23:56:31 -0400
committerErik Dubois2017-04-30 23:56:31 -0400
commite5c13f897b5f989fc41bfad255f13c9e91f43aac (patch)
tree1383f773ccd9c86c5df1883e01337f38616703ed
parent025afe9e1ab5e4f916b581f504c873ff315ac9d1 (diff)
downloadaur-e5c13f897b5f989fc41bfad255f13c9e91f43aac.tar.gz
fixing for glibc
-rw-r--r--.SRCINFO14
-rw-r--r--0006-glibc-2.25-Avoid-conflicts-with-integer-width-macros-from-TS-18.patch72
-rw-r--r--PKGBUILD23
-rw-r--r--fontconfig-ultimate-git.tar.bz2bin40695 -> 0 bytes
4 files changed, 92 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5cc431b6cc5a..b48061a9ed7c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Mon May 1 03:10:56 UTC 2017
+# Mon May 1 03:55:59 UTC 2017
pkgbase = fontconfig-infinality-ultimate
pkgdesc = A library for configuring and customizing font access, optimized for freetype2-infinality-ultimate.
pkgver = 2.12.1
- pkgrel = 3
+ pkgrel = 4
url = http://www.fontconfig.org/release/
install = fontconfig-ultimate.install
changelog = CHANGELOG
@@ -35,11 +35,13 @@ pkgbase = fontconfig-infinality-ultimate
backup = etc/fonts/conf.avail.infinality/38-repl-webfonts-custom.conf
backup = etc/fonts/conf.avail.infinality/97-selective-rendering-custom.conf
source = http://www.fontconfig.org/release/fontconfig-2.12.1.tar.bz2
- source = fontconfig-ultimate-git.tar.bz2
+ source = https://raw.githubusercontent.com/archfan/infinality_bundle/820e74be8345a0da2cdcff0a05bf5fa10fd85740/02_fontconfig-iu/fontconfig-ultimate-git.tar.bz2
source = fc-cache-ib.hook
- md5sums = b5af5a423ee3b5cfc34846838963c058
- md5sums = a02962475eb066f1bdb1ad3376c95d38
- md5sums = d7f4e07501c01f1dfff79c76aae5ce71
+ source = 0006-glibc-2.25-Avoid-conflicts-with-integer-width-macros-from-TS-18.patch
+ sha256sums = b449a3e10c47e1d1c7a6ec6e2016cca73d3bd68fbbd4f0ae5cc6b573f7d6c7f3
+ sha256sums = b4977cfb0dc64167be3b58ae63022ffb2648e08519b0c061ee2ca43620d8b980
+ sha256sums = 026971a9fac1ee4fb0ef74d5833ce5e12b4645de8ebdf1cadb3cb943cf46abd3
+ sha256sums = 82982895a7be0be725e27a906e54b9d3da7bde237c6a59cf67def082c9b9e59a
pkgname = fontconfig-infinality-ultimate
diff --git a/0006-glibc-2.25-Avoid-conflicts-with-integer-width-macros-from-TS-18.patch b/0006-glibc-2.25-Avoid-conflicts-with-integer-width-macros-from-TS-18.patch
new file mode 100644
index 000000000000..cad71707adc0
--- /dev/null
+++ b/0006-glibc-2.25-Avoid-conflicts-with-integer-width-macros-from-TS-18.patch
@@ -0,0 +1,72 @@
+From 20cddc824c6501c2082cac41b162c34cd5fcc530 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Sun, 11 Dec 2016 14:32:00 -0800
+Subject: [PATCH] Avoid conflicts with integer width macros from TS
+ 18661-1:2014
+
+glibc 2.25+ has now defined these macros in <limits.h>
+https://sourceware.org/git/?p=glibc.git;a=commit;h=5b17fd0da62bf923cb61d1bb7b08cf2e1f1f9c1a
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+Upstream-Status: Submitted
+
+ fontconfig/fontconfig.h | 2 +-
+ src/fcobjs.h | 2 +-
+ src/fcobjshash.gperf | 2 +-
+ src/fcobjshash.h | 2 +-
+ 4 files changed, 4 insertions(+), 4 deletions(-)
+
+Index: fontconfig-2.12.1/fontconfig/fontconfig.h
+===================================================================
+--- fontconfig-2.12.1.orig/fontconfig/fontconfig.h
++++ fontconfig-2.12.1/fontconfig/fontconfig.h
+@@ -128,7 +128,8 @@ typedef int FcBool;
+ #define FC_USER_CACHE_FILE ".fonts.cache-" FC_CACHE_VERSION
+
+ /* Adjust outline rasterizer */
+-#define FC_CHAR_WIDTH "charwidth" /* Int */
++#define FC_CHARWIDTH "charwidth" /* Int */
++#define FC_CHAR_WIDTH FC_CHARWIDTH
+ #define FC_CHAR_HEIGHT "charheight"/* Int */
+ #define FC_MATRIX "matrix" /* FcMatrix */
+
+Index: fontconfig-2.12.1/src/fcobjs.h
+===================================================================
+--- fontconfig-2.12.1.orig/src/fcobjs.h
++++ fontconfig-2.12.1/src/fcobjs.h
+@@ -51,7 +51,7 @@ FC_OBJECT (DPI, FcTypeDouble, NULL)
+ FC_OBJECT (RGBA, FcTypeInteger, NULL)
+ FC_OBJECT (SCALE, FcTypeDouble, NULL)
+ FC_OBJECT (MINSPACE, FcTypeBool, NULL)
+-FC_OBJECT (CHAR_WIDTH, FcTypeInteger, NULL)
++FC_OBJECT (CHARWIDTH, FcTypeInteger, NULL)
+ FC_OBJECT (CHAR_HEIGHT, FcTypeInteger, NULL)
+ FC_OBJECT (MATRIX, FcTypeMatrix, NULL)
+ FC_OBJECT (CHARSET, FcTypeCharSet, FcCompareCharSet)
+Index: fontconfig-2.12.1/src/fcobjshash.gperf
+===================================================================
+--- fontconfig-2.12.1.orig/src/fcobjshash.gperf
++++ fontconfig-2.12.1/src/fcobjshash.gperf
+@@ -44,7 +44,7 @@ int id;
+ "rgba",FC_RGBA_OBJECT
+ "scale",FC_SCALE_OBJECT
+ "minspace",FC_MINSPACE_OBJECT
+-"charwidth",FC_CHAR_WIDTH_OBJECT
++"charwidth",FC_CHARWIDTH_OBJECT
+ "charheight",FC_CHAR_HEIGHT_OBJECT
+ "matrix",FC_MATRIX_OBJECT
+ "charset",FC_CHARSET_OBJECT
+Index: fontconfig-2.12.1/src/fcobjshash.h
+===================================================================
+--- fontconfig-2.12.1.orig/src/fcobjshash.h
++++ fontconfig-2.12.1/src/fcobjshash.h
+@@ -284,7 +284,7 @@ FcObjectTypeLookup (register const char
+ {(int)(long)&((struct FcObjectTypeNamePool_t *)0)->FcObjectTypeNamePool_str43,FC_CHARSET_OBJECT},
+ {-1},
+ #line 47 "fcobjshash.gperf"
+- {(int)(long)&((struct FcObjectTypeNamePool_t *)0)->FcObjectTypeNamePool_str45,FC_CHAR_WIDTH_OBJECT},
++ {(int)(long)&((struct FcObjectTypeNamePool_t *)0)->FcObjectTypeNamePool_str45,FC_CHARWIDTH_OBJECT},
+ #line 48 "fcobjshash.gperf"
+ {(int)(long)&((struct FcObjectTypeNamePool_t *)0)->FcObjectTypeNamePool_str46,FC_CHAR_HEIGHT_OBJECT},
+ #line 55 "fcobjshash.gperf"
diff --git a/PKGBUILD b/PKGBUILD
index de72fb265887..ca5d8cff5c1d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@ pkgdesc="A library for configuring and customizing font access, optimized for fr
url='http://www.fontconfig.org/release/'
license=('custom' 'MIT')
pkgver=2.12.1
-pkgrel=3
+pkgrel=4
arch=('i686' 'x86_64')
changelog=CHANGELOG
groups=('infinality-bundle')
@@ -28,8 +28,9 @@ backup=('etc/fonts/fonts.conf'
'etc/fonts/conf.avail.infinality/97-selective-rendering-custom.conf')
install=fontconfig-ultimate.install
source=(http://www.fontconfig.org/release/${_basename}-${pkgver}.tar.bz2
- ${_basename}-ultimate-git.tar.bz2
- fc-cache-ib.hook)
+ https://raw.githubusercontent.com/archfan/infinality_bundle/820e74be8345a0da2cdcff0a05bf5fa10fd85740/02_fontconfig-iu/fontconfig-ultimate-git.tar.bz2
+ fc-cache-ib.hook
+ 0006-glibc-2.25-Avoid-conflicts-with-integer-width-macros-from-TS-18.patch)
# a nice page to test font matching:
# http://zipcon.net/~swhite/docs/computers/browsers/fonttest.html
@@ -40,15 +41,14 @@ prepare() {
02-configure.ac.patch
03-Makefile.in.patch
04-Makefile-20160818.conf.d.patch
- 05-Makefile.am.in.patch)
+ 05-Makefile.am.in.patch
+ 0006-glibc-2.25-Avoid-conflicts-with-integer-width-macros-from-TS-18.patch)
# copy fontconfig-ib patches & stuff
cd "${_basename}-ultimate-git"
-
+ cp -r ../0006-glibc-2.25-Avoid-conflicts-with-integer-width-macros-from-TS-18.patch "${srcdir}/${_basename}-${pkgver}"
cp -r conf.d.infinality "${srcdir}/${_basename}-${pkgver}"/conf.d.infinality
- cp -r fontconfig_patches/*.patch "${srcdir}/${_basename}-${pkgver}"
-
- # prepare src
+ cp -r fontconfig_patches/*.patch "${srcdir}/${_basename}-${pkgver}" # prepare src
cd "${srcdir}/${_basename}-${pkgver}"
# infinality & post release fixes
@@ -113,6 +113,7 @@ package() {
find "${pkgdir}" -type d -name .git -exec rm -r '{}' +
}
-md5sums=('b5af5a423ee3b5cfc34846838963c058'
- 'a02962475eb066f1bdb1ad3376c95d38'
- 'd7f4e07501c01f1dfff79c76aae5ce71')
+sha256sums=('b449a3e10c47e1d1c7a6ec6e2016cca73d3bd68fbbd4f0ae5cc6b573f7d6c7f3'
+ 'b4977cfb0dc64167be3b58ae63022ffb2648e08519b0c061ee2ca43620d8b980'
+ '026971a9fac1ee4fb0ef74d5833ce5e12b4645de8ebdf1cadb3cb943cf46abd3'
+ '82982895a7be0be725e27a906e54b9d3da7bde237c6a59cf67def082c9b9e59a')
diff --git a/fontconfig-ultimate-git.tar.bz2 b/fontconfig-ultimate-git.tar.bz2
deleted file mode 100644
index 21bfdd34ad46..000000000000
--- a/fontconfig-ultimate-git.tar.bz2
+++ /dev/null
Binary files differ