summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMoritz Bunkus2015-06-13 12:52:34 +0200
committerMoritz Bunkus2015-06-13 12:52:34 +0200
commite5deb014689157022e413e9b25d7ea9693e0dc36 (patch)
treefa0acdb08b0e72a2ad762991ded25aead3cab5fa
downloadaur-e5deb014689157022e413e9b25d7ea9693e0dc36.tar.gz
Initial import
-rw-r--r--.AURINFO14
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD45
3 files changed, 75 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..280c87a91a10
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,14 @@
+pkgbase = perl-getopt-mixed
+ pkgdesc = Library for getopt processing with both long and short options
+ pkgver = 1.12
+ pkgrel = 2
+ url = http://search.cpan.org/~cjm/Getopt-Mixed/
+ arch = any
+ license = GPL
+ license = PerlArtistic
+ depends = perl
+ source = http://search.cpan.org/CPAN/authors/id/C/CJ/CJM/Getopt-Mixed-1.12.tar.gz
+ options = !emptydirs
+
+pkgname = perl-getopt-mixed
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..617d881973c2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = perl-getopt-mixed
+ pkgdesc = Library for getopt processing with both long and short options
+ pkgver = 1.12
+ pkgrel = 2
+ url = http://search.cpan.org/~cjm/Getopt-Mixed/
+ arch = any
+ license = GPL
+ license = PerlArtistic
+ depends = perl
+ options = !emptydirs
+ source = http://search.cpan.org/CPAN/authors/id/C/CJ/CJM/Getopt-Mixed-1.12.tar.gz
+ md5sums = 124360ea13bb6ccebeadc3e3a7fcdd59
+ sha512sums = 74e7d0e7cf854d18b69cf36caf9647f78660db1b21ceb6750aae15aec5e40947902834d7f178adeae442f83958157809a2f95f1873c120dc3093c35d1fdc0ad2
+
+pkgname = perl-getopt-mixed
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..22fcf40f03ee
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+pkgname=perl-getopt-mixed
+pkgver=1.12
+pkgrel="2"
+pkgdesc="Library for getopt processing with both long and short options"
+arch=('any')
+url="http://search.cpan.org/~cjm/Getopt-Mixed/"
+license=('GPL' 'PerlArtistic')
+depends=('perl')
+options=('!emptydirs')
+source=(http://search.cpan.org/CPAN/authors/id/C/CJ/CJM/Getopt-Mixed-$pkgver.tar.gz)
+md5sums=('124360ea13bb6ccebeadc3e3a7fcdd59')
+sha512sums=('74e7d0e7cf854d18b69cf36caf9647f78660db1b21ceb6750aae15aec5e40947902834d7f178adeae442f83958157809a2f95f1873c120dc3093c35d1fdc0ad2')
+
+
+prepare_environment() {
+ export PERL_MM_USE_DEFAULT=1 PERL5LIB="" \
+ PERL_AUTOINSTALL=--skipdeps \
+ PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
+ PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
+ MODULEBUILDRC=/dev/null
+ cd "${srcdir}/Getopt-Mixed-${pkgver}"
+}
+
+build() {
+ prepare_environment
+ /usr/bin/perl Makefile.PL
+ make
+}
+
+check() {
+ prepare_environment
+ make test
+}
+
+package() {
+ prepare_environment
+ make install
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+}
+
+# Local Variables:
+# mode: shell-script
+# sh-basic-offset: 2
+# End:
+# vim:set ts=2 sw=2 et: