summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGergely Imreh2019-07-22 17:35:50 +0100
committerGergely Imreh2019-07-22 17:35:50 +0100
commite608b84a890072c63a77a8575018b42014240034 (patch)
treebb38e0c2b1a2d11c0472a19e74aa5d276ae06d52
parentc47d696ea2e72c9d0cc3e1a9d21e5748e8154f5a (diff)
downloadaur-e608b84a890072c63a77a8575018b42014240034.tar.gz
bump version to 18.9.7
Also add fixes for pull issues in the service file, temporary until upstream fixes stuff differently. Signed-off-by: Gergely Imreh <imrehg@gmail.com>
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD21
-rw-r--r--balena-engine.service.patch12
3 files changed, 29 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1cf499e7f576..4e85d22539fa 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = balena-engine
pkgdesc = A Moby-based container engine for the Internet of Things
- pkgver = 18.9.6
+ pkgver = 18.9.7
pkgrel = 1
epoch = 1
url = https://www.balena.io/
@@ -23,12 +23,14 @@ pkgbase = balena-engine
optdepends = lxc: lxc backend support
options = !strip
options = !buildflags
- source = git+https://github.com/balena-os/balena-engine.git#tag=v18.9.6
+ source = git+https://github.com/balena-os/balena-engine.git#tag=v18.9.7
source = balena-engine.sysusers
source = 80-balena-engine.rules
+ source = balena-engine.service.patch
sha256sums = SKIP
sha256sums = 39ab64fca83966b0edf2d56013ce33dcb44962800c1f0a29673708c9ba9328e3
sha256sums = fbdcb0d6c5794c9db8fa30e81fa0f1d2f91d11e23f4c286e15ff57e8bef87bce
+ sha256sums = c871ee7817b57c6f1c7674d0c93b1db767bb394a70852d8288df257bc2d29f54
pkgname = balena-engine
diff --git a/PKGBUILD b/PKGBUILD
index 8fd677a63852..e7b738ac4a80 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Maintainer: Gegrely Imreh <imrehg@gmail.com>
pkgname=balena-engine
-pkgver=18.9.6
+pkgver=18.9.7
pkgrel=1
epoch=1
pkgdesc='A Moby-based container engine for the Internet of Things'
@@ -21,23 +21,28 @@ options=('!strip' '!buildflags')
# https://github.com/docker/docker-ce/blob/master/components/engine/hack/dockerfile/binaries-commits
source=("git+https://github.com/balena-os/balena-engine.git#tag=v${pkgver}"
"balena-engine.sysusers"
- "80-balena-engine.rules")
+ "80-balena-engine.rules"
+ "balena-engine.service.patch")
sha256sums=('SKIP'
'39ab64fca83966b0edf2d56013ce33dcb44962800c1f0a29673708c9ba9328e3'
- 'fbdcb0d6c5794c9db8fa30e81fa0f1d2f91d11e23f4c286e15ff57e8bef87bce')
+ 'fbdcb0d6c5794c9db8fa30e81fa0f1d2f91d11e23f4c286e15ff57e8bef87bce'
+ 'c871ee7817b57c6f1c7674d0c93b1db767bb394a70852d8288df257bc2d29f54')
+
+
+prepare() {
+ cd "${srcdir}/${pkgname}"
+ patch --forward --strip=1 --input="${srcdir}/balena-engine.service.patch"
+}
build() {
- cd "${srcdir}/balena-engine/"
- echo $(git describe --tags --always) > VERSION
+ cd "${srcdir}/${pkgname}/"
+ echo -n $(git describe --tags --always | sed 's/^v//;s/-/./g') > VERSION
./build.sh
}
package() {
### engine
-# find "${srcdir}/${pkgname}/bundles/binary-balena/" -executable -type f -exec install -Dm755 {} "${pkgdir}/usr/bin/" \;
-# find "${srcdir}/${pkgname}/bundles/binary-balena/" -executable -type l -exec install -Dm755 {} "${pkgdir}/usr/bin/" \;
-
for f in "${srcdir}/${pkgname}/bundles/binary-balena/"* ; do
install -Dm755 "${f}" -t "${pkgdir}/usr/bin/"
done
diff --git a/balena-engine.service.patch b/balena-engine.service.patch
new file mode 100644
index 000000000000..1b00af4a2161
--- /dev/null
+++ b/balena-engine.service.patch
@@ -0,0 +1,12 @@
+--- ./contrib/init/systemd/balena-engine.service.old 2019-07-22 17:11:02.087699839 +0100
++++ ./contrib/init/systemd/balena-engine.service 2019-07-22 17:11:43.603623006 +0100
+@@ -7,6 +7,9 @@
+
+ [Service]
+ Type=notify
++# Force name resolution, for more details see:
++# https://github.com/balena-os/balena-engine/issues/170
++Environment=GODEBUG=netdns=go
+ # the default is not to use systemd for cgroups because the delegate issues still
+ # exists and systemd currently does not support the cgroup feature set required
+ # for containers run by docker