summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorConnor Behan2015-06-08 21:25:15 -0400
committerConnor Behan2015-06-08 21:25:15 -0400
commite60fb1d6dcd37afdcb9de5a6369ec9c558c6333d (patch)
treefc767656720d1fe10e67a8ffd1b925a91dd61962
downloadaur-e60fb1d6dcd37afdcb9de5a6369ec9c558c6333d.tar.gz
Initial import
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD16
2 files changed, 34 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..120badb1052d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = diet-kconfig
+ pkgdesc = A script to trim unused modules when compiling the kernel
+ pkgver = 1
+ pkgrel = 5
+ url = http://ftp.suse.com/pub/people/tiwai/misc/diet-kconfig
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = findutils
+ depends = grep
+ depends = sed
+ depends = awk
+ depends = coreutils
+ source = http://ftp.suse.com/pub/people/tiwai/misc/diet-kconfig
+ md5sums = 500addab85db4abd77e70f04cc352eab
+
+pkgname = diet-kconfig
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..df1d37e74bfe
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,16 @@
+# Contributor: ConnorBehan <connor.behan@gmail.com>
+
+pkgname=diet-kconfig
+pkgver=1
+pkgrel=5
+pkgdesc="A script to trim unused modules when compiling the kernel"
+arch=('i686' 'x86_64')
+url="http://ftp.suse.com/pub/people/tiwai/misc/${pkgname}"
+license=('GPL')
+depends=('findutils' 'grep' 'sed' 'awk' 'coreutils')
+source=($url)
+
+package() {
+ install -Dm755 "$srcdir"/$pkgname "$pkgdir"/usr/bin/$pkgname
+}
+md5sums=('500addab85db4abd77e70f04cc352eab')