summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKagamma2021-09-22 07:23:39 +0700
committerKagamma2021-09-22 07:23:39 +0700
commite61906afb1402a26a534ab7a20f3725e35acb9d1 (patch)
treece7cf0d451ac522326d7f8f8762eed11813754f7
downloadaur-e61906afb1402a26a534ab7a20f3725e35acb9d1.tar.gz
Initial push.
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD75
2 files changed, 98 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d9fe5240be8a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = castle-engine-git
+ pkgdesc = Cross-platform 3D and 2D game engine using modern Object Pascal
+ pkgver = v7.0.alpha.1.r16494.f39aec48a
+ pkgrel = 1
+ url = https://castle-engine.io/
+ arch = x86_64
+ license = LGPL with static linking exception
+ makedepends = git
+ makedepends = make
+ makedepends = fpc
+ makedepends = lazarus
+ depends = gtk2
+ depends = freetype2
+ depends = openal
+ depends = libpng
+ depends = libvorbis
+ depends = mesa
+ optdepends = fpc: to compile games
+ optdepends = lazarus: to compile castle-editor
+ source = git+https://github.com/castle-engine/castle-engine.git
+ md5sums = SKIP
+
+pkgname = castle-engine-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3249cdc6d0dc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,75 @@
+# Maintainer: Trung Le (Kagamma) <kagamma(dot)km(at)gmail(dot)com>
+pkgname=castle-engine-git
+pkgver=v7.0.alpha.1.r16494.f39aec48a
+pkgrel=1
+epoch=
+pkgdesc="Cross-platform 3D and 2D game engine using modern Object Pascal"
+arch=(x86_64)
+url="https://castle-engine.io/"
+license=('LGPL with static linking exception')
+groups=()
+depends=(gtk2 freetype2 openal libpng libvorbis mesa)
+makedepends=(git make fpc lazarus)
+checkdepends=()
+optdepends=('fpc: to compile games'
+ 'lazarus: to compile castle-editor')
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=(git+https://github.com/castle-engine/castle-engine.git)
+noextract=()
+md5sums=('SKIP')
+validpgpkeys=()
+pkgver() {
+ cd castle-engine
+ printf "%s.r%s.%s" "$(git describe --abbrev=0 | sed 's/\([^-]*-g\)/r\1/;s/-/./g')" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+build() {
+ # Build tools
+ cd castle-engine
+ make cleanall tools
+ tools/build-tool/castle-engine --project tools/castle-editor compile
+ make cleanall
+}
+package() {
+ cd castle-engine
+ # Prepare desktop file
+ printf '[Desktop Entry]
+Encoding=UTF-8
+Type=Application
+Icon=/usr/src/castle-engine/doc/pasdoc/logo/castle_game_engine_icon.png
+Path=/usr/src/castle-engine
+Exec=/usr/bin/castle-editor
+Name=Castle Editor
+GenericName=Castle Game Engine Editor
+Category=Application;Development;GUIDesigner;Programming;
+Categories=Application;Development;GUIDesigner;Programming;
+Keywords=editor;pascal;fpc;design;castle;engine;' > castle-editor.desktop
+ # Install binaries & desktop file
+ install -Dm755 tools/build-tool/castle-engine "${pkgdir}/usr/bin/castle-engine"
+ install -Dm755 tools/castle-editor/castle-editor "${pkgdir}/usr/bin/castle-editor"
+ install -Dm755 tools/castle-curves/castle-curves "${pkgdir}/usr/bin/castle-curves"
+ install -Dm755 tools/image-to-pascal/image-to-pascal "${pkgdir}/usr/bin/image-to-pascal"
+ install -Dm755 tools/texture-font-to-pascal/texture-font-to-pascal "${pkgdir}/usr/bin/texture-font-to-pascal"
+ install -Dm755 tools/to-data-uri/to-data-uri "${pkgdir}/usr/bin/to-data-uri"
+ install -Dm755 castle-editor.desktop "${pkgdir}/usr/share/applications/castle-editor.desktop"
+ # Cleanup
+ rm -f tools/build-tool/castle-engine
+ rm -f tools/castle-editor/castle-editor
+ rm -f tools/castle-curves/castle-curves
+ rm -f tools/image-to-pascal/image-to-pascal
+ rm -f tools/texture-font-to-pascal/texture-font-to-pascal
+ rm -f tools/to-data-uri/to-data-uri
+ rm -f castle-editor.desktop
+ rm -rf .git
+ # Install the rest to /usr/src
+ mkdir -p ${pkgdir}/usr/src/castle-engine
+ cp -rf * ${pkgdir}/usr/src/castle-engine
+ # Cleanup temporary source
+ cd ..
+ rm -rf castle-engine
+}