summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorrainbowintheshell2016-10-01 12:14:40 -0300
committerrainbowintheshell2016-10-01 12:14:40 -0300
commite61ea2a643a28a71939818aa05596c48f9d713dc (patch)
treeb5e3eaf5170286da007e856787be3179b88a6457
downloadaur-e61ea2a643a28a71939818aa05596c48f9d713dc.tar.gz
init
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD19
2 files changed, 35 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3d0eace6935a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = blackpearl
+ pkgdesc = Watch movies and series from The Pirate Bay in your terminal
+ pkgver = 0.0.5
+ pkgrel = 1
+ url = https://www.npmjs.com/package/blackpearl
+ arch = any
+ license = WTFPL
+ makedepends = npm
+ depends = nodejs
+ depends = npm
+ options = !emptydirs
+ source = blackpearl::git+https://github.com/rainbowintheshell/blackpearl.git
+ md5sums = SKIP
+
+pkgname = blackpearl
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e1669873904f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Rainbow <rainbowtupperware@openmailbox.org>
+
+pkgname=blackpearl
+pkgver=0.0.5
+pkgrel=1
+pkgdesc="Watch movies and series from The Pirate Bay in your terminal"
+arch=('any')
+url="https://www.npmjs.com/package/blackpearl"
+license=('WTFPL')
+depends=('nodejs' 'npm')
+makedepends=('npm')
+options=(!emptydirs)
+source=("$pkgname"::'git+https://github.com/rainbowintheshell/blackpearl.git')
+md5sums=('SKIP')
+
+package() {
+ cd "${srcdir}/${pkgname}"
+ npm install --user root -g --prefix "${pkgdir}/usr"
+}