summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOtto Ahoniemi2020-01-11 11:36:59 +0200
committerOtto Ahoniemi2020-01-11 11:36:59 +0200
commite622aef0f7eb66f62c5be75b8a631f2006af6840 (patch)
tree454cb9d2539a173bf5dbc8bcf1c883dc9fb88c4a
downloadaur-e622aef0f7eb66f62c5be75b8a631f2006af6840.tar.gz
Add first package version from Github releases
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD16
2 files changed, 28 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5141e1cf3bb5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = pinentry-wayland
+ pkgdesc = A small shell script wrapper for setting different pinentry-clients for Wayland GUI and terminal usage.
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://github.com/otahontas/pinentry-wayland/blob/master/README.md
+ arch = any
+ license = CC0 1.0 Universal
+ source = https://github.com/otahontas/pinentry-wayland/archive/1.0.tar.gz
+ sha256sums = SKIP
+
+pkgname = pinentry-wayland
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..57f727000c0c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,16 @@
+# Maintainer: Otto Ahoniemi <otto@ottoahoniemi.fi>
+
+pkgname=pinentry-wayland
+pkgver=1.0
+pkgrel=1
+pkgdesc="A small shell script wrapper for setting different pinentry-clients for Wayland GUI and terminal usage."
+arch=('any')
+url="https://github.com/otahontas/pinentry-wayland/blob/master/README.md"
+license=('CC0 1.0 Universal')
+source=("https://github.com/otahontas/pinentry-wayland/archive/${pkgver}.tar.gz")
+sha256sums=('SKIP')
+
+package() {
+ cd "$pkgname-$pkgver"
+ install -D -m 755 ${pkgname} "${pkgdir}/usr/bin/${pkgname}"
+}