summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorColin Arnott2017-12-10 05:41:49 +0000
committerColin Arnott2017-12-10 05:41:49 +0000
commite62424fcfa9abc2c4986ecaa41864b80b6993e7f (patch)
treefbac601a4596a50f05b41f1276b3955e4a274a8d
parentd206e6d18def4658b3453c20efa0f1c7d7c8f386 (diff)
downloadaur-e62424fcfa9abc2c4986ecaa41864b80b6993e7f.tar.gz
add provides conflicts and simplify PKGBUILD
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD14
2 files changed, 10 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e912d926801c..be427b796c2e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Sun Dec 10 05:31:42 UTC 2017
+# Sun Dec 10 05:40:56 UTC 2017
pkgbase = azure-vhd-utils-git
pkgdesc = Azure VHD utilities for Go.
- pkgver = r37.2dd43d8
+ pkgver = r7.d206e6d
pkgrel = 1
url = https://github.com/Microsoft/azure-vhd-utils
arch = x86_64
@@ -10,6 +10,8 @@ pkgbase = azure-vhd-utils-git
license = MIT
makedepends = go
makedepends = git
+ provides = azure-vhd-utils
+ conflicts = azure-vhd-utils
options = !strip
options = !emptydirs
diff --git a/PKGBUILD b/PKGBUILD
index 05e93d118dc1..9d7d734a414e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,17 @@
# Maintainer: Colin Arnott <colin@urandom.co.uk>
# Co-Maintainer: Luca Weiss <WEI16416@spengergasse.at>
-_pkgname=azure-vhd-utils
-pkgname=${_pkgname}-git
-pkgver=r37.2dd43d8
+pkgname=azure-vhd-utils-git
+pkgver=r7.d206e6d
pkgrel=1
pkgdesc="Azure VHD utilities for Go."
arch=('x86_64' 'i686')
url="https://github.com/Microsoft/azure-vhd-utils"
license=('MIT')
makedepends=('go' 'git')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
options=('!strip' '!emptydirs')
-_gourl=github.com/Microsoft/${_pkgname}
pkgver() {
cd $srcdir/src/$_gourl/
@@ -20,12 +20,10 @@ pkgver() {
prepare() {
export GOPATH="$srcdir"
- go get -fix -v -x ${_gourl}
+ go get -fix -v -x ${url#https://}
}
package() {
install -Dm755 $srcdir/bin/azure-vhd-utils "$pkgdir/usr/bin/vhd"
- install -Dm644 $srcdir/src/${_gourl}/LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm644 $srcdir/src/${url#https://}/LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}
-
-# vim:set ts=2 sw=2 et: