summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDonald Carr2019-06-28 00:25:23 -0700
committerDonald Carr2019-06-28 00:48:33 -0700
commite6747c5eb87ea0cd1ed1d74823f8dd0370cf976f (patch)
tree32fd39f07c37156b4bd71aa23d3c222e4d6cb09c
parent717e68571b309b60acd8b535ceaa70a4cb4ad509 (diff)
downloadaur-e6747c5eb87ea0cd1ed1d74823f8dd0370cf976f.tar.gz
Cease to automatically slam variables into gdm env
Change-Id: Id640557eaf9548ac388133fa2a8047872f2dcae8
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD3
-rwxr-xr-xqt-gtk-platform-plugin-git.install11
3 files changed, 14 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f20b0075d6a0..873856f36c05 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,9 @@
-# Generated by mksrcinfo v8
-# Sat Jun 22 01:58:06 UTC 2019
pkgbase = qt-gtk-platform-plugin-git
pkgdesc = GTK platform backend for Qt
pkgver = 20190427.da0e695
pkgrel = 1
url = https://github.com/CrimsonAS/gtkplatform
+ install = qt-gtk-platform-plugin-git.install
arch = any
license = LGPL3
provides = qt-gtk-platform-plugin
diff --git a/PKGBUILD b/PKGBUILD
index 71c1a6380397..a4423f536a59 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,6 +13,7 @@ url='https://github.com/CrimsonAS/gtkplatform'
license=('LGPL3')
source=("git://github.com/CrimsonAS/gtkplatform.git")
sha256sums=('SKIP')
+install=${pkgname}.install
pkgver () {
cd "${srcdir}/gtkplatform"
@@ -26,7 +27,7 @@ build() {
}
package() {
- local env_dir=${pkgdir}/usr/share/gdm/env.d/
+ local env_dir=${pkgdir}/usr/share/qt-gtk-platform-plugin
local pacman_hook_dir=${pkgdir}/etc/pacman.d/hooks
local env_file=${startdir}/qt-force-gtk-platform.env
local hook_file=${startdir}/100-qt-gtk-platform-plugin-git.hook
diff --git a/qt-gtk-platform-plugin-git.install b/qt-gtk-platform-plugin-git.install
new file mode 100755
index 000000000000..b2403da14c92
--- /dev/null
+++ b/qt-gtk-platform-plugin-git.install
@@ -0,0 +1,11 @@
+post_install() {
+ echo ""
+ echo "To have gdm automatically export QT_QPA_PLATFORM=gtk where, run:"
+ echo "ln -s /usr/share/qt-gtk-platform-plugin/qt-force-gtk-platform.env /usr/share/gdm/env.d/qt-force-gtk-platform.env"
+ echo "Achtung; Some Qt apps will crash with this backend in use, for example: Qt Creator, Zeal and probably swathes of KDE"
+ echo ""
+}
+
+post_upgrade() {
+ post_install
+}