summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYour Name2018-03-24 20:59:52 -0400
committerYour Name2018-03-24 20:59:52 -0400
commite68eabc2433d9850c05563931b55215a577640c6 (patch)
tree59949eca0c6e17dddfb76d3a30b1e50314105689
downloadaur-e68eabc2433d9850c05563931b55215a577640c6.tar.gz
alpha
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD40
2 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b9d4d2084765
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = openfx-gmic-git
+ pkgdesc = A set of Readers/Writers plugins written using the OpenFX standard
+ pkgver = 2.3.8
+ pkgrel = 1
+ url = https://github.com/MrKepzie/openfx-io
+ arch = x86_64
+ license = GPL2
+ makedepends = git
+ makedepends = expat
+ makedepends = boost
+ depends = seexpr
+ depends = openimageio
+ depends = ffmpeg
+ optdepends = openfx-gmic-bin
+ optdepends = natron-plugins
+ source = openfx-gmic::git+https://github.com/NatronGitHub/openfx-gmic.git#commit=d7595c483a9a7b480841bb9e8588e7a566bbb82e
+ sha512sums = SKIP
+
+pkgname = openfx-gmic-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3d0d97cc54e7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Hugo Courtial <hugo [at] courtial [not colon] me>
+# Maintainer: Luca Weiss <luca (at) z3ntu (dot) xyz>
+
+pkgname=openfx-gmic-git
+name=openfx-gmic
+pkgver=2.3.8
+pkgrel=1
+arch=("x86_64")
+pkgdesc="A set of Readers/Writers plugins written using the OpenFX standard"
+url="https://github.com/MrKepzie/openfx-io"
+license=("GPL2")
+depends=("seexpr" "openimageio" "ffmpeg")
+#depends=("opencolorio" "openexr" "openimageio" "ffmpeg" "boost-libs")
+makedepends=("git" "expat" "boost")
+optdepends=("openfx-gmic-bin" "natron-plugins")
+com=d7595c483a9a7b480841bb9e8588e7a566bbb82e
+source=("$name::git+https://github.com/NatronGitHub/openfx-gmic.git#commit=$com"
+)
+sha512sums=('SKIP'
+)
+
+_bits=32 ; [[ "$CARCH" = 'x86_64' ]] && _bits=64
+
+prepare() {
+ cd "$srcdir/$name"
+
+ git submodule update --init --recursive
+
+}
+
+build() {
+ cd "$srcdir/$name"
+ make CONFIG=release
+}
+
+package() {
+ cd "$srcdir/$name"
+ mkdir -p "$pkgdir/usr/OFX/Plugins"
+ make install PLUGINPATH=$pkgdir/usr/OFX/Plugins CONFIG=release BITS=$_bits
+}