summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlarchunix2020-09-11 23:46:37 +0200
committerlarchunix2020-09-11 23:46:37 +0200
commite6a5f6768ac33ab299a992d53f69e4be8ed2c92f (patch)
treef83303f06160560355075d8dc921009a294c55b9
parentc115cdfbe89a59bbb689a85fa362308785bf3c4d (diff)
downloadaur-e6a5f6768ac33ab299a992d53f69e4be8ed2c92f.tar.gz
Update to upstream release 0.7.15
Also try to comply to Arch Linux CMake package guidelines: => https://wiki.archlinux.org/index.php/CMake_package_guidelines Note: Arch Linux carry a downstream patch to honour CPPFLAGS environment variable since cmake-3.17.2-2. => https://github.com/archlinux/svntogit-packages/commit/bb5432e5
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD36
2 files changed, 20 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 36615862b088..06fa8644f2af 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,12 @@
pkgbase = libsolv
pkgdesc = Library for solving packages and reading repositories
- pkgver = 0.7.14
+ pkgver = 0.7.15
pkgrel = 1
url = https://github.com/openSUSE/libsolv
arch = i686
arch = x86_64
license = custom:BSD
- makedepends = cmake
+ makedepends = cmake>=3.13
makedepends = perl
makedepends = python
makedepends = ruby
@@ -21,8 +21,8 @@ pkgbase = libsolv
optdepends = perl: for perl bindings
optdepends = python: for python bindings
optdepends = ruby: for ruby bindings
- source = https://github.com/openSUSE/libsolv/archive/0.7.14/libsolv-0.7.14.tar.gz
- md5sums = a7a991fa70c310c31fabedc5b12453af
+ source = https://github.com/openSUSE/libsolv/archive/0.7.15/libsolv-0.7.15.tar.gz
+ md5sums = 81bf541831904ceb77ce041730dfeade
pkgname = libsolv
diff --git a/PKGBUILD b/PKGBUILD
index 9ad7e63b7ad7..82b6b76351d3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,24 @@
pkgname=libsolv
-pkgver=0.7.14
+pkgver=0.7.15
pkgrel=1
pkgdesc="Library for solving packages and reading repositories"
arch=('i686' 'x86_64')
url="https://github.com/openSUSE/$pkgname"
license=('custom:BSD')
depends=('bzip2' 'expat' 'rpm-tools' 'xz' 'zchunk' 'zlib' 'zstd')
-makedepends=('cmake' 'perl' 'python' 'ruby' 'swig')
+makedepends=('cmake>=3.13' 'perl' 'python' 'ruby' 'swig')
optdepends=('perl: for perl bindings'
'python: for python bindings'
'ruby: for ruby bindings')
source=("$url/archive/$pkgver/$pkgname-$pkgver.tar.gz")
-md5sums=('a7a991fa70c310c31fabedc5b12453af')
-
-prepare() {
- cd "$pkgname-$pkgver"
- rm -rf build
- mkdir build
-}
+md5sums=('81bf541831904ceb77ce041730dfeade')
build() {
- cd "$pkgname-$pkgver"/build
+ cd "$pkgname-$pkgver"
- cmake -DCMAKE_BUILD_TYPE=Release \
- -DCMAKE_C_FLAGS="$CFLAGS $CPPFLAGS" \
+ cmake -B build \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_C_FLAGS_RELEASE='-DNDEBUG' \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DUSE_VENDORDIRS=ON \
@@ -56,22 +51,23 @@ build() {
-DENABLE_ZSTD_COMPRESSION=ON \
-DMULTI_SEMANTICS=ON \
-DWITH_LIBXML2=OFF \
- ..
- make
+ make -C build
}
check() {
- cd "$pkgname-$pkgver"/build
- make ARGS="-V" test
+ cd "$pkgname-$pkgver"
+
+ make -C build ARGS="-V" test
}
package() {
- cd "$pkgname-$pkgver"/build
- make DESTDIR="$pkgdir/" install
+ cd "$pkgname-$pkgver"
+
+ make -C build DESTDIR="$pkgdir/" install
- install -Dp -m644 ../LICENSE.BSD "$pkgdir/usr/share/licenses/$pkgname/LICENSE.BSD"
- install -Dp -m644 ../README "$pkgdir/usr/share/doc/$pkgname/README"
+ install -Dp -m644 LICENSE.BSD "$pkgdir/usr/share/licenses/$pkgname/LICENSE.BSD"
+ install -Dp -m644 README "$pkgdir/usr/share/doc/$pkgname/README"
}
# vim: set ft=sh ts=4 sw=4 noet: