summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorZion Nimchuk2022-03-04 21:49:19 -0800
committerZion Nimchuk2022-03-04 21:49:19 -0800
commite6b01a49a81158330462c1f7f2e35c02debbf79e (patch)
treedbee3b19333a4862a80a8a868053e0efeb078935
parent9a0aef4e771d293c72c8822c7de56329a46d90e9 (diff)
downloadaur-e6b01a49a81158330462c1f7f2e35c02debbf79e.tar.gz
Remove usage of system flatbuffers
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD9
2 files changed, 6 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2a52309fc8a4..9abc21e9344a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = rpcs3-git
pkgdesc = A Sony PlayStation 3 emulator
- pkgver = 0.0.20.13150.bba528e2a
+ pkgver = 0.0.21.13331.e33b13060
pkgrel = 1
url = https://github.com/RPCS3/rpcs3
arch = x86_64
@@ -35,7 +35,6 @@ pkgbase = rpcs3-git
depends = zlib
depends = curl
depends = wolfssl
- depends = flatbuffers
depends = pugixml
provides = rpcs3
conflicts = rpcs3
diff --git a/PKGBUILD b/PKGBUILD
index 855f25cf39e0..e81d683820ab 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Submitter: Maxime Gauduin <alucryd@archlinux.org>
pkgname=rpcs3-git
-pkgver=0.0.20.13150.bba528e2a
+pkgver=0.0.21.13331.e33b13060
pkgrel=1
pkgdesc='A Sony PlayStation 3 emulator'
arch=(x86_64)
@@ -34,8 +34,9 @@ depends=(
zlib
curl
wolfssl
- flatbuffers
pugixml
+# newer system flatbuffers is incompatible with the version RPCS3 depends on
+# flatbuffers
)
makedepends=(
cmake
@@ -75,7 +76,7 @@ prepare() {
git config submodule.llvm.url ../rpcs3-llvm
SUBMODULES=($(git config --file .gitmodules --get-regexp path | \
- awk '!/ffmpeg/ && !/libpng/ && !/zlib/ && !/curl/ && !/llvm/ && !/glslang/ && !/wolfssl/ && !/pugixml/ && !/flatbuffers/'))
+ awk '!/ffmpeg/ && !/libpng/ && !/zlib/ && !/curl/ && !/llvm/ && !/glslang/ && !/wolfssl/ && !/pugixml/'))
# We need to convert from a relative folder path to a https://github.com path
for ((i=0;i<${#SUBMODULES[@]};i+=2))
@@ -107,7 +108,7 @@ build() {
-DUSE_SYSTEM_ZLIB=ON \
-DUSE_SYSTEM_CURL=ON \
-DUSE_SYSTEM_WOLFSSL=ON \
- -DUSE_SYSTEM_FLATBUFFERS=ON \
+ -DUSE_SYSTEM_FLATBUFFERS=OFF \
-DUSE_SYSTEM_PUGIXML=ON
make -C build