summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNikolay Korotkiy2019-10-24 00:27:00 +0300
committerNikolay Korotkiy2019-10-24 00:27:00 +0300
commite6b36251b895a444645886e5f8da942126eb8ab9 (patch)
tree07d63c818e11a07a9ba6ce542874b7a96c728251
parentfdc12dc2f81c5a90a40ff81edd3b5a8fa39f306c (diff)
downloadaur-e6b36251b895a444645886e5f8da942126eb8ab9.tar.gz
mapper release v0.9.0
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD10
2 files changed, 10 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 689a3a8c014a..0dcfd572c4d7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
-# Generated by makepkg 5.1.3
-# Wed Aug 21 23:31:54 UTC 2019
+# Generated by makepkg 5.2.0
+# Wed Oct 23 21:23:26 UTC 2019
pkgbase = openorienteering-mapper-git
pkgdesc = Map drawing program from OpenOrienteering
- pkgver = 20190820.3.r0.g90083097
+ pkgver = 0.9.0.r4.g608eb9ee
pkgrel = 1
url = https://www.openorienteering.org/apps/mapper/
install = openorienteering-mapper.install
@@ -18,9 +18,9 @@ pkgbase = openorienteering-mapper-git
depends = proj>=4.9.2
depends = gdal
optdepends = qt5-imageformats: Support for TIFF etc.
- provides = openorienteering-mapper=20190820.3.r0.g90083097
+ provides = openorienteering-mapper=0.9.0.r4.g608eb9ee
conflicts = openorienteering-mapper
- source = https://github.com/OpenOrienteering/mapper/archive/dev.tar.gz
+ source = https://github.com/OpenOrienteering/mapper/archive/master.tar.gz
sha256sums = SKIP
pkgname = openorienteering-mapper-git
diff --git a/PKGBUILD b/PKGBUILD
index 9a4f3a06ce56..6d44b43ebf36 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Maintainer: Nikolay Korotkiy <sikmir@gmail.com>
_orgname=OpenOrienteering
_pkgname=mapper
-_branch=dev
+_branch=master
_use_gh_api=true
_gh_api_url="https://api.github.com/repos/${_orgname}/${_pkgname}"
_wl_project=${_orgname}
_wl_hz="https://hosted.weblate.org/healthz/"
_wl_dl="https://hosted.weblate.org/download/${_wl_project}"
pkgname=${_orgname,,}-${_pkgname}-git
-pkgver=20190820.3.r0.g90083097
+pkgver=0.9.0.r4.g608eb9ee
pkgrel=1
pkgdesc='Map drawing program from OpenOrienteering'
arch=(x86_64)
@@ -34,12 +34,12 @@ sha256sums=('SKIP')
pkgver() {
if [ "${_use_gh_api}" = true ]; then
- read -r tag_name tag_sha <<<$(curl -s "${_gh_api_url}/tags" | \
- jq -r '.[0]|[.name,.commit.sha]|@sh' | sed "s/'//g")
+ read -r tag_name tag_sha <<<$(curl -s "${_gh_api_url}/releases" | \
+ jq -r '.[0]|[.tag_name,.target_commitish]|@sh' | sed "s/'//g")
head=$(curl -s "${_gh_api_url}/git/refs/heads/${_branch}" | \
jq -r '.object.sha')
count=$(curl -s "${_gh_api_url}/compare/${tag_sha}...${head}" | \
- jq -r '.total_commits')
+ jq -r '.behind_by')
tag_name=${tag_name//-/.} # pkgver is not allowed to contain hyphens
printf "%s.r%s.g%.8s" "${tag_name#?}" "${count}" "${head}"