summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDan Shick2021-03-16 16:22:27 -0400
committerDan Shick2021-03-16 16:22:27 -0400
commite6b3e55174768f6c5b558f19f2d75653035fb49a (patch)
tree2e9dc9eae39a154ac233485a55ba9eaff0dcec4e
parent60b0866a7c6b886921aef2114fa340ec42cc003e (diff)
downloadaur-e6b3e55174768f6c5b558f19f2d75653035fb49a.tar.gz
Add scdoc to makedepends
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD4
-rwxr-xr-xupdate-depends.sh1
3 files changed, 5 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1fd83136037a..e7dfa8f45a31 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = xdg-desktop-portal-wlr-git
pkgdesc = xdg-desktop-portal backend for wlroots
- pkgver = v0.2.0.r1.g07154bb
+ pkgver = v0.2.0.r10.g6c8f6ca
pkgrel = 1
url = https://github.com/emersion/xdg-desktop-portal-wlr
arch = x86_64
@@ -9,6 +9,7 @@ pkgbase = xdg-desktop-portal-wlr-git
makedepends = meson
makedepends = wayland-protocols
makedepends = wayland
+ makedepends = scdoc
depends = xdg-desktop-portal
depends = pipewire
depends = iniparser
diff --git a/PKGBUILD b/PKGBUILD
index 4518dfb13056..6075b0001318 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Davide Depau <davide@depau.eu>
pkgname=xdg-desktop-portal-wlr-git
-pkgver=v0.2.0.r1.g07154bb
+pkgver=v0.2.0.r10.g6c8f6ca
pkgrel=1
pkgdesc='xdg-desktop-portal backend for wlroots'
url=https://github.com/emersion/xdg-desktop-portal-wlr
@@ -10,7 +10,7 @@ license=(custom:MIT)
provides=("${pkgname%-git}" "xdg-desktop-portal-impl")
conflicts=("${pkgname%-git}")
depends=(xdg-desktop-portal pipewire iniparser)
-makedepends=(git meson wayland-protocols wayland)
+makedepends=(git meson wayland-protocols wayland scdoc)
optdepends=(
"libpipewire02: For Chromium WebRTC desktop screencast (see project GitHub page)"
"obs-xdg-portal: OBS Studio plugin for XDG Desktop Portal (or wlrobs for direct wlroots integration)"
diff --git a/update-depends.sh b/update-depends.sh
index 9ac2f3f41e9d..6b708076cc7f 100755
--- a/update-depends.sh
+++ b/update-depends.sh
@@ -31,6 +31,7 @@ echo "$pkgs" | grep -q meson && move_to_makedepends meson
echo "$pkgs" | grep -q wayland-protocols && move_to_makedepends wayland-protocols
echo "$pkgs" | grep -q wayland && move_to_makedepends wayland
echo "$pkgs" | grep -q systemd-libs && move_to_makedepends systemd-libs
+echo "$pkgs" | grep -q scdoc && move_to_makedepends scdoc
# Strip out empty lines
pkgs="$(echo "$pkgs" | sed '/^$/d')"