summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorshinnova2018-01-12 21:06:31 +0100
committershinnova2018-01-12 21:06:31 +0100
commite6bdb6262fec75e21d9b60961e488c33a4e626a0 (patch)
treec32776d3e344efd924c6f6a5a8c765b03daeb222
downloadaur-e6bdb6262fec75e21d9b60961e488c33a4e626a0.tar.gz
First commit
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD34
-rw-r--r--hex-tcg.desktop10
-rwxr-xr-xhex-tcg_startup5
4 files changed, 72 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6bafd53809d0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = hex-tcg
+ pkgdesc = Unofficial build for Hex: Shards of Fate, a digital card game
+ pkgver = 1.0.8.045
+ pkgrel = 1
+ url = https://www.hextcg.com/
+ arch = i686
+ arch = x86_64
+ license = custom: commercial
+ depends = libgl
+ depends = curl
+ options = !strip
+ options = staticlibs
+ source = http://fallback.hextcg.com/static/live/linux/hex.tar.gz
+ source = https://www.hextcg.com/wp-content/themes/hex/images/logo-hex.png
+ source = hex-tcg_startup
+ source = hex-tcg.desktop
+ sha256sums = 447a4437febe26cab06ea7de981fc1a58220f85d97f73601e664f73b4c21ab88
+ sha256sums = SKIP
+ sha256sums = bc5c554bc1142e02f45eb1877388e595106362bad79c0f9232d124d51f981ecc
+ sha256sums = 27d2511d1044a340e313d715c85f79752269032ae1ecc2eeefbfadf0bfc2dd50
+
+pkgname = hex-tcg
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fdb6701fe94a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Ivanka Heins (ivanka@tuta.io)
+# Contributor: oleerik
+
+pkgname="hex-tcg"
+pkgver="1.0.8.045"
+_pkgname="hex"
+pkgrel="1"
+pkgdesc="Unofficial build for Hex: Shards of Fate, a digital card game"
+arch=('i686' 'x86_64')
+url="https://www.hextcg.com/"
+options=("!strip" "staticlibs")
+license=("custom: commercial")
+depends=("libgl" "curl")
+source=("http://fallback.hextcg.com/static/live/linux/hex.tar.gz"
+ "https://www.hextcg.com/wp-content/themes/hex/images/logo-hex.png"
+ "hex-tcg_startup"
+ "hex-tcg.desktop")
+sha256sums=("447a4437febe26cab06ea7de981fc1a58220f85d97f73601e664f73b4c21ab88"
+ "SKIP"
+ "bc5c554bc1142e02f45eb1877388e595106362bad79c0f9232d124d51f981ecc"
+ "27d2511d1044a340e313d715c85f79752269032ae1ecc2eeefbfadf0bfc2dd50")
+
+package() {
+ cd $srcdir
+ install -dm755 "${pkgdir}/usr/bin" "${pkgdir}/opt/${pkgname}"
+ install -Dm755 Hex.x86 "${pkgdir}/opt/${pkgname}/Hex.x86"
+ install -Dm644 logo-hex.png "${pkgdir}/usr/share/icons/logo-hex.png"
+ install -Dm644 hex-tcg.desktop "${pkgdir}"/usr/share/applications/hex-tcg.desktop
+ cp -dr AssetBundles/ "${pkgdir}/opt/${pkgname}/AssetBundles"
+ cp -d config.ini "${pkgdir}/opt/${pkgname}/config.ini"
+ cp -dr Data/ "${pkgdir}/opt/${pkgname}/Data"
+ cp -dr Hex_Data/ "${pkgdir}/opt/${pkgname}/Hex_Data"
+ install -Dm755 hex-tcg_startup "${pkgdir}/usr/bin/${pkgname}"
+}
diff --git a/hex-tcg.desktop b/hex-tcg.desktop
new file mode 100644
index 000000000000..e550e4818ec5
--- /dev/null
+++ b/hex-tcg.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Hidden=false
+Exec=hex-tcg
+Icon=/usr/share/icons/logo-hex.png
+Type=Application
+Categories=Game;
+NoDisplay=false
+StartupNotify=false
+Terminal=false
+Name=Hex Shards of Fate
diff --git a/hex-tcg_startup b/hex-tcg_startup
new file mode 100755
index 000000000000..9ef1775b31c6
--- /dev/null
+++ b/hex-tcg_startup
@@ -0,0 +1,5 @@
+#!/bin/bash
+
+cd /opt/hex-tcg/
+./Hex.x86
+cd -