summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfrealgagu2020-07-14 19:45:26 -0500
committerfrealgagu2020-07-14 19:45:26 -0500
commite6d5c6ebda32f2c1ac967ca3bd5f8cacd7c1a77b (patch)
tree58f3d8d97cd61bc4f6f3ab522f3fc55a469bc640
parent489fbddb90e0590bb09325b9e8d52a07ae5926bf (diff)
downloadaur-e6d5c6ebda32f2c1ac967ca3bd5f8cacd7c1a77b.tar.gz
Adding group flutterusers at post_install. Changing dependency from lib32-libglvnd to libglvnd.
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD4
-rw-r--r--flutter.install20
3 files changed, 11 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e0b23e95b4a0..c8fe5c81d728 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = flutter
pkgdesc = A new mobile app SDK to help developers and designers build modern mobile apps for iOS and Android.
pkgver = 1.17.5
- pkgrel = 1
+ pkgrel = 2
url = https://flutter.io
install = flutter.install
arch = x86_64
@@ -9,7 +9,6 @@ pkgbase = flutter
license = BSD
license = CCPL
makedepends = python
- depends = bash
depends = git
depends = glu
depends = java-environment
diff --git a/PKGBUILD b/PKGBUILD
index 56490da524af..676bb1a01f88 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,12 +3,12 @@
pkgname=flutter
pkgver=1.17.5
-pkgrel=1
+pkgrel=2
pkgdesc="A new mobile app SDK to help developers and designers build modern mobile apps for iOS and Android."
arch=("x86_64")
url="https://${pkgname}.io"
license=("custom" "BSD" "CCPL")
-depends=("bash" "git" "glu" "java-environment" "libglvnd" "unzip")
+depends=("git" "glu" "java-environment" "libglvnd" "unzip")
optdepends=("android-sdk" "android-studio" "dart" "intellij-idea-community-edition" "intellij-idea-ultimate-edition" "perl" "python")
makedepends=("python")
backup=("opt/${pkgname}/packages/${pkgname}_test/pubspec.yaml" "opt/${pkgname}/packages/${pkgname}/pubspec.yaml")
diff --git a/flutter.install b/flutter.install
index 38b040390344..8e5693109561 100644
--- a/flutter.install
+++ b/flutter.install
@@ -1,20 +1,15 @@
post_install() {
+ groupadd -f flutterusers
+ chgrp -R flutterusers /opt/flutter
+ chmod -R g+w /opt/flutter
printf "$(tput setaf 4)Flutter was installed on $(tput setaf 2)/opt/flutter$(tput sgr0)\n"
printf "$(tput setaf 4)$(tput sgr0)\n"
- printf "$(tput setaf 4)You need to source $(tput setaf 2)/etc/profile$(tput setaf 4) or relogin to add flutter to your path.$(tput sgr0)\n"
+ printf "$(tput setaf 4)If you intend to use it as a regular user, add your user into the group flutterusers:$(tput sgr0)\n"
+ printf "$(tput setaf 2)gpasswd -a <user> flutterusers$(tput sgr0)\n"
printf "$(tput setaf 4)$(tput sgr0)\n"
- printf "$(tput setaf 4)This folder has root permissions, so keep in mind to run flutter as root,$(tput sgr0)\n"
- printf "$(tput setaf 4)otherwise you will not be able to modify anything in this directory.$(tput sgr0)\n"
+ printf "$(tput setaf 4)You need to source $(tput setaf 2)/etc/profile$(tput setaf 4) or relogin to add flutter to your path.$(tput sgr0)\n"
printf "$(tput setaf 4)$(tput sgr0)\n"
- printf "$(tput setaf 4)If you intend to use it as a regular user, create the Flutter users group:$(tput sgr0)\n"
- printf "$(tput setaf 2)groupadd flutterusers$(tput sgr0)\n"
- printf "$(tput setaf 4)Add your user into this group:$(tput sgr0)\n"
- printf "$(tput setaf 2)gpasswd -a <user> flutterusers$(tput sgr0)\n"
- printf "$(tput setaf 4)Change folder's group.$(tput sgr0)\n"
- printf "$(tput setaf 2)chown -R :flutterusers /opt/flutter$(tput sgr0)\n"
- printf "$(tput setaf 4)Change permissions of the folder so the user that was just added to the group will be able to write in it:$(tput sgr0)\n"
- printf "$(tput setaf 2)chmod -R g+w /opt/flutter$(tput sgr0)\n"
- printf "$(tput setaf 4)Re-login your terminal in to the newly created group:$(tput sgr0)\n"
+ printf "$(tput setaf 4)Re-login your terminal in to the group flutterusers:$(tput sgr0)\n"
printf "$(tput setaf 2)newgrp flutterusers$(tput sgr0)\n"
}
@@ -23,6 +18,7 @@ post_upgrade() {
}
post_remove() {
+ groupdel flutterusers
printf "$(tput setaf 4)If you had added/modified files or permissions in folder /opt/flutter is possible you need to delete it manually.$(tput sgr0)\n"
printf "$(tput setaf 2)rm -rf /opt/flutter$(tput sgr0)\n"
}