summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2021-05-22 16:34:15 -0500
committerLuis Martinez2021-05-22 16:35:20 -0500
commite6db3f16293a8d2e2c97a85026c736e258f60c34 (patch)
tree5059889ef29955c4fb9cc95e9f57e6eed71b1355
parent80685c8a5ebe228608424405d6f7ebfd3efce7c7 (diff)
downloadaur-e6db3f16293a8d2e2c97a85026c736e258f60c34.tar.gz
PKGBUILD rewrite
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD51
2 files changed, 29 insertions, 39 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fa4801da7738..7653ff7f6fc5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,18 @@
pkgbase = emulsion-bin
- pkgdesc = A fast and minimalistic image viewer
+ pkgdesc = A fast and minimalistic image viewer (binary release)
pkgver = 9.0
- pkgrel = 1
- url = https://arturkovacs.github.io/emulsion-website/
+ pkgrel = 2
+ url = https://arturkovacs.github.io/emulsion-website
arch = x86_64
license = MIT
- makedepends = coreutils
- makedepends = tar
- optdepends = hicolor-icon-theme: hicolor theme hierarchy
+ makedepends = dpkg
+ depends = gcc-libs
+ optdepends = hicolor-icon-theme
provides = emulsion
conflicts = emulsion
- source = https://github.com/ArturKovacs/emulsion/releases/download/v9.0/Emulsion-Linux.deb-v9.0.deb
- md5sums = fde7100a3764cf25eca0fbd0f30c860d
+ options = !emptydirs
+ source = emulsion-9.0.deb::https://github.com/arturkovacs/emulsion/releases/download/v9.0/Emulsion-Linux.deb-v9.0.deb
+ sha256sums = f66ab3b655af4da6e4c3fb60540c241cc9e7055ab70a0638aedd8af484d90427
pkgname = emulsion-bin
diff --git a/PKGBUILD b/PKGBUILD
index 58bbd4349429..4beecb179a66 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,37 +1,26 @@
-# Maintainer: Szymon Scholz <first name last name [at] gmail [dot] com>
+# Maintainer: Luis Martinez <luis dot martinez at tuta dot io>
+# Contributor: Szymon Scholz <first name last name [at] gmail [dot] com>
-pkgname='emulsion-bin'
-pkgver='9.0'
-pkgrel='1'
-pkgdesc='A fast and minimalistic image viewer'
+pkgname=emulsion-bin
+_name="${pkgname%-bin}"
+pkgver=9.0
+pkgrel=2
+pkgdesc="A fast and minimalistic image viewer (binary release)"
arch=('x86_64')
-conflicts=('emulsion')
-provides=('emulsion')
-makedepends=(
- 'coreutils'
- 'tar'
-)
-optdepends=(
- 'hicolor-icon-theme: hicolor theme hierarchy'
-)
-url='https://arturkovacs.github.io/emulsion-website/'
+url="https://arturkovacs.github.io/emulsion-website"
license=('MIT')
-source=(
- "https://github.com/ArturKovacs/emulsion/releases/download/v$pkgver/Emulsion-Linux.deb-v$pkgver.deb"
-)
-md5sums=('fde7100a3764cf25eca0fbd0f30c860d')
-
-_mirror() {
- install "$1" "usr/$2" "$pkgdir/usr/$2"
-}
+depends=('gcc-libs')
+makedepends=('dpkg')
+optdepends=('hicolor-icon-theme')
+provides=("$_name")
+conflicts=("$_name")
+options=(!emptydirs)
+source=("$_name-$pkgver.deb::https://github.com/arturkovacs/emulsion/releases/download/v$pkgver/Emulsion-Linux.deb-v$pkgver.deb")
+sha256sums=('f66ab3b655af4da6e4c3fb60540c241cc9e7055ab70a0638aedd8af484d90427')
package() {
- #msg2 'Extracting data...'
- tar xf data.tar.gz
-
- #msg2 'Installing...'
- install -Dm644 usr/lib/emulsion/LICENSE.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
- _mirror -Dm755 bin/emulsion
- _mirror -Dm755 share/applications/emulsion.desktop
- _mirror -Dm644 share/icons/hicolor/256x256/apps/emulsion.png
+ dpkg-deb --extract "$_name-$pkgver.deb" "$pkgdir/"
+ install -d "$pkgdir/usr/share/licenses/$pkgname/"
+ mv "$pkgdir/usr/lib/$_name/LICENSE.txt" "$pkgdir/usr/share/licenses/$pkgname/"
+ chown -R root:root "$pkgdir/"
}