summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjustforlxz2022-02-25 13:47:44 +0800
committerjustforlxz2022-02-25 13:47:44 +0800
commite6dd0ad943759b368f4bd59790e3710570d20137 (patch)
tree518ef3427f64312031473a3fc98c38f7ad2a0336
parente3aa7095247645f5dde5ed737ef29e3dd65734f5 (diff)
downloadaur-e6dd0ad943759b368f4bd59790e3710570d20137.tar.gz
update
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD22
-rw-r--r--fix.patch61
3 files changed, 80 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 786c52305719..e64e12591a2d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,17 @@
pkgbase = deepin-polkit-agent-git
pkgdesc = Deepin Polkit Agent
- pkgver = 5.4.3.r3.g6140269
+ pkgver = 5.5.3.r10.g0def9c0
pkgrel = 1
url = https://github.com/linuxdeepin/dde-polkit-agent
- arch = x86_64
+ arch = aarch64
groups = deepin-git
license = GPL3
makedepends = git
- makedepends = qt5-tools
+ makedepends = polkit-qt5
+ makedepends = dtkcommon-git
makedepends = dtkwidget-git
+ makedepends = cmake
+ makedepends = ninja
depends = deepin-qt-dbus-factory-git
depends = startdde-git
depends = polkit-qt5
@@ -16,6 +19,8 @@ pkgbase = deepin-polkit-agent-git
provides = deepin-polkit-agent
conflicts = deepin-polkit-agent
source = deepin-polkit-agent-git::git://github.com/linuxdeepin/dde-polkit-agent
+ source = fix.patch
sha512sums = SKIP
+ sha512sums = b02235cece90a01942cd0898cfb85c7eb8fa6f980c4e1d83cfa115baba1599ca878788b5d89338444afe8267c30b11f9279ebda98d3bbc3dd4f3fe03cd1f0572
pkgname = deepin-polkit-agent-git
diff --git a/PKGBUILD b/PKGBUILD
index 33769ffb2fde..74da63558661 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,21 @@
# Maintainer: justforlxz <justforlxz@gmail.com>
pkgname=deepin-polkit-agent-git
-pkgver=5.4.3.r3.g6140269
+pkgver=5.5.3.r10.g0def9c0
pkgrel=1
pkgdesc='Deepin Polkit Agent'
-arch=('x86_64')
+arch=('aarch64')
url="https://github.com/linuxdeepin/dde-polkit-agent"
license=('GPL3')
depends=('deepin-qt-dbus-factory-git' 'startdde-git' 'polkit-qt5' 'dtkwidget-git')
-makedepends=('git' 'qt5-tools' 'dtkwidget-git')
+makedepends=('git' 'polkit-qt5' 'dtkcommon-git' 'dtkwidget-git' 'cmake' 'ninja')
conflicts=('deepin-polkit-agent')
provides=('deepin-polkit-agent')
groups=('deepin-git')
-source=("$pkgname::git://github.com/linuxdeepin/dde-polkit-agent")
-sha512sums=('SKIP')
+source=("$pkgname::git://github.com/linuxdeepin/dde-polkit-agent"
+ "fix.patch")
+sha512sums=('SKIP'
+ 'b02235cece90a01942cd0898cfb85c7eb8fa6f980c4e1d83cfa115baba1599ca878788b5d89338444afe8267c30b11f9279ebda98d3bbc3dd4f3fe03cd1f0572')
pkgver() {
cd $pkgname
@@ -22,18 +24,16 @@ pkgver() {
prepare() {
cd $pkgname
- # https://github.com/linuxdeepin/developer-center/issues/1721
- sed -i 's/bool is_deepin = true/bool is_deepin = false/' policykitlistener.cpp
- sed -i '/setCancel/d' policykitlistener.cpp
+ patch -p1 -i ../fix.patch
}
build() {
cd $pkgname
- qmake-qt5 PREFIX=/usr
- make -j$(nproc)
+ cmake . -G Ninja -DCMAKE_INSTALL_PREFIX=/usr
+ ninja
}
package() {
cd $pkgname
- make INSTALL_ROOT="$pkgdir" install
+ DESTDIR="$pkgdir" ninja install
}
diff --git a/fix.patch b/fix.patch
new file mode 100644
index 000000000000..3cbb63980ae2
--- /dev/null
+++ b/fix.patch
@@ -0,0 +1,61 @@
+--- test/policykitlistener.cpp 2022-02-23 21:39:00.000000000 +0800
++++ dde-polkit-agent/policykitlistener.cpp 2022-02-23 21:36:43.000000000 +0800
+@@ -203,7 +203,7 @@ void PolicyKitListener::completed(bool g
+ m_showInfoSuccess = false;
+
+ if (m_exAuth) {
+- m_session.data()->authCtrl(AUTH_CLOSE, -1);
++ //m_session.data()->authCtrl(AUTH_CLOSE, -1);
+ }
+ finishObtainPrivilege();
+ }
+@@ -243,7 +243,7 @@ void PolicyKitListener::exAuthInfo(bool
+ m_isMfa = isMfa;
+
+ if (!isMfa) {
+- m_session.data()->authCtrl(AUTH_START, -1);
++ //m_session.data()->authCtrl(AUTH_START, -1);
+ }
+ }
+
+@@ -271,7 +271,7 @@ void PolicyKitListener::createSessionFor
+ }
+ // We will create new session only when some user is selected
+ if (m_selectedUser.isValid()) {
+- m_session = new Session(m_selectedUser, m_cookie, m_result, &m_details);
++ m_session = new Session(m_selectedUser, m_cookie, m_result);
+
+ connect(m_session.data(), &Session::request, this,
+ &PolicyKitListener::request);
+@@ -281,10 +281,10 @@ void PolicyKitListener::createSessionFor
+ &PolicyKitListener::showError);
+ connect(m_session.data(), &Session::showInfo, this,
+ &PolicyKitListener::showInfo);
+- connect(m_session.data(), &Session::exAuthStatus, this,
+- &PolicyKitListener::exAuthStatus);
+- connect(m_session.data(), &Session::exAuthInfo, this,
+- &PolicyKitListener::exAuthInfo);
++// connect(m_session.data(), &Session::exAuthStatus, this,
++// &PolicyKitListener::exAuthStatus);
++// connect(m_session.data(), &Session::exAuthInfo, this,
++// &PolicyKitListener::exAuthInfo);
+
+ m_session->initiate();
+ }
+@@ -294,14 +294,14 @@ void PolicyKitListener::fillResult()
+ {
+ if (!m_session.isNull()) {
+ if (m_wasCancelled) {
+- m_session.data()->result()->setCancel("aciton cancel");
++ m_session.data()->result()->setError("aciton cancel");
+ } else if (!m_gainedAuthorization) {
+ m_session.data()->result()->setError("password error");
+ }
+ m_session.data()->result()->setCompleted();
+ } else {
+ if (m_wasCancelled) {
+- m_result->setCancel("action cancel");
++ m_result->setError("action cancel");
+ } else if (!m_gainedAuthorization) {
+ m_result->setError("password error");
+ }