summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLoen2016-06-24 18:59:58 +0000
committerLoen2016-06-24 18:59:58 +0000
commite704aa18a357c55c0833d4b4f70b03506f7cb858 (patch)
tree64d8f21de5bf80d3d81e73cf77f902455ffe85ac
parent675c5d9eb29b2e98c0a5b8ae115723eb0f24efbe (diff)
downloadaur-e704aa18a357c55c0833d4b4f70b03506f7cb858.tar.gz
First Loen commit
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD26
2 files changed, 23 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ef28ee78bc67..6cef008985c8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,17 @@
-# Generated by mksrcinfo v8
-# Fri Feb 5 04:53:28 UTC 2016
pkgbase = python-exifread
pkgdesc = Read Exif metadata from tiff and jpeg files.
pkgver = 2.1.2
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/ianare/exif-py
arch = any
license = BSD
- makedepends = python-setuptools
+ makedepends = python2-pip
+ makedepends = python-pip
depends = python
source = https://pypi.python.org/packages/source/E/ExifRead/ExifRead-2.1.2.tar.gz
- sha256sums = 79e244f2eb466709029e8806fe5e2cdd557870c3db5f68954db0ef548d9320ad
+ md5sums = 8f5099e11e2137e0ce5acbec91c219be
+
+pkgname = python2-exifread
pkgname = python-exifread
- depends = python
diff --git a/PKGBUILD b/PKGBUILD
index 9e167dbfde94..018c543020e6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,30 @@
-#Maintainer: David McInnis <davidm@eagles.ewu.edu>
+# Maintainer: Christopher Loen <christopherloen at gmail dot com>
+# Contributor: David McInnis <davidm@eagles.ewu.edu>
pkgbase=('python-exifread')
-pkgname=('python-exifread')
+pkgname=('python2-exifread' 'python-exifread')
_module='ExifRead'
pkgver='2.1.2'
-pkgrel=1
+pkgrel=2
pkgdesc="Read Exif metadata from tiff and jpeg files."
url="https://github.com/ianare/exif-py"
depends=('python')
-makedepends=('python-setuptools')
+makedepends=('python2-pip' 'python-pip')
license=('BSD')
arch=('any')
source=("https://pypi.python.org/packages/source/E/ExifRead/ExifRead-${pkgver}.tar.gz")
-sha256sums=('79e244f2eb466709029e8806fe5e2cdd557870c3db5f68954db0ef548d9320ad')
+md5sums=('8f5099e11e2137e0ce5acbec91c219be')
-package() {
- depends+=()
+package_python2-exifread() {
cd "${srcdir}/${_module}-${pkgver}"
- python setup.py install --root="${pkgdir}" --optimize=1
- install -Dm644 LICENSE.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.txt"
+ echo :: Installing for python2.7 ...
+ pip2 install --isolated --root="${pkgdir}" --no-deps --ignore-installed .
+
+ install -Dm644 LICENSE.txt "${pkgdir}/usr/share/licenses/${pkgbase}/LICENSE.txt"
+}
+
+package_python-exifread() {
+ cd "${srcdir}/${_module}-${pkgver}"
+ echo :: Installing for python3 up to python3.4 ...
+ pip3 install --isolated --root="${pkgdir}" --no-deps --ignore-installed .
}