summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorblackhole2015-06-09 14:14:51 +0200
committerblackhole2015-06-09 14:14:51 +0200
commite714c46a0197bb78364d44d25add23e8484304fe (patch)
treecf45fb0d7ce626ddf1f3224423924dea80522aa6
downloadaur-e714c46a0197bb78364d44d25add23e8484304fe.tar.gz
Initial import
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD40
-rw-r--r--unified-remote-server.install25
-rw-r--r--urserver.service11
4 files changed, 96 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ba4f76fa4a3d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = unified-remote-server
+ pkgdesc = Unified Remote Server
+ pkgver = 3.2.5.703
+ pkgrel = 1
+ url = http://www.unifiedremote.com/
+ install = unified-remote-server.install
+ arch = x86_64
+ license = freeware
+ depends = libxext
+ depends = libx11
+ depends = bluez-libs
+ optdepends = bluez
+ optdepends = bluez-utils
+ source = http://www.unifiedremote.com/static/builds/server/linux-x64/703/urserver-3.2.5.703.deb
+ source = urserver.service
+ sha256sums = 5d02b48f9436815641718cef704592a11148f5894718d7a99f14da0fd0c52325
+ sha256sums = ca049fc2e6b08276bf22b262577feca3fb4f83bef95e8f95a95d16b8d59fd107
+
+pkgname = unified-remote-server
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dfa0da9c3278
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: AudioLinux <audiolinux AT fastmail DOT fm>
+# Contributor: peace4all <markspost at rocketmail dot com>
+
+pkgname=unified-remote-server
+pkgver=3.2.5.703
+pkgrel=1
+pkgdesc="Unified Remote Server"
+arch=('x86_64')
+url="http://www.unifiedremote.com/"
+depends=('libxext' 'libx11' 'bluez-libs')
+optdepends=('bluez' 'bluez-utils')
+license=('freeware')
+install=$pkgname.install
+source=("http://www.unifiedremote.com/static/builds/server/linux-x64/703/urserver-$pkgver.deb" "urserver.service")
+sha256sums=('5d02b48f9436815641718cef704592a11148f5894718d7a99f14da0fd0c52325' 'ca049fc2e6b08276bf22b262577feca3fb4f83bef95e8f95a95d16b8d59fd107' )
+
+package() {
+ cd ${srcdir}
+
+ # decompress data
+ tar zxf data.tar.gz
+
+ # fix and revert desktop file to old behaviour
+ sed -i -e '9,24d;26d' $(find . -name 'urserver.desktop')
+
+ # install folders
+ mkdir -p ${pkgdir}/{opt,usr}
+ cp -r {opt,usr} "${pkgdir}/"
+
+ # clean up permissions
+ find "${pkgdir}" -type d | xargs -I {} chmod -R 755 "{}"
+ find "${pkgdir}" -type f | xargs -I {} chmod -R 644 "{}"
+ chmod 755 "${pkgdir}/opt/urserver/urserver"
+ chmod 755 "${pkgdir}/opt/urserver/urserver-start"
+ chmod 755 "${pkgdir}/opt/urserver/urserver-stop"
+
+ # add systemd service
+ install -Dm644 "urserver.service" "$pkgdir/usr/lib/systemd/system/urserver.service"
+}
+
diff --git a/unified-remote-server.install b/unified-remote-server.install
new file mode 100644
index 000000000000..b95a1284607c
--- /dev/null
+++ b/unified-remote-server.install
@@ -0,0 +1,25 @@
+post_install() {
+ gtk-update-icon-cache -q -t -f /usr/share/icons/hicolor
+echo "
+ The simplest way to start the server is:
+ /opt/urserver/urserver --daemon
+
+ add the above line to a startup script etc.
+
+ For more options:
+ /opt/urserver/urserver --help
+
+ See link for port configurations:
+ http://wiki.unifiedremote.com/wiki/Configuration:Routers_and_Ports
+
+ Configure server from a browser:
+ localhost:9510/web"
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ gtk-update-icon-cache -q -t -f /usr/share/icons/hicolor
+}
diff --git a/urserver.service b/urserver.service
new file mode 100644
index 000000000000..7fc620280b0c
--- /dev/null
+++ b/urserver.service
@@ -0,0 +1,11 @@
+[Unit]
+Description=Unified Remote Server
+After=network.target
+
+[Service]
+RemainAfterExit=yes
+ExecStart=/bin/bash /opt/urserver/urserver-start
+ExecStop=/bin/bash /opt/urserver/urserver-stop
+
+[Install]
+WantedBy=network.target