summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTércio Martins2022-08-13 03:37:21 -0300
committerTércio Martins2022-08-13 03:37:21 -0300
commite73315421c0e6209a6d306629dffc0b31314c95c (patch)
tree924b34ee9fd91e1a4a22307dcd149611440c042a
parent7a7ecc8067bd23f87001e4d77f679eae854207ae (diff)
downloadaur-e73315421c0e6209a6d306629dffc0b31314c95c.tar.gz
Insert "provides" variable in PKGBUILD
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD7
2 files changed, 8 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f196e2c31545..93485b09f317 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,16 @@
pkgbase = openfx-misc-git
pkgdesc = Miscellaneous OpenFX plugins
- pkgver = Natron.2.4.1.r0.g73ee8412
+ pkgver = Natron.2.4.3.r2.gaac35191
pkgrel = 1
url = https://github.com/NatronGitHub/openfx-misc
arch = x86_64
license = GPL
+ makedepends = git
makedepends = openmp
depends = libgl
+ depends = python
optdepends = natron-plugins-git: More presets for the Shadertoy plugin
+ provides = openfx-misc
conflicts = openfx-misc
source = openfx-misc::git+https://github.com/NatronGitHub/openfx-misc
source = openfx::git+https://github.com/NatronGitHub/openfx
diff --git a/PKGBUILD b/PKGBUILD
index eb8631128ae6..218ca57d4fa8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,20 +3,21 @@
# Contributor: Luca Weiss <luca (at) z3ntu (dot) xyz>
pkgname=openfx-misc-git
-pkgver=Natron.2.4.1.r0.g73ee8412
+pkgver=Natron.2.4.3.r2.gaac35191
pkgrel=1
arch=('x86_64')
pkgdesc="Miscellaneous OpenFX plugins"
url="https://github.com/NatronGitHub/openfx-misc"
license=('GPL')
-depends=('libgl')
-makedepends=('openmp')
+depends=('libgl' 'python')
+makedepends=('git' 'openmp')
optdepends=('natron-plugins-git: More presets for the Shadertoy plugin')
_pkgname=${pkgname%-git}
_url=${url%/${_pkgname}}
conflicts=("${_pkgname}")
+provides=("${_pkgname}")
source=("${_pkgname}::git+${url}"
"openfx::git+${_url}/openfx"