summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRaphael Nestler2015-08-16 01:07:08 +0200
committerRaphael Nestler2015-08-16 01:07:08 +0200
commite75072fd34efa87b7b6a06021723c86e7391c5f5 (patch)
tree40922dccbb4a852b038ba329eb124528b976ad18
downloadaur-e75072fd34efa87b7b6a06021723c86e7391c5f5.tar.gz
Initial import
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD33
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..647c5a0b3988
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = libbtbb-git
+ pkgdesc = Bluetooth baseband decoding library
+ pkgver = 2014.02.R2.r53.gac7dabc
+ pkgrel = 1
+ epoch = 2
+ url = https://github.com/greatscottgadgets/libbtbb
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = cmake
+ makedepends = python2
+ makedepends = git
+ depends = zlib
+ depends = openssl
+ depends = libssh2
+ provides = libbtbb
+ conflicts = libbtbb
+ source = git://github.com/greatscottgadgets/libbtbb
+ md5sums = SKIP
+
+pkgname = libbtbb-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b551f2a3e3c3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Raphael Nestler <raphael.nestler@gmail.com>
+
+_gitname=libbtbb
+pkgname=libbtbb-git
+pkgver=2014.02.R2.r53.gac7dabc
+epoch=2
+pkgrel=1
+pkgdesc='Bluetooth baseband decoding library'
+arch=('i686' 'x86_64')
+url="https://github.com/greatscottgadgets/libbtbb"
+license=('GPL2')
+depends=(python)
+makedepends=(cmake python2 git)
+provides=('libbtbb')
+conflicts=('libbtbb')
+source=(git://github.com/greatscottgadgets/libbtbb)
+md5sums=(SKIP)
+
+pkgver() {
+ cd $_gitname
+ git describe --long --tags | sed -r 's/([^-]*-g)/r\1/;s/-/./g;s/v//'
+}
+
+build() {
+ cd $_gitname
+ cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr \
+ -DTHREADSAFE=ON -DPYTHON_EXECUTABLE=/usr/bin/python2
+ make
+}
+
+package() {
+ make -C $_gitname DESTDIR="$pkgdir" install
+}