summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2023-10-30 14:58:50 -0600
committerMark Wagie2023-10-30 14:58:50 -0600
commite76c067945396e6df4d757b2e7d254f8ab1af2c1 (patch)
tree032ea2b0b937d3e064151e19361783d38372d241
parent4f65090681ea2f80125f7e14bbf30f152db21ee6 (diff)
downloadaur-e76c067945396e6df4d757b2e7d254f8ab1af2c1.tar.gz
remove check dep on Xvfb
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD15
2 files changed, 6 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f7d46bf078b4..c592f3009a04 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = nicotine-plus-git
pkgdesc = A graphical client for the SoulSeek peer-to-peer system
- pkgver = 3.3.0.dev5.r9680.2b040538b
+ pkgver = 3.3.0.dev6.r9955.023383076
pkgrel = 1
url = https://nicotine-plus.org
arch = any
license = GPL3
checkdepends = appstream-glib
checkdepends = desktop-file-utils
- checkdepends = python-pytest-xvfb
+ checkdepends = python-pytest
makedepends = git
makedepends = python-build
makedepends = python-installer
diff --git a/PKGBUILD b/PKGBUILD
index 60ff3f14d1b7..1371a3fdd0bb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# Contributor: x-demon
pkgname=nicotine-plus-git
_appdata_id=org.nicotine_plus.Nicotine
-pkgver=3.3.0.dev5.r9680.2b040538b
+pkgver=3.3.0.dev6.r9955.023383076
pkgrel=1
pkgdesc="A graphical client for the SoulSeek peer-to-peer system"
arch=('any')
@@ -16,7 +16,7 @@ optdepends=('gtk4: default GTK version'
'libadwaita: for Adwaita theme on GNOME (GTK 4)'
'gtk3: fallback if GTK 4 is not installed'
'gspell: for spell checking in chat (GTK 3)')
-checkdepends=('appstream-glib' 'desktop-file-utils' 'python-pytest-xvfb')
+checkdepends=('appstream-glib' 'desktop-file-utils' 'python-pytest')
provides=("${pkgname%-git}" 'nicotine+' 'nicotine')
conflicts=("${pkgname%-git}" 'nicotine+' 'nicotine')
source=('git+https://github.com/Nicotine-Plus/nicotine-plus.git')
@@ -36,18 +36,11 @@ build() {
check() {
cd "$srcdir/${pkgname%-git}"
- # Some tests require an X server
- _display=":70"
- Xvfb ${_display} -screen 0 1024x768x24 -ac -noreset & xpid=$!
- trap "kill -TERM $xpid || :" EXIT
- sleep 3
- export DISPLAY=${_display}
-
# Tests requiring an Internet connection are disabled
pytest --deselect=test/unit/test_version.py
- desktop-file-validate data/${_appdata_id}.desktop
- appstream-util validate-relax --nonet data/${_appdata_id}.appdata.xml
+ desktop-file-validate "data/${_appdata_id}.desktop"
+ appstream-util validate-relax --nonet "data/${_appdata_id}.appdata.xml"
}
package() {